LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-22-2008, 07:23 AM   #1
mathavi
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
How to enable rsh service in linux?


Hai i want to enable rsh service in my linux machine.
after that i want to connect from windows to linux.

i added rsh in /etc/securetty file.

then i added enable=no in /rsh file.

But i could not connect from windows to rsh.
It saying permission denied.cant establish connection.
 
Old 04-22-2008, 07:28 AM   #2
jf.argentino
Member
 
Registered: Apr 2008
Location: Toulon (France)
Distribution: FEDORA CORE
Posts: 493

Rep: Reputation: 50
Do you have installed the server part? Use your package manager to do so, and search for "rsh" or "rsh-server".
Once installed, be sure it will run automatically by properly configuring services
Generally, "ssh" is said to be more secure than "rsh".
 
Old 04-22-2008, 07:45 AM   #3
DotHQ
Member
 
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 545

Rep: Reputation: 33
Like jf said, you need to have rsh-server installed.

You also need a /etc/hosts.equiv file with the IP and username of the servers allowed to access your rsh service.

Once rsh-server is inplace you have to restart the inetd or xinetd service (depending on os version, new versions use xinetd)
the command is:
service xinetd restart

view the /var/log/messages file after you see the connection refused message. Usually it will give you a hint as to what the problem is.
ie:
tail /var/log/messages

----
Hi to jf. I have fond memories of Toulon France from many moons ago.

Last edited by DotHQ; 04-22-2008 at 07:47 AM.
 
Old 10-14-2012, 02:57 PM   #4
paz9
LQ Newbie
 
Registered: Jan 2009
Location: Philadelphia, PA
Distribution: Red Hat
Posts: 8

Rep: Reputation: 0
Talking All of the above + xinetd conf

FYI, I did all of the above and then some, no luck.
I am running CentOS 6.3 with xinetd, so rsh is a subservice of that.

Here is what I did that finally worked:

vi /etc/xinetd.conf

# Comment out the lines that say "enabled" like this:
# enabled = rsh

# Uncomment and add any junk after "disabled":
disabled = anyjunk

:x

/etc/init.d/xinetd restart
rsh myunsecuresystem pwd


I still cannot rsh localhost, but who cares?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rsh service not starting up sir-lancealot Linux - Server 6 12-27-2007 09:59 AM
Enable rsh dvong3 Linux - Networking 4 01-19-2006 12:27 AM
howto enable rsh in users a/c ? dogma Linux - Newbie 1 07-18-2003 02:58 PM
how do i enable rsh? srkherad Linux - General 1 11-01-2002 08:48 AM
rsh and rlogin service configuration romagnol Linux - General 1 06-28-2002 03:08 PM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration