LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2006, 03:29 PM   #1
DuracellUltra
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Rep: Reputation: 0
How to stop the window menu being displayed with Alt+RMB


Hi all,

So I thought I would give Linux a try and a couple of days ago installed Fedora Core 5 x86_64, I've done all the updates and installed Blender but when I Alt+RMB in Blender the window menu pops up.

Any help in disabling this feature so that Blender gets a chance to handle the Alt+RMB combination would be gratefully appreciated.

thanks in advance for any assistance.

Last edited by DuracellUltra; 07-12-2006 at 04:06 PM.
 
Old 07-12-2006, 05:38 PM   #2
DuracellUltra
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Talking

Huh, finally worked it out so for any other newbie getting caught here is some useful info (I hope)

The GNOME window manager is called Metacity. url wikipedia wiki Metacity
GNOME has a tool called GConf for storing application and desktop settings url en wikipedia org wiki GConf and url www gnome org projects gconf

GConf stores schemas in '/etc/gconf/schemas' and one of those schemas is called "metacity.schemas"
the first key in the schema is 'mouse_button_modifier', just what I was looking for!

Don't edit the schema file.

you can also find it by running 'gconf-editor' (Applications->System Tools->Configuration Editor) and navigating the tree to '/schemas/apps/metacity/general'

type 'man gconftool-2' and familiarize yourself with the tool.

type 'gconftool-2 --type string --set /schemas/apps/metacity/general/mouse_button_modifier ""'.

I don't know if just logging out will suffice but I logged out and restarted X11 like so:-

'Desktop->Log Out' and when the login screen is displayed 'Ctrl+Alt+Backspace' to restart X11.

Hope someone finds that helpful

ps: if you are wondering why the weird URLs, the site won't let me post any real ones yet.
sorry, gave up with trying to post half undertandable URLs

Last edited by DuracellUltra; 07-12-2006 at 05:40 PM.
 
Old 07-14-2006, 05:57 AM   #3
DuracellUltra
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Oops, looks like I found the long way round, the short route is

'Desktop->Preferences->Windows' and change the 'Movement' key.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Window border RMB event LzW-x General 0 06-11-2006 01:51 AM
The Grub Menu is not displayed notis Linux - General 3 03-07-2006 04:34 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 05:56 PM
K-Menu displayed in Konqueror? drj000 Linux - Software 0 12-05-2004 07:10 PM
How to disable alt+RMB? invicta Red Hat 1 03-23-2004 04:14 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration