LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2011, 09:43 AM   #1
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Rep: Reputation: 0
How do I log on as root without using 'su' when I'm in gnome GUI?


Using RHEL 5 the admin user is logged on and Gnome is open. I need to make a change to the /etc/security/limits.conf file using root but if I su to root the change does not stick. I've been told to log on as root without using 'su' but cannot find out how to do this?
 
Old 03-01-2011, 10:06 AM   #2
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,047

Rep: Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108
Please explain exactly what you mean by "the change does not stick."

I would recommend:

Code:
su -
nano /etc/security/limits.conf
exit
(You can substitute vi etc. for nano if you prefer.)

It is theoretically possible to log in to Gnome as root, but it is not designed to be easy as it is very poor security practice.
 
1 members found this post helpful.
Old 03-01-2011, 01:11 PM   #3
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
re '..not stick', after su - to root entered 'ulimit -c unlimited' then entered 'ulimit -a' and the change was displayed. Then went back to user account and entered 'ulimit -a' and the change was not shown.
 
Old 03-01-2011, 02:58 PM   #4
Kyle Lionheart
LQ Newbie
 
Registered: Nov 2006
Location: Italy
Distribution: Ubuntu, Debian
Posts: 21

Rep: Reputation: 2
You may have answered yourself in the first post here.

Quote:
Originally Posted by rgm6000 View Post
[...] I need to make a change to the /etc/security/limits.conf file using root [...]
I'd guess that ulimit as root changes the limits for root, so if you want to apply the change to a different user you'll have to manually edit limits.conf(and you can only do that as root). snowpine's instructions look fine to me
 
1 members found this post helpful.
Old 03-01-2011, 03:46 PM   #5
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
OK thanks.
Using ssh from my pc, I went to limit.conf as root and entered * soft core unlimited
logged off and logged on as root, entered 'ulimit -a' and got core file size (blocks,-c) unlimited, changed to another user and got core file size (blocks,-c) 0. What am I missing?
 
Old 03-01-2011, 08:51 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Let me explain it this way; you can interactively change those values FOR THE CURRENT SESSION by issuing those cmds at the cmd line.
To make them 'stick' you actually have to manually edit the file with vi /vim (substitute your editor of choice).
This is pretty much std for any cmd in Linux.

HTH
 
Old 03-02-2011, 07:31 AM   #7
Kyle Lionheart
LQ Newbie
 
Registered: Nov 2006
Location: Italy
Distribution: Ubuntu, Debian
Posts: 21

Rep: Reputation: 2
you changed the soft limit. What is the hard limit for *(and/or your specific user)? Soft limits cannot go above hard ones.
 
Old 03-02-2011, 08:08 AM   #8
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
A little background, I am making these changes on our production internet server. The reason I've been trying to make the change is to get more debug data because we have intermittent crashes on the application server on this system. I'm working with the application vendor and they recommended the change.

I've been using vi for all my edits. This server has only 1 user with logon privileges at present there are 3 settings in limits.conf:
* soft core unlimited
user1 soft nofile 20000
user1 hard nofile 49152
(Logged on as root the core file size shows 'unlimited', as user1 '0'.)

Since soft limits cannot go above hard, what additional setting do you think is needed?
My vendor only specified changing 'soft'
 
Old 03-02-2011, 09:12 AM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
A softlimit can be changed by a normal user up to the hard limit. The kernel enforces the soft limit. So you don't need to change the hard limit. The hard limit prevents a normal user from increasing a limit above a certain amount.
 
Old 03-03-2011, 05:30 AM   #10
Kyle Lionheart
LQ Newbie
 
Registered: Nov 2006
Location: Italy
Distribution: Ubuntu, Debian
Posts: 21

Rep: Reputation: 2
is there anything in /etc/security/limits.d/ that may override what you set in limits.conf? That's the only other thing I can think of right now.
 
Old 03-04-2011, 10:58 AM   #11
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
We do not seem to have a 'limits.d' file. I'm on this project part time so cannot get back to it until next week, at that time I'm planning to open a support case with Red Hat and I will post the outcome. Thanks to all for your assistance.
 
Old 03-25-2011, 10:11 AM   #12
rgm6000
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Red Hat solution:

Please run the following command as the non root user.# unlimit -c unlimited

Thanks to all for your support.
 
  


Reply

Tags
limits.conf, redhat, ulimit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Some application installation questions: log in as root or log in as 'user' & do 'su' Robert.Thompson Slackware 9 02-25-2011 09:19 AM
log in as Root in gui xtriggerx Linux - Newbie 4 02-01-2010 06:31 AM
log into the gui as root ronss SUSE / openSUSE 2 07-31-2007 01:44 PM
Can't log on as ROOT and go to GUI checho4 Mandriva 5 08-17-2005 06:58 PM
How to log in (root) without GUI thenewbster Mandriva 4 09-20-2003 04:44 PM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration