LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2016, 05:57 AM   #1
carryrain
LQ Newbie
 
Registered: Jul 2016
Posts: 2

Rep: Reputation: Disabled
How can I set it to monitor mode?


I try to change config Managed Mode to Monitor Mode
I use Linux OpenWrt 3.18.29 - BusyBox v1.23.2
The following is my wireless configuration
|------------------------------
|config wifi-device radio0
| option type ralink
| option ht 20
|
|config wifi-iface
| option device radio0
| option network lan
| option mode monitor
| option hidden 1
|------------------------------
The following is my network configuration
|-------------------------------------
|config interface 'loopback'
| option ifname 'lo'
| option proto 'static'
| option ipaddr '127.0.0.1'
| option netmask '255.0.0.0'
|
|config globals 'globals'
| option ula_prefix ''
|
|config interface 'lan'
| option ifname 'eth0.1'
| option force_link '1'
| option macaddr ''
| option type 'bridge'
| option proto 'static'
| option ipaddr '192.168.8.1'
| option netmask '255.255.255.0'
|
|config interface 'wan'
| option ifname 'radio0'
| option force_link '1'
| option macaddr ''
| option proto 'dhcp'
|--------------------------------------
when i use 'iw reg get', i can see the changed mode
|------------------------------------------------------------------
|root@OpenWrt:/etc/config# iw reg get
|global
|country 00: DFS-UNSET
| (2402 - 2472 @ 40), (6, 20), (N/A)
| (2457 - 2482 @ 40), (6, 20), (N/A), PASSIVE-SCAN
| (2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
| (5170 - 5250 @ 160), (6, 20), (N/A), PASSIVE-SCAN
| (5250 - 5330 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
| (5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
|------------------------------------------------------------------
but, when i use 'iwconfig', it was not changed
|-------------------------------------------------
|ra0 RTWIFI SoftAP ESSID:"WRTnode1A7C"
| Mode:Managed Channel=11 Access Point:
|-------------------------------------------------

How can I set it to monitor mode?

***
I had download package from the following site:
#1.
https://github.com/openwrt-mirror/openwrt
I had used the following commands:
git clone https://github.com/openwrt-mirror/openwrt.git
(i fixed the url)
and then I did make menuconfig
#2. I tried the following link, too.
https://github.com/wrtnode-sdk/openwrt
But the same result.
After setting menuconfig, "make V=s" has been done.
I don't know what to look at further.
cf)
Menuconfig
Language - Lua - libwiinfo-lua
Libraries - libiw
Libraries - libiwinfo
Network - iw
Utilities - iwcap
Utilities - iwcap
with defalut config
 
Old 07-08-2016, 06:14 AM   #2
carryrain
LQ Newbie
 
Registered: Jul 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
add ***

I had download package from the following site:
#1.
https://github.com/openwrt-mirror/openwrt
I had used the following commands:
git clone https://github.com/openwrt-mirror/openwrt.git
(i fixed the url)
and then I did make menuconfig
#2. I tried the following link, too.
https://github.com/wrtnode-sdk/openwrt
But the same result.
After setting menuconfig, "make V=s" has been done.
I don't know what to look at further.
cf)
Menuconfig
Language - Lua - libwiinfo-lua
Libraries - libiw
Libraries - libiwinfo
Network - iw
Utilities - iwcap
Utilities - iwcap
with defalut config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error message trying to set monitor mode kryyp Linux - Newbie 2 07-29-2015 11:27 AM
Cant' Set to Mode Monitor mr_pink_eyes Linux - Wireless Networking 2 06-08-2007 11:54 AM
iwconfig mode monitor Error: "Set Mode" (8B06) WOP1337 Linux - Wireless Networking 2 04-03-2007 09:13 AM
ipw2100 could not set monitor mode ErikZ Linux - Wireless Networking 8 05-11-2005 06:34 AM
Need help for set up monitor mode with Prism 1 inthefuture Linux - Wireless Networking 7 06-21-2004 10:43 PM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration