LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-13-2009, 01:23 PM   #1
alelb22
LQ Newbie
 
Registered: May 2009
Location: Argentina, South America
Distribution: Slackware 12.2
Posts: 17

Rep: Reputation: 0
Help: NTFS and Slackware 12.2


SOLVED, SORRY


First, thanks for reading this.

I'm dual booting XP and SW on a Sata disk..
The partitions of that disk are (in XP):
C:\ for Windows
D:\ for files
And the linux partitions (Swap and Ext3)...

I have an IDE disk with files too (Music, videos, etc..)
I can see the files in the C and D drives, but i can not access the IDE partition (I have only one in that disk) (I'm using SW NOW, not XP)


This is the original fstab: (when i installed SW)
/dev/sda6 swap swap defaults 0 0
/dev/sda7 / ext3 defaults 1 1
/dev/sda1 /ntfc-c ntfs-3g umask=000 1 0
/dev/sda5 /ntfc-d vfat defaults 1 0
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0

This is the one I am using now. With this i can acces C & D:
/dev/sda6 swap swap defaults 0 0
/dev/sda7 / ext3 defaults 1 1
/dev/sda1 /ntfc-c ntfs-3g umask=000 1 0
/dev/sda5 /ntfc-d ntfs-3g umask=000 1 0
/dev/hda5 /ntfc-e ntfs-3g umask=000 1 0
#/dev/sda5 /ntfc-d vfat defaults 1 0
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0

/dev/sda1 /mnt/windows ntfs-3g defaults 0 0


HDA5 was added only to test... is not working ^^


I have also tryed with:

ntfs-3g /dev/hda5 /mnt/win
ntfs-3g-mount: failed to access mountpoint /mnt/win: No such file or directory


Using fdisk -l

Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf92bf92b

Device Boot Start End Blocks Id System
/dev/hda1 2 10011 80405325 f W95 Ext'd (LBA)
/dev/hda5 2 10011 80405293+ 7 HPFS/NTFS

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9e0e9e0e

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1912 15358108+ 7 HPFS/NTFS
/dev/sda2 1913 9729 62790052+ f W95 Ext'd (LBA)
/dev/sda5 1913 8414 52227283+ 7 HPFS/NTFS
/dev/sda6 8415 8536 979933+ 82 Linux swap
/dev/sda7 8537 9729 9582741 83 Linux

Disk /dev/sdb: 4126 MB, 4126146560 bytes
16 heads, 32 sectors/track, 15740 cylinders
Units = cylinders of 512 * 512 = 262144 bytes
Disk identifier: 0x051570d6

Device Boot Start End Blocks Id System
/dev/sdb1 1 15740 4029424 c W95 FAT32 (LBA)




Sorry for to things:
Asking noob questions like this.. i wansn't able to find anything that worked here..
My bad ensligh, i think i need more practice =P

If you need more info ask and i will reply as faster as i can...





_______________________
EDIT:

I only needed to do this:
mkdir /mnt/ntfs
mount -t ntfs /dev/hda5 /mnt/ntfs


Sorry for creating this thread

Last edited by alelb22; 05-13-2009 at 01:28 PM.
 
Old 05-13-2009, 03:26 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.15.5
Posts: 1,527
Blog Entries: 12

Rep: Reputation: 170Reputation: 170
You are much better off using ntfs-3g like this: mount -t ntfs-3g /dev/hda5 /mnt/ntfs
 
Old 05-13-2009, 11:00 PM   #3
alelb22
LQ Newbie
 
Registered: May 2009
Location: Argentina, South America
Distribution: Slackware 12.2
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks for your comment..
Why is that way better?
Every time i reboot the PC I have to do that, so, how can i avoid retyping it?

And another question:
I've read that writing in NTFS partitions from Linux is unsafe because it may corrupt the partition data. Is that true with this version of Slackware? (12.2)

Last edited by alelb22; 05-14-2009 at 12:16 AM.
 
Old 05-14-2009, 12:22 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
If you use ntfs-3g package then it could as be safe for use. I never had problems till date. (Touch wood).
 
Old 05-14-2009, 12:27 AM   #5
alelb22
LQ Newbie
 
Registered: May 2009
Location: Argentina, South America
Distribution: Slackware 12.2
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks!
And what should I do to make that every time the OS loads that partition is mounted?
 
Old 05-14-2009, 12:38 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Edit the fstab file as super user and add the entry there.
But make sure you install the ntfs-3g package before.

Code:
/dev/sda5   /mnt/ntfs   ntfs-3g   defaults   0    0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS 3G in slackware 12.0 not functioning? ic_torres Linux - Newbie 3 10-15-2007 08:44 PM
Problems on using XP (NTFS) and SlackWare 9 Judac Slackware 1 06-15-2004 01:47 AM
ntfs mounting in slackware littlenicky Slackware 4 10-22-2003 01:31 AM
use NTFS system in slackware 9 proder Linux - Hardware 2 05-11-2003 02:24 AM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration