LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-20-2004, 05:49 PM   #1
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Rep: Reputation: 15
Help Me! Kernel Problem


I use apt-get install kernel-image-2.4.26-1-686 and after I rebooted, I got the lovley message "Kernel Panic: VFS: Unable to Mount root fs on 03:01"
I looked through the start and 1 mager thing is missing, the IDE control is not getting loaded.

So how do If fix this.
 
Old 06-20-2004, 06:12 PM   #2
fenderman11111
Member
 
Registered: Jun 2004
Location: Denton
Distribution: debian, freebsd
Posts: 121

Rep: Reputation: 15
this most likely means that the kernel cannot find the initrd file. this is a root fs image that the kernel mounts as a type virtual file system for boot purposes(hence 'type vfs'). you should try getting a rescue disk and booting into your system. If you use lilo you need to edit /etc/lilo.conf and add the line 'initrd=/initrd.img' or wherever the image is located. oh, and make sure the file _exists_.
 
Old 06-20-2004, 06:19 PM   #3
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
ok heres what lilo says

image=/vmlinuz
label=Linux
read-only
# restricted
# alias=1

so where does that 'initrd=/initrd.img' go in here

that file is under the root file system (/)
 
Old 06-20-2004, 06:29 PM   #4
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Rep: Reputation: 15
you can put it below the 'image = /vmlinuz' line :

Code:
image=/vmlinuz
initrd=/initrd.img
label=Linux
read-only
 
Old 06-20-2004, 06:41 PM   #5
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Ok I entered that and it did the same thing as before ??

Now what can I try ?

Any help would be very nice.
 
Old 06-21-2004, 03:00 AM   #6
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
bump
 
Old 06-21-2004, 03:43 AM   #7
praveen_2003
Member
 
Registered: Apr 2003
Location: india
Posts: 144

Rep: Reputation: 15
i suppose u must have missed out some file system in the configuration while making a manual configuration in the make menu config ...hope fully
 
Old 06-21-2004, 04:51 AM   #8
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Rep: Reputation: 15
I'm sorry, I don't know much about how debian manages things. The only thing I can ask is whether or not you entered the root='/dev/your_root_drive' correctly in the lilo.conf. The root option should point to the disk partition where your '/' directory is installed. Here an example from my lilo.conf

Code:
image = /boot/vmlinuz-2.6.7
  root = /dev/hda7
  label = Slack
  read-only
 
Old 06-22-2004, 02:05 AM   #9
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
In responce to praveen_2003

I got a precompiled kernel from one of the debian mirror site so I didn't have to configure them.


In responce to usercsr

My root partion is /dev/hda1
 
Old 06-22-2004, 12:50 PM   #10
OneManArmy
Member
 
Registered: Apr 2004
Location: Motherboard
Distribution: Debian GNU/Linux
Posts: 156

Rep: Reputation: 30
Hello there,
I had the exact problem before but fortunately a friend of mine is a debian
developer so he solved it on the fly.
As for as I remember, the problem was with the initrd.And thats what one
of the previous replies suggested.
u need to add the initrd line to ur lilo. However, that line should be pointing
to the initrd location in ur file system. so in order to create that initrd u need
to use the command make-kpkg with the --initrd option which generates the
necessary file which u need to refrence in the lilo.
U can read through the man page of "make-kpkg" and how to use the --initrd
option.

Here is where my initrd is located in /
lrwxrwxrwx 1 root root 27 Jun 6 05:02 initrd.img -> boot/initrd.img-2.6.6-1-686

so as u c what means by initrd=/initrd.img line in the lilo ,is that it is pointing to that
symbolic link which in turn points to the location of the actual initrd (the one u should
get form make-kpkg). And if I understand well u can even replace that initrd=/initrd.img
by initrd=/location_of_generated_initrd. creatin a symbolic link is just a fancy thing I think.

I am completely new to linux and thats all I remembered from that kernel panic
problem I had. I hope it helps. ah, and dont 4get to type "lilo" after editin and
saving lilo.conf

Last edited by OneManArmy; 06-22-2004 at 01:00 PM.
 
Old 06-26-2004, 05:04 AM   #11
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
I got it to boot the kernel in the weirdest way (as I see it) I added the old kernel to the lilo.conf file and it booted the new kernel all the way but it didnt load my network card. So am I missing something or is my kernel lacking the support for that card??
 
Old 06-26-2004, 08:41 AM   #12
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
if ti failed bringing up interface eth0 this is normal, mine fails it all the time and networks just fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing module in Fedora Core 2 (2.6 kernel vs 2.4 problem?) Arodef Linux - Kernel 3 11-30-2007 02:55 PM
kernel 2.6.9 Kernel panic problem salahuddin_66 Slackware 2 08-11-2007 03:17 AM
Kernel panic problem with all of my kernels after installing new kernel nosebleed Linux - Software 2 04-14-2006 09:48 PM
Problem booting up new kernel. Kernel panic error... RHLinuxGUY Red Hat 2 04-11-2004 04:59 AM
Linux Kernel Problem -- Kernel panic: CPU context corrupt crcooney Linux - Distributions 0 01-15-2004 08:48 AM


All times are GMT -5. The time now is 01:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration