LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2008, 05:04 PM   #1
yzhong
Member
 
Registered: Jun 2007
Location: sydney
Distribution: redhat , ubuntu, centos
Posts: 56

Rep: Reputation: 16
Help. can't start up with centos 5.0


Need to quick fix a centos 5.0 system to make it boot
The problem is when boot this system,
1.press F12 enter boot menu
2.choose boot from internal disk
3.screen appear "GRUB" and then stop (not GRUB>)

I try to do the following things
1.put this disk on another redhat system and mount it, seems no problem for this disk.
2.boot from a centos live CD( centos have 6 CD + 1 live CD)
3.screen appear boot> , enter linux rescue
(I did on another redhat system before,on # run chroot /mnt/sysimage , grub-install...)
but seems centos is another story.
It boots and enter a GUI interface for user centos( not root), when I open a terminal, it's $ (what's the default root passwd?).
I find the previous /dev/sda2 is on /mnt/lvm/vgroup/vg but /mnt/lvm/vgroup/vg/boot is empty, also can't find where is previous /dev/sda1 located.

I think reinstall the grub, system should be fine, but on this case , how to do that, or do you come with any other idea?

Thanks in advance

Last edited by yzhong; 12-03-2008 at 07:06 PM.
 
Old 12-03-2008, 09:03 PM   #2
tuxtutor
LQ Newbie
 
Registered: Dec 2008
Distribution: Solaris, CentOS
Posts: 4

Rep: Reputation: 0
Here are the steps to reinstalling GRUB might help.

-Boot your rescue or install CD
-Choose -Rescue installed system or boot with "linux rescue"

Code:
chroot /mnt/sysimage
grub-install /dev/hda use /dev/sda for sata
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH Won't Start on CentOS Linux SystemOverload Linux - Server 4 11-11-2007 04:36 PM
how to start apache2 on centOS 4 entz Linux - Server 2 04-27-2007 07:29 PM
[centos] start/shutdown errors pcandpc Linux - Distributions 1 04-27-2007 10:55 AM
msyql service won't start on CentOS 4.4 dbyy Linux - Server 10 04-14-2007 03:25 AM
start LDAP on CENTOS! mumux Linux - Software 5 08-10-2005 07:00 PM


All times are GMT -5. The time now is 08:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration