LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2003, 05:57 PM   #1
MightyKC
Member
 
Registered: Feb 2003
Distribution: Ubuntu 7.10
Posts: 47

Rep: Reputation: 15
hdparm/dma


I am trying to enable dma on /dev/hdd.
I found a few threads that said that I will need to add a line to /etc/modules.conf file. Will the line be: options hdd dma=1 ?
I have no idea how to do this. I figured out how to change it from 16 bit to 32 bit though. hdd is a partition on my hard drive right? It wouldn't be a hard drive problem would it? It is an 80 gb two year old drive.
 
Old 06-29-2003, 06:09 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
what said you want to edit modules.conf? shouldn't need to at all.

just use hdparm directly.

hdparm -k 1 -d 1 /dev/hda

-d = dma -k = keep settings on reboot

hdd would be your secondary slave drive, so that will be unlikely to be correct.
 
Old 06-29-2003, 06:21 PM   #3
MightyKC
Member
 
Registered: Feb 2003
Distribution: Ubuntu 7.10
Posts: 47

Original Poster
Rep: Reputation: 15
hda is already in 32 bit mode with dma turned on
when I do:
hdparm -d1 /dev/hdd

I get:
setting using_dma to 1 (on)
HDIO_set_dma failedperation not permitted
Using _dma =0 (off)


However, this is good right, because if hda is 32 bit dma enabled then it is not a hardware problem, right?
 
Old 06-29-2003, 06:23 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you're not root i guess.... it'd be a very strange world if a normal user can enable dma on a drive...
 
Old 06-29-2003, 06:30 PM   #5
MightyKC
Member
 
Registered: Feb 2003
Distribution: Ubuntu 7.10
Posts: 47

Original Poster
Rep: Reputation: 15
no no,,,, that is logged out as normal user and logged in as root
 
Old 07-01-2003, 06:23 AM   #6
MightyKC
Member
 
Registered: Feb 2003
Distribution: Ubuntu 7.10
Posts: 47

Original Poster
Rep: Reputation: 15
O.K. hdd is not a partition of the hard drive. hdd is the dvd player. The line I needed to add to /etc/modules.conf is:
options hdc-cd dma=1

I figured out how to do this on my own.
But, when I did it my -Tt score went from 13.36MB/sec to 1.67MB/sec to INPUT/OUTPUT error. Then I tried xine again and it still plays(poorly) If I have got the thing so scrambled that it can't test itself how does it still play. I tried removing the line. xine-check says I have dma problems again. What is this input output error. How do I correct this?
 
Old 08-19-2003, 12:00 AM   #7
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Did you ever fix this because I'm exactly where you were at when you posted and no one's helping me.
 
Old 08-19-2003, 09:43 AM   #8
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Maybe DMA is not enabled in your kernel. I seem to recall some chipsets (especially VIA) need a special compile flag. Maybe:

CONFIG_BLK_DEV_VIA82CXXX=y

I think I was caught by this compiling kernel 2.4.21 on a VIA KT setup. There are also a bunch of flags affected DMA directly. I have

CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_IDEDMA_PCI_AUTO=y
CONFIG_BLK_DEV_IDEDMA=y
CONFIG_IDEDMA_AUTO=y

Sorry if that is a bit vague. If you google 'HDIO_set_dma failed' you will see this is a not uncommon gotcha. Maybe there is some boot parameter to fix things??? Otherwise you probably have to recompile the kernel. Where did you get your kernel in the first place?

Later: the VIA82CXXX support is also available as a module, so you might be able to modprobe it: 'modprobe via82cxxx', if you think that might be the problem.

Last edited by maroonbaboon; 08-19-2003 at 09:57 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hdparm can't enable dma with ich6m rob666 Linux - Hardware 5 09-05-2005 06:00 PM
turning DMA on with hdparm geniarse Linux - Hardware 4 09-09-2004 04:47 PM
Kernel 2.6.5, hdparm dma, and AK72 linuxbeak Linux - Hardware 2 05-04-2004 10:19 AM
Enabling DMA with no hdparm ? SML Fedora 1 02-22-2004 04:52 PM
Enabling DMA with no hdparm SML Red Hat 1 02-22-2004 04:46 PM


All times are GMT -5. The time now is 03:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration