LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2015, 08:01 PM   #1
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Rep: Reputation: Disabled
HDMI Audio Not Working


I have just switched over from DVI to HDMI on a new monitor. I would like to feed the audio out over HDMI. Currently I get no audio over HDMI. Is there a setting to enable this? I am running Debian Wheezy with XFCE.
 
Old 01-12-2015, 01:07 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,499

Rep: Reputation: 193Reputation: 193
Install the PulseAudio Volume Control if it's not already installed:

# apt-get install pavucontrol

Open the application and go to the "Configuration" tab. You usually see two drop down menu buttons for "Profile", one for built-in audio, analog and the other for "High Definition Audio Controller". The later is the one you usually need to fool around with to activate sound over hdmi. To completely have all sound through hdmi, try selecting "Digital Stereo(HDMI) Output" in the High Definition Audio Controller Profile and selecting "Off" for the analog profile.
Also, double check and make sure that sound over hdmi is supported in linux for your graphics card.

Last edited by kilgoretrout; 01-12-2015 at 01:13 PM.
 
Old 01-12-2015, 01:31 PM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You will also need a .asoundrc file withe hdmi set as default.
 
Old 01-24-2015, 08:03 PM   #4
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thank you for the reply! I installed pavucontrol and then launched it. Upon doing so, I was presented with an error. The error is detailed in the screen capture but it basically says that the connection to PulseAudio failed. I am not an experienced Linux user but I do recall that there is an alternative sound driver (?) Alsa. Could that be my issue? If so, how do I configure which to use? Any thoughts?

In regards to the .asoundrc file. Should this be located in my home folder? I have no such file currently.
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	7
Size:	37.7 KB
ID:	17434  
 
Old 01-24-2015, 08:06 PM   #5
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Possibly related to the HDMI issue I just noticed something odd... most menus appear fine however some application menus have text so small that it is unreadable. Examples attached.
Attached Thumbnails
Click image for larger version

Name:	Small.JPG
Views:	16
Size:	29.2 KB
ID:	17435   Click image for larger version

Name:	Normal.JPG
Views:	16
Size:	39.3 KB
ID:	17436  
 
Old 01-25-2015, 11:39 AM   #6
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
What sound card do you have?
Code:
aplay -l
If you have a new sound card then you'll probably have to install its appropriate drivers with apt-get install.

Once you have your sound card name do a quick search for it on the net with debian and ubuntu added.
If there are any known problems, then there should be solutions.
The ubuntu sites are helpful in my experience.

My radeon hdmi card gave me a few problems - but they were eventually sorted.
 
Old 01-25-2015, 12:05 PM   #7
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks! Below is the output of aplay. I am off and searching on ALC887...

Quote:
**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 01-25-2015, 01:35 PM   #8
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Quote:
Originally Posted by jorsborn View Post
Thanks! Below is the output of aplay. I am off and searching on ALC887...
You might have found this link yourself:
Some guy has got sound working on the same card using debian.
http://forums.debian.net/viewtopic.php?t=59680

Looks like you'll be busy.
 
Old 01-25-2015, 02:05 PM   #9
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
I had not stumbled on that one... thank you! I have compiled, installed and rebooted. Inside the mixer application is a list of controls (front mic, line in, surround, etc.). The only applicable control that I can see is IEC958. I have that enabled... though unlike other controls that have a level associated with it, the IEC958 does not.

Next I tried making a .asoundrc file in my home directory. I added...

Code:
pcm.!default {
	type hw
	card 0
}

ctl.!default {
	type hw           
	card 0
}
... though I don't know what good that does since I only have one card. Regardless, it doesn't seem to have had an effect on anything.
 
Old 01-25-2015, 02:37 PM   #10
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Quote:
Originally Posted by jorsborn View Post
I had not stumbled on that one... thank you! I have compiled, installed and rebooted. Inside the mixer application is a list of controls (front mic, line in, surround, etc.). The only applicable control that I can see is IEC958. I have that enabled... though unlike other controls that have a level associated with it, the IEC958 does not.
Go to Configuration on Pavucontrol.
There should be two 'Profile' fields.
The top profile should have your sound card as output. Select it.

Now on your desktop, find system settings for sound. Select your hdmi sound card.
Do this while playing sound in the background.

Code:
Next I tried making a .asoundrc file in my home directory. I added...
If it doesn't work then delete it. That's what I had to do.
 
Old 01-25-2015, 02:39 PM   #11
jorsborn
LQ Newbie
 
Registered: Jan 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hmmm.... confused. Isn't pavucontrol for pulse audio? I am using alsa. I get the same error when I launch pavucontrol (see my 2nd post for screenshot).
 
Old 01-25-2015, 03:18 PM   #12
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Quote:
Originally Posted by jorsborn View Post
Hmmm.... confused. Isn't pavucontrol for pulse audio? I am using alsa. I get the same error when I launch pavucontrol (see my 2nd post for screenshot).
Pulse Audio Volume Control is PAVuControl.
It's called pavucontrol on the command line. Sorry, I should've said pulse audio.

Ensure nothing is muted on alsa and that it can see your sound card when you press F6. Increase the sound settings with the 'up' arrow on your keyboard.
I eventually got sound on one OS when I made the correct setting on pulse audio.
 
Old 01-25-2015, 05:14 PM   #13
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Your asoundrc needs to list the hda as default, when I gat home tonight I will post mine so you have an example that you can copy & edit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SOLVED - HDMI Audio working with nVidia Ion Nouveau driver Flymo Linux - Hardware 0 09-27-2013 09:45 PM
HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) felipefv Linux - Hardware 8 02-06-2012 09:47 AM
Ubuntu 11.10 HDMI not working for Audio and Video sbauer72 Ubuntu 5 01-01-2012 12:49 PM
HDMI audio not working maheshsub00 Ubuntu 1 02-10-2010 03:43 PM
HDMI Audio not working with ASUS M3N78-EM Spectre5 Linux - Software 6 05-25-2009 10:19 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration