LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2015, 12:03 AM   #1
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 140

Rep: Reputation: 15
HDMI and sound optical output not working


I just installed Debian 8 on a new ASUS z87-a and most things work fine right out of the box. However even though DVI and regular sound output work fine, I tried the HDMI connection but I have no sound and the image is just a blue screen. I tried also the sound optical output and got no sound either. Is there some special drivers that need to be installed for HDMI and SPDIF to work?
 
Old 05-17-2015, 01:28 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
http://www.linuxquestions.org/questi...ta-4175541104/
 
Old 05-17-2015, 07:23 AM   #3
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 140

Original Poster
Rep: Reputation: 15
not sure I understand what I have to do

parents@pc8:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevices #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 0 [HDMI 1]
Subdevices: 1/1
Subdevices #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevices #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC892 Analog [ALC892 Digital]
Subdevices: 1/1
Subdevices #0: subdevice #0

I am a beginner in Linux... what exactly do I have to do to make work HDMI and optical output for sound?
 
Old 05-17-2015, 11:14 AM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You obviously have 2 hdmi ports, there are 2 listed. Choose 1 either {card0 device3} or {card 0device 7}. Did you see my .asoundrc file? Copy & edit it. it goes in your home directory.
 
Old 05-18-2015, 12:15 PM   #5
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 140

Original Poster
Rep: Reputation: 15
I tried all possible combinations but didn't work. However when I checked with aplay -L (capital "L") I noticed that the optical output was listed

iec958:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Digital
IEC958 (S/PDIF) Digital Audio Output

this was the only place where I found S/PDIF referrred to.. I would prefer to use this optical output but how to do it? any new ideas?
 
Old 05-18-2015, 01:59 PM   #6
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 140

Original Poster
Rep: Reputation: 15
HERE IS A COMPLETE LIST of devices from aplay -L command

root@pc8:~# aplay -L
No protocol specified
xcb_connection_has_error() returned true
No protocol specified
xcb_connection_has_error() returned true
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
hdmi:CARD=HDMI,DEV=0
HDA Intel HDMI, HDMI 0
HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
HDA Intel HDMI, HDMI 1
HDMI Audio Output
dmix:CARD=HDMI,DEV=3
HDA Intel HDMI, HDMI 0
Direct sample mixing device
dmix:CARD=HDMI,DEV=7
HDA Intel HDMI, HDMI 1
Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
HDA Intel HDMI, HDMI 0
Direct sample snooping device
dsnoop:CARD=HDMI,DEV=7
HDA Intel HDMI, HDMI 1
Direct sample snooping device
hw:CARD=HDMI,DEV=3
HDA Intel HDMI, HDMI 0
Direct hardware device without any conversions
hw:CARD=HDMI,DEV=7
HDA Intel HDMI, HDMI 1
Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
HDA Intel HDMI, HDMI 0
Hardware device with all software conversions
plughw:CARD=HDMI,DEV=7
HDA Intel HDMI, HDMI 1
Hardware device with all software conversions
default:CARD=PCH
HDA Intel PCH, ALC892 Analog
Default Audio Device
sysdefault:CARD=PCH
HDA Intel PCH, ALC892 Analog
Default Audio Device
front:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
Front speakers
surround21:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
Direct sample mixing device
dmix:CARD=PCH,DEV=1
HDA Intel PCH, ALC892 Digital
Direct sample mixing device
dsnoop:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
Direct sample snooping device
dsnoop:CARD=PCH,DEV=1
HDA Intel PCH, ALC892 Digital
Direct sample snooping device
hw:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
Direct hardware device without any conversions
hw:CARD=PCH,DEV=1
HDA Intel PCH, ALC892 Digital
Direct hardware device without any conversions
plughw:CARD=PCH,DEV=0
HDA Intel PCH, ALC892 Analog
Hardware device with all software conversions
plughw:CARD=PCH,DEV=1
HDA Intel PCH, ALC892 Digital
Hardware device with all software conversions
 
Old 05-18-2015, 02:08 PM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I thought you were working on hdmi
Spdif should be listed in Sound Settings, just select from there.
 
Old 05-18-2015, 03:26 PM   #8
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 140

Original Poster
Rep: Reputation: 15
Weird thing... When I got back into Multimedia/Sound settings and fiddle a little bit it made optical sound then also later HDMI sound (also after the video worked in HDMI). I even deleted the .asoundrc file and it still works fine. Thanks for your help and time spent on this
 
Old 05-18-2015, 09:57 PM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Great glad you got it working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HDMI output won't transmit sound baronobeefdip Linux - Hardware 11 03-13-2014 01:34 PM
Switching sound to HDMI output narz Linux - General 3 12-29-2013 10:21 PM
HDMI output is not working DVI1 I think PeterUK Ubuntu 15 05-06-2013 09:53 AM
no sound output ati hdmi Grub3r Linux - Laptop and Netbook 3 02-14-2011 07:56 PM
How to get the TOSLINK (Optical) sound output working? MegaSvensk Linux - Newbie 14 09-24-2007 02:22 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration