LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-06-2010, 07:32 AM   #1
nwtlnxqstns
LQ Newbie
 
Registered: Nov 2007
Posts: 26

Rep: Reputation: 15
grub2 ./configure error


Hi,

I have mandriva 2007 install on my desktop. I tried to update to grub2. When I run the ./configure I got the following error message. THanks.

This script, last modified 2009-06-10, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

http://git.savannah.gnu.org/gitweb/?....guess;hb=HEAD
and
http://git.savannah.gnu.org/gitweb/?...ig.sub;hb=HEAD

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-06-10

uname -m = i686
uname -r = 2.6.17-13mdvlegacy
uname -s = Linux
uname -v = #1 SMP Fri Mar 23 19:05:24 UTC 2007

/usr/bin/uname -p =
/bin/uname -X =

hostinfo =
/bin/universe =
/usr/bin/arch -k =
/bin/arch = i686
/usr/bin/oslevel =
/usr/convex/getsysinfo =

UNAME_MACHINE = i686
UNAME_RELEASE = 2.6.17-13mdvlegacy
UNAME_SYSTEM = Linux
UNAME_VERSION = #1 SMP Fri Mar 23 19:05:24 UTC 2007
configure: error: cannot guess build type; you must specify one


###############################################

output from config-guess


./config.guess: unable to guess system type

This script, last modified 2009-06-10, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

http://git.savannah.gnu.org/gitweb/?....guess;hb=HEAD
and
http://git.savannah.gnu.org/gitweb/?...ig.sub;hb=HEAD

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-06-10

uname -m = i686
uname -r = 2.6.17-13mdvlegacy
uname -s = Linux
uname -v = #1 SMP Fri Mar 23 19:05:24 UTC 2007

/usr/bin/uname -p =
/bin/uname -X =

hostinfo =
/bin/universe =
/usr/bin/arch -k =
/bin/arch = i686
/usr/bin/oslevel =
/usr/convex/getsysinfo =

UNAME_MACHINE = i686
UNAME_RELEASE = 2.6.17-13mdvlegacy
UNAME_SYSTEM = Linux
UNAME_VERSION = #1 SMP Fri Mar 23 19:05:24 UTC 2007
 
Old 07-07-2010, 04:59 PM   #2
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Just a long shot. Linux after kernel 2.6.28 (about 2009) started to detect hard disks by libATA. Your 2007 Mandriva with a 2.6.17 kernel is really too old for Grub2. It is possible Grub2 may depend on newer components unavailable from your old kernel.

How about installing the new Mandriva 2010 RC2 which has a 2.6.33 kernel.

Alternatively you can stick with Grub1 which can do everything Grub2 can except booting beyond 1.3TB position of a hard disk and the ability to cope with hard disks partitioned by the gpt scheme.
 
Old 07-07-2010, 07:57 PM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
I no longer use MDV but try this

http://mirror.internode.on.net/pub/m...009.1.i586.rpm

2) did you try to compile using install instructions in file?
ftp://alpha.gnu.org/gnu/grub/grub-1.98.tar.gz
 
Old 07-07-2010, 08:41 PM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
Created a RPM- and YUM-based version of this script that should work with Mandriva and build Kernel 2.6.35:

http://5ykx2q.bay.livefilestore.com/...ownload&psid=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB Read Error After Upgrade to grub2 linuxpyro Linux - Software 4 03-29-2010 09:00 PM
Grub2 - Error 15 telestrial Linux - Software 13 03-11-2010 06:26 PM
error with grub2 mierdatuti Ubuntu 1 02-10-2010 10:36 AM
Grub2 (grub-1.96) ERROR: NOT AN ASSIGNMENT ssenuta Linux - General 7 09-02-2009 08:15 AM
Error 18 when trying to boot with GRUB or GRUB2 DaneM Linux - Software 6 09-20-2005 02:45 PM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration