LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2015, 07:17 AM   #1
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
gedit not opening from terminal - not authenticated


I have just installed a new debian OS and want to change a file.
For some reason, gedit didn't come pre-packaged so I installed it with apt-get.

When I use a terminal as root, gedit won't open. I get the following error message:
Code:
gedit grub
(gedit:3679): EggSMClient-WARNING **: Failed to connect to the session 
manager: Authentication Rejected, reason : None of the authentication
protocols specified are supported and host-based authentication 
failed
Gedit will open page files on the desktop - but not on the terminal.
Is this because I haven't done something with the new install or should I remove gedit and reinstall?
 
Old 01-14-2015, 07:22 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Did you try:
Code:
gksu gedit
 
Old 01-14-2015, 07:44 AM   #3
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by brianL View Post
Did you try:
gksu gedit
It's funny but both 'gksu' and 'gksudo' aren't recognised as commands:
Code:
gksu gedit grub
bash: gksu: command not found
gksudo gedit grub
bash: gksudo: command not found
I'm using xfce GUI - I hope that doesn't have anything to do with it.
On a different debian install, I think gksudo tends to work.
 
Old 01-14-2015, 08:00 AM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Quote:
I'm using xfce GUI - I hope that doesn't have anything to do with it.
I believe the default file manager in xfce is thunar and the default text editor is leafpad or mousepad. There should be several text editors available and you should be able to find them from from your Debian menu under editors or text editors. Something is amiss though if you correctly installed gedit and it won't open files. You might try one of the other text editors to ensure that it is just gedit. I don't use Debian so can't really be much help.

Some alternative options at the Debian forums, link below. Scroll down to the post by user kedaha which shows the same error message you posted and several options to get around it.

http://forums.debian.net/viewtopic.php?f=17&t=105850

Last edited by yancek; 01-14-2015 at 08:48 AM. Reason: Add link
 
1 members found this post helpful.
Old 01-14-2015, 08:00 AM   #5
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Try (as root, of course):
Code:
apt-get install gksu
I think it should work in xfce.

Last edited by brianL; 01-14-2015 at 08:07 AM.
 
Old 01-14-2015, 10:32 AM   #6
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by yancek View Post
I believe the default file manager in xfce is thunar and the default text editor is leafpad or mousepad.
Some alternative options at the Debian forums, link below. Scroll down to the post by user kedaha which shows the same error message you posted and several options to get around it.
I used mousepad for the text editor as root. But it told me not to make changes to source with the text editor.
So I switched to user and and opened mousepad. But it wouldn't allow me to make changes - probably because I don't have permission!

This has been useful.
I found you need to enter root with
Code:
su -
The hyphen is important.
After that you can use gedit to make changes to files:
Code:
gedit <filename>
This is unconventional and I'm sure I'll forget it soon!
 
Old 01-14-2015, 10:36 AM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by brianL View Post
Try (as root, of course):
apt-get install gksu
I think it should work in xfce.
I installed gksu and was surprised it wasn't installed already.
However, I still got an error message with gksu.
I eventually used the archaic vi editor after several attempts.
But I think the 'su -' command will allow you to open gedit without problems.
 
Old 01-14-2015, 09:55 PM   #8
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
Great it works. A thought though, on the GUI what applications are used is often dictated by the enteries in the 'main menu' "app", make sure gedit is ticked to use it via gksu or gksudo -the two are different and relate to if you installed with a separate root password or used sudo.

Fred.

nano text editor is probably accessable and lot easier to use than vi.

Last edited by Fred Caro; 01-14-2015 at 09:58 PM. Reason: add extra coment
 
Old 01-15-2015, 01:41 PM   #9
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
If you want to edit system files you need to log in as root and that applies to pretty much anything outside the /home/user directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED]gedit Embedded Terminal Has No Prompt killingthemonkey Linux - Software 1 02-23-2014 07:42 PM
[SOLVED] gedit command not opening any file even as root :( blitz_adp Linux - Newbie 2 11-14-2010 05:12 AM
Opening VLC with the terminal line so the terminal will go back to normal baldurpet Linux - Newbie 3 01-14-2009 10:57 AM
Wanted: Spam filter to bounce authenticated mail to authenticated address Wassercrats Linux - Software 4 11-08-2007 07:56 PM
Opening a new terminal from Fluxbox menu (or another terminal) hallamigo Linux - Software 1 05-02-2004 04:32 AM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration