LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-04-2004, 07:50 PM   #1
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Rep: Reputation: 15
Unhappy gDesklets installation. Help needed with libraries


Ok I installed gDesklets months ago. It was the 30pre version. Everything worked fine. However, today I installed Python2.3 so I could configure one of the desklets. Now, nothing is working. When I go to start gDesklets it tells me its timedout.
I did a re-configure and got a bunch of errors. Turns out, I now need glibtop, glibtop2, and python dev packages. My husband looked at it and said something about them bring wrapped and needing to edit the config files. He's no help.
Can anyone tell me where I can find these files that I need to download? I tried on the gDesklet forum, but those people arent very nice. They treat me like Im an idiot.
So since this forum is super nice, I figured someone on here could help me. Thanks in advance!
much love,
nikki
 
Old 08-04-2004, 08:18 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
this may be of help

http://fatboy.ucd.ie/gdesklets/

good luck.
 
Old 08-04-2004, 08:39 PM   #3
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Original Poster
Rep: Reputation: 15
Thanks Peacedog, I tried that and followed the directions and everything installed with no errors, but its telling me that theres no module named gnome.ui. Any ideas?
much love,
nikki
 
Old 08-05-2004, 07:27 AM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
a quick google for gnome.ui module turned up some results, i'll save you the time of doing it.

http://www.google.com/linux?hl=en&lr...=Google+Search

hope that gets you going.
good luck.
 
Old 08-05-2004, 11:05 AM   #5
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Original Poster
Rep: Reputation: 15
Ok I took a look at the link, and read tons, and basically, I have to re-install pyorbit and then re-install gnome-python2. So I did all that. Got no errors, everything went smoothly. Then I went and reconfigured gDesklets. No errors. However, when I went to do a make this is what I got:
gcc: -lXau: linker input file unused because linking not done
gcc: -lgtop-2.0: linker input file unused because linking not done
gcc: -lglib-2.0: linker input file unused because linking not done
make[4]: *** No rule to make target `glibtop_tmpl.i', needed by `glibtop.i'. Stop.
make[4]: Leaving directory `/home/nikki/gDesklets-0.30pre/libdesklets/system'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/nikki/gDesklets-0.30pre/libdesklets/system'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/nikki/gDesklets-0.30pre/libdesklets'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nikki/gDesklets-0.30pre'
make: *** [all] Error 2
I know I have glibtop, I got it yesterday and installed it and everything went fine. What am I doing wrong?
much love,
nikki
 
Old 08-05-2004, 07:43 PM   #6
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
to be honest googling the the error message leads me to believe this is a programming problem w/the make file or possibly some options entered during the compile process. i found this

Quote:
It means that creating an object file does not require linking so the
libraries provided by the --libs option were not used.
here

http://studio.imagemagick.org/piperm...ry/000438.html

that was from a google on the error. i'm not really a programming guy, so i'm limited to googling. sorry to be no more help, but, i'll keep googling, and keep an eye on this thread, if we don't get you fixed up in another day or two, i'll report this to the mods, there are several mods who are great programers, Tinkster, and acid kewpie, come to mind. again sorry. maybe we'll find the answer yet.
 
Old 08-05-2004, 08:51 PM   #7
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Original Poster
Rep: Reputation: 15
Peacedog,
Not a problem. I'm super thankful that someone has taken the time to try and help. Thanks so much!
much love,
nikki
 
Old 08-06-2004, 07:02 PM   #8
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
done some more reading today, this error

No rule to make target `glibtop_tmpl.i', needed by `glibtop.i'. Stop.

is covered in the missing handbook, have you tried this?

Quote:
My build fails because 'No rule to make target `glibtop_tmpl.i' - what do I do?
This is not really a big deal - run 'make -k' instead of make to ignore this error.
 
Old 08-07-2004, 07:44 PM   #9
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Original Poster
Rep: Reputation: 15
Yes I have tried that and it didnt work either. I went and got the new Slack and installed that. However, I am now getting the message that gnome-python2 isnt installed and I know it is. Ya know I dont even wanna use the stupid desklets anymore. I just wanna figure this out so I can say "I figured this out" LOL. Thanks for the help.
much love,
nikki
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gDesklets Installation Probelm PEACEYALL Linux - Software 1 04-17-2005 09:11 AM
gDesklets problems. Help needed, I am about to suffer a mental brakedown Icetec Linux - General 4 11-14-2004 07:17 AM
programs and libraries needed for a kernel update darkleaf Linux - Software 4 06-25-2004 09:12 AM
gdesklets installation requirements NRHBasher Linux - Newbie 3 05-06-2004 04:19 PM
Glide libraries needed. Coramoor Linux - Newbie 4 05-13-2003 06:35 PM


All times are GMT -5. The time now is 05:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration