LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2013, 09:14 PM   #1
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Rep: Reputation: Disabled
Unhappy ftp user (cent os) can'T create directory on wordpress site


hallo friends
i want to update my wordpress blog site and linux cent os is a hosting server for this site and i have created ftp user for wordpress. but when ever i want to update my wordpress blog. ftp user can't create directory and installtion get failed .
can someone please help me

http://www.linuxquestions.org/questi...AAAElFTkSuQmCC
 
Old 12-17-2013, 09:18 PM   #2
nd7rmn8
Member
 
Registered: Jan 2013
Distribution: Arch
Posts: 50

Rep: Reputation: 13
have you checked the permissions for the directory you are uploading into?
 
Old 12-17-2013, 09:30 PM   #3
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
wordpress

yes , i have checked it.
command: chmod 775 -R /var/www/html/handover
and then permission folder
drwxrwxr-x permission of folder
with this command
ls -la /var/www/html/handover.
thanks
 
Old 12-17-2013, 09:32 PM   #4
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
hallo friends
i want to update my wordpress blog site and linux cent os is a hosting server for this site and i have created ftp user for wordpress. but when ever i want to update my wordpress blog. ftp user can't create directory and installtion get failed
What's in the log file?
I can't see your screenshot. If you use vsftpd, check /etc/vsftpd.conf for the log file name, and set the xferlog_enable parameter to "yes".
 
Old 12-17-2013, 09:34 PM   #5
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
yes , i have checked it.
command: chmod 775 -R /var/www/html/handover
and then permission folder
drwxrwxr-x permission of folder
with this command
ls -la /var/www/html/handover.
thanks
This folder doesn't have write permission for other. Is the user wordpress the owner, or does it belong to the group of the handover directory?
 
Old 12-17-2013, 09:39 PM   #6
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
wordpress user is the owner of the handover directory. i didn't make any group until now.
wordpress(ftp user) is only a user for this directory.
 
Old 12-17-2013, 09:42 PM   #7
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
xferlog is enable already
Attached Thumbnails
Click image for larger version

Name:	xferlog.PNG
Views:	6
Size:	4.3 KB
ID:	14252   Click image for larger version

Name:	permission.PNG
Views:	3
Size:	3.6 KB
ID:	14253  
 
Old 12-17-2013, 09:58 PM   #8
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
my ftp user was other(not owner and not belong to group) and then i set write permission for other and suddenly this worked.

command:
1::: chmod 777 -R /var/www/html/handover(here write your folder name,where your programnme is saved,in my case this is "handover").(to set the permission for folder)
2::: ls -la /var/www/html/handover.(to see the permission of folder)


thanks to all,
 
Old 12-17-2013, 09:59 PM   #9
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
xferlog is enable already
Great. And what does the log say?
 
Old 12-17-2013, 10:01 PM   #10
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
dear friend , i have no idea how to check this log
can you please write me how to check it
 
Old 12-17-2013, 10:09 PM   #11
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
dear friend , i have no idea how to check this log
can you please write me how to check it
To solve problems with services, you need to listen to what the services tell you. They usually communicate with you via a log file. If you use vsftpd to upload files to the handover directory, the name of the log file can be configured in /etc/vsftpd.conf. From the vsftpd.conf manual page:

Quote:
xferlog_enable
If enabled, a log file will be maintained detailling uploads and downloads. By default, this file will be placed at /var/log/vsftpd.log, but this location may be overridden using the configuration setting vsftpd_log_file.
 
Old 12-17-2013, 10:12 PM   #12
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
my ftp user was other(not owner and not belong to group) and then i set write permission for other and suddenly this worked.

command:
1::: chmod 777 -R /var/www/html/handover(here write your folder name,where your programnme is saved,in my case this is "handover").(to set the permission for folder)
2::: ls -la /var/www/html/handover.(to see the permission of folder)
You have me confused. I thought your ftp user was wordpress?
If the user name was other, it is no wonder that you could upload anything to the handover directory, since there were no write permissions. After the chmod command, other has write permissions and can upload.
 
Old 12-17-2013, 10:29 PM   #13
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
i am sorry friend. really thanks. whgile discussing with you i got idea this idea and my problem was solved.
thanks a lot.
 
Old 12-17-2013, 10:45 PM   #14
kunalks
Member
 
Registered: Dec 2013
Posts: 53

Original Poster
Rep: Reputation: Disabled
ldap coinfiguration in wordpress

hallo guys, i also want to configure ldap in my wordpress blog and i am really so closed to do it.does someone has idea about it that how can i make it possible.
i am using wordpress plugin and i am really so closed to make it possible.http://http://wordpress.org/plugins/...-role-manager/.
but when i try from wordpress login page , i can't login.
and my server respond me that user didn't create
Attached Thumbnails
Click image for larger version

Name:	ldaps.PNG
Views:	3
Size:	78.1 KB
ID:	14254   Click image for larger version

Name:	server msg.PNG
Views:	1
Size:	6.5 KB
ID:	14256  
 
Old 12-17-2013, 11:05 PM   #15
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by kunalks View Post
hallo guys, i also want to configure ldap in my wordpress blog and i am really so closed to do it.does someone has idea about it that how can i make it possible.
i am using wordpress plugin and i am really so closed to make it possible.http://http://wordpress.org/plugins/...-role-manager/.
but when i try from wordpress login page , i can't login.
and my server respond me that user didn't create
I suggest you open a new thread, as the subject of this one is now grossly misleading. For now I don't know enough of LDAP to help you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install of wordpress on cent os meil Linux - Server 2 09-16-2011 07:48 AM
ftp user can't create a directory on ftp server bharatlalgupta Red Hat 4 01-27-2010 02:58 PM
anonymous user can't create a directory on ftp server bharatlalgupta Red Hat 3 01-27-2010 11:16 AM
create ftp user for vsftpd server without home directory cccc Linux - Networking 2 07-30-2005 07:32 AM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration