LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2005, 07:23 AM   #1
martinj
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 3.1
Posts: 28

Rep: Reputation: 15
Fstab giving ntfs RO axx to all users?


Code:
/dev/hda1       /media/windows  ntfs    ro, defaults,user,GID=1000,umask=0222 0       0
I wrote that, but I am not able to mount it as user /*uid=1000* The user is also part of group id=1000*/ nor axx it as a user.
 
Old 06-12-2005, 09:39 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
axx??? what does "axx" mean?
 
Old 06-12-2005, 09:40 AM   #3
martinj
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 3.1
Posts: 28

Original Poster
Rep: Reputation: 15
access- sorry about that.
 
Old 06-12-2005, 10:00 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well if that is a char for char copy of the entry, then you have an invalid space between "ro," and the reset of the options. the gid specified there is not who can mount it, but who the files will appear to belong to once mounted. afaik any normal user should be bale to mount it. i'd wonder why it's not mounted automatically on boot, it's not like it's going anywhere.
 
Old 06-12-2005, 10:20 AM   #5
martinj
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 3.1
Posts: 28

Original Poster
Rep: Reputation: 15
It is not mounted at boot and it looks like this now

Code:
/dev/hda1       /media/windows  ntfs    ro,defaults,user,GID=1000,umask=0222 0       0
as root I can mount/view but not as a standard user.
 
Old 06-12-2005, 11:07 AM   #6
martinj
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 3.1
Posts: 28

Original Poster
Rep: Reputation: 15
Got it working now
Code:
/dev/hda1       /media/windows  ntfs    ro,defaults,user,gid=1000,umask=0222 0       0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
giving users permission to mount a CD ricardo_ok Slackware 4 11-03-2005 01:58 PM
Giving users their own little virtual server... murr4y Linux - Security 2 06-17-2005 08:26 AM
fstab: giving a user acct read-only access to specific partition doorbits Linux - General 4 05-18-2004 03:11 PM
Giving users access to the system... TCasp77 Slackware 5 02-28-2004 02:18 PM
fstab file to allow all users to read ntfs jza Linux - General 1 01-29-2004 03:05 PM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration