LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-25-2003, 08:12 AM   #1
CountryBoy
LQ Newbie
 
Registered: Jan 2003
Location: PA, USA
Distribution: Lindows 3.0
Posts: 6

Rep: Reputation: 0
frustrated Lindows newbie


I received my new Lindows PC yesterday and am very frustrated with it already. I had envisioned it as very simple to use and easily customized, but am finding just the opposite - I can't even access the BIOS. I have been a reluctant Windows user since 3.0 and hoped to break the chains at last.

I have Win2K and purchased the Lindows PC for my wife to use for her home business. I have a dialup modem (external Hayes Accura V.92). I installed a PCI network card in Win2K and connected to Lindows onboard LAN with crossover Cat5 cable. The network icon appears on the start bar of Win2K, but I am not sure what to do next to complete the connection. Neither PC recognizes the other. Can I set this up so Lindows can access the internet via modem on Win2K, as well as access printer, CDRW, etc? Or do I have to move peripherals to Lindows?
 
Old 01-25-2003, 08:55 AM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
After connecting to your isp open the connections properties and select share this connection on the sharing tab.

Then setup the lindows pc to use dhcp

Setup sharing in your printer properties, then use the printer setup to setup a network printer in lindows.

You can share the files on a cd in the cdrw, but if you mean use it as a writer, I don't think so.

To use windows shares you need smbclient, there are gui programs available, but the best thing to do is mount the shared folder on a folder on the linux box. Then you can use any file manager you want.

Last edited by DavidPhillips; 01-25-2003 at 09:03 AM.
 
Old 02-04-2003, 10:04 AM   #3
CountryBoy
LQ Newbie
 
Registered: Jan 2003
Location: PA, USA
Distribution: Lindows 3.0
Posts: 6

Original Poster
Rep: Reputation: 0
I had internet connection and browser problems with Win2K and have just now been able to follow up your answer.

I opened TCP/IP properties in Win2K for internet dial-up and enabled sharing for the internet connection. This set the LAN to use IP address 192.168.0.1, but when I clicked YES to continue I received the following error:

"Error 783: Internet Connection Sharing cannot be enabled. The LAN connection selected as the private network is either not present, or is disconnected from the network. Please ensure that the LAN adapter is connected before enabling Internet Connection Sharing."

The status of the LAN connection is already listed as ENABLED in the Network and Dial-Up Connections window, but apparently Win2K and Lindows are still missing something for the LAN so we need to deal with this first. Does the DHCP in Lindows need to be activated first? What does this do?
 
Old 02-04-2003, 03:56 PM   #4
baldy3105
Member
 
Registered: Jan 2003
Location: Cambridgeshire, UK
Distribution: Mint (Desktop), Debian (Server)
Posts: 876

Rep: Reputation: 184Reputation: 184
Yes you can do this. Your problem at the moment appears to be W2K. The state of the Lindows box should not stop you from enabling ICS on the W2K box. As long as the LAN interface is up,
which it appears to be.

For some reason ICS is seeing the LAN as not there.

Try manually setting the Lindows box to 192.168.0.2 255.255.255.0 , and the win2k box up as 192.168.0.1 255.255.255.0. See if A- the machines can ping their own address and B they can ping each other. This will prove that your LAN connection is OK

If this doesn't work then you have more fundamental problems with one of the nics, a driver, or possibly the cable. Dont muck about with ICS untill you get this working.
 
Old 02-04-2003, 06:30 PM   #5
CountryBoy
LQ Newbie
 
Registered: Jan 2003
Location: PA, USA
Distribution: Lindows 3.0
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks! I now definitely have a connection between Win2K and Lindows! :-) I was able to ping Lindows from Win2K but don't know what command / program to use in Lindows to go the other way. On Win2K I can see the number of packets sent and received in the network icon in system tray.

Now... to figure out how to make use of the LAN. I tried to enable sharing with the dial-up internet connection in Win2K but received the following error:

"Error 783: Internet Connect Sharing cannot be enabled. The LAN connection selected as the private network is either not present, or is disconnected from the network. Please ensure that the LAN Adapter is connected before enabling ICS."

Why would I get this error since the LAN is enabled?

Why did David suggest using DHCP in the Lindows? Would this make a difference? I have no clue about networking or Linux, so I am really starting from ground level. Thanks!
 
Old 02-04-2003, 08:23 PM   #6
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
The last time I saw this I went to the network properties. selected the nic and removed it.

Then go into the mycomputer properties and go into device manager and make sure the nic is removed from there.

Then reboot and reinstall the nic. You want to have tcp/ip in network properties, if you have any other protocols remove them. They only cause problems.
 
Old 02-05-2003, 04:22 AM   #7
CountryBoy
LQ Newbie
 
Registered: Jan 2003
Location: PA, USA
Distribution: Lindows 3.0
Posts: 6

Original Poster
Rep: Reputation: 0
I uninstalled / reinstalled the network and only have tcp/ip checked. I can still ping Lindows from Win2k and view number of packets sent / received but Lindows no longer appears in my workgroup. I still cannot share the ICS - same error 783.

I tried mounting Win2K in workgroup on Lindows and this also did not work, so I am at a loss to know what to try next.
 
Old 02-05-2003, 07:01 AM   #8
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
You should post your error on a windows site.
Your problem is with win2k, not lindows.
After you get rid of the error in windows, do the rest of
what dave said to do.
windows error messages rarely have anything to do
with what the real problem is.
 
Old 02-06-2003, 03:44 AM   #9
baldy3105
Member
 
Registered: Jan 2003
Location: Cambridgeshire, UK
Distribution: Mint (Desktop), Debian (Server)
Posts: 876

Rep: Reputation: 184Reputation: 184
This is true, your prob is with Win2k. If the old reinstall trick didn't work then its likely to be a dodgy driver. Did you use the driver that came with w2k or did you download the latest one you could get? More specifically a Win2000 driver.?

David is quite right, you should use DHCP on Lindows when you get ICS going properly. I just told you to get rid of it to make things as simple as possible to test your lan. Untill ICS is working properly DHCP will only confuse matters as ICS provides the DHCP server functionality.

When you get ICS going it will tell you how to configure the client.

Try getting a newer driver, or failing that another card. Should be able to get a 10/100 nic for about 10, thats about $5
 
Old 03-01-2003, 02:55 PM   #10
angelrod
Member
 
Registered: Oct 2002
Location: Mexico
Distribution: RedHat 9.0 and SuSE 8.1
Posts: 229

Rep: Reputation: 30
Proxy

Instead of having a battle with the win2k internet sharing, why don't you try installing an external proxy software like winproxy, winroute, or I'll recommend browsegate (it's easier if you're not used to proxy)
 
Old 03-01-2003, 03:06 PM   #11
CountryBoy
LQ Newbie
 
Registered: Jan 2003
Location: PA, USA
Distribution: Lindows 3.0
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the tip angelrod. I will check into it. For the short term, I already formatted the hard drive that had Lindows and installed W2K on PC #2. Still having LAN problems. I think it is due to corrupt W2K installation on PC #1. Will try a dual installation when I get time and try your suggestion.
 
Old 03-01-2003, 09:31 PM   #12
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
If you want a good router for your connection you should really be using linux. You can get an old computer for next to nothing, people throw them away all the time, and they make great dependable routers.

Last edited by DavidPhillips; 03-01-2003 at 09:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated Newbie - Sound jrcreasy Debian 9 08-12-2005 01:25 PM
Frustrated semi-newbie to linux j0217995 Linux - Newbie 4 11-20-2004 06:17 AM
Please help a newbie - Pulling my hair out so frustrated!!!! Nixon Mandriva 4 06-23-2004 05:28 PM
Frustrated newbie slackware user libranikki Linux - Newbie 26 11-28-2003 07:57 PM
Frustrated newbie....internet problems caro Linux - Newbie 4 07-27-2003 04:34 AM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration