LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2011, 11:51 AM   #1
jeffmd55
LQ Newbie
 
Registered: Mar 2011
Location: Newark, DE
Distribution: Ubuntu Karmic Koala
Posts: 9

Rep: Reputation: 0
Firefox not seeing CUPS printers


I'm new to Linux administration so please excuse my ignorance. I have an Ubuntu Karmic (9.10) installation with LTSP 5.2 installed. I'm using CUPS version 1.4.1. The other day I ran an lpoptions -d printername command not realizing that I was setting the system default incorrectly. Now my issue is that all apps see the CUPS printers correctly, except for Firefox which doesn't see any (Print to File only option). I've searched for hours trying to find the configuration file that this command impacted for Firefox with no luck. Does anyone have any ideas? Any help is appreciated.

Thanks,
Jeff
 
Old 03-18-2011, 11:57 AM   #2
savona
Member
 
Registered: Mar 2011
Location: Bellmawr, NJ
Distribution: Red Hat / Fedora
Posts: 195

Rep: Reputation: 50
The "print to file" option you see is not a Firefox window.

What your saying is that when you hit print in Firefox the only option available is print to file? But when you print in other applications you see your system default printer?
 
Old 03-18-2011, 12:00 PM   #3
savona
Member
 
Registered: Mar 2011
Location: Bellmawr, NJ
Distribution: Red Hat / Fedora
Posts: 195

Rep: Reputation: 50
So did you try to set the default printer again?

The following command should show you the available printers:
lpstat -a

Then the following command to set it as default:
lpoptions -d <printer>
 
Old 03-21-2011, 11:14 AM   #4
jeffmd55
LQ Newbie
 
Registered: Mar 2011
Location: Newark, DE
Distribution: Ubuntu Karmic Koala
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by savona View Post
The "print to file" option you see is not a Firefox window.

What your saying is that when you hit print in Firefox the only option available is print to file? But when you print in other applications you see your system default printer?

Yes, the only option upon hitting print in Firefox is print to file. I have 90 printers setup through CUPS that are shared on 3 different servers. I can see all of these printers from all applications except for Firefox. Since this is a Terminal Server environment, I should have set the default through the CUPS web interface, but instead ran the lpoptions command on this one server. This must have changed a system level setting somewhere for Firefox, but I can't seem to find the right config file to edit. I've gone through all of the Firefox about:config options but haven't found what I'm looking for.
 
Old 03-21-2011, 11:27 AM   #5
savona
Member
 
Registered: Mar 2011
Location: Bellmawr, NJ
Distribution: Red Hat / Fedora
Posts: 195

Rep: Reputation: 50
Give this a go:

In the address field type "about:config"
In Filter field type "print"
Double click on print.printer_printer

This will show you the current default printer. Change this for the one that you would like to use as the default
 
Old 03-22-2011, 03:33 PM   #6
jeffmd55
LQ Newbie
 
Registered: Mar 2011
Location: Newark, DE
Distribution: Ubuntu Karmic Koala
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by savona View Post
Give this a go:

In the address field type "about:config"
In Filter field type "print"
Double click on print.printer_printer

This will show you the current default printer. Change this for the one that you would like to use as the default

I wasn't seeing an entry for print.printer_printer, but there were a lot of user set permissions on three other printers (one of those being print_to_file). I actually reset all of them (not what I planned on doing) closed/reopened and Firefox started seeing all the printers again. Then I went into System--> Administration-->Printing and set a system wide default. Now I can see it set as print.printer_printer when I go into about:config. Thanks for the tips. It's working again.

Jeff
 
Old 03-23-2011, 09:24 AM   #7
savona
Member
 
Registered: Mar 2011
Location: Bellmawr, NJ
Distribution: Red Hat / Fedora
Posts: 195

Rep: Reputation: 50
Please mark the thread solved to help keep the forum nice and tidy. Also if you found my comments helpful please click Yes on the bottom right of the post!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS and HP printers barn63 Slackware 4 07-26-2010 07:12 PM
[SOLVED] Firefox print does only shows lpr and "to file", not other printers configged in cups deadeyes Linux - Desktop 3 09-29-2009 10:33 AM
[cups] "no printers found" - printer isn't recognized by CUPS over network Majin_Buu Linux - Server 3 06-18-2009 11:25 AM
Cups disables printers! AndrewCAtWayofthebit Red Hat 2 07-14-2008 01:27 AM
Printers and cups Pedroski Linux - Hardware 1 10-05-2003 07:50 PM


All times are GMT -5. The time now is 03:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration