LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-25-2006, 03:00 AM   #1
trancekid
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Rep: Reputation: 0
Failed to start the X server after installing Nvidia drivers...


Newb here, trying to learn to work with Linux myself but after a day of attempting to install the Nvidia drivers and this problem still ruining my night I come looking for help.

Well I was having a lot of problems installing the nvidia drivers but eventually found a forum on google with someone who had this problem so I was using

sh NVIDIA* --x-module-path=/usr/lib/xorg/modules

to install the drivers. Supposedly this puts them in the correct directory so that the X server error would go away however it has not worked. I have tried following numerous step-by-step installation directions I found on google but I always run into this problem.

My X Windows is ver 7.0 so it should work, as I am using FC5.

Here is my Xorg.setup.log file...

Code:
X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006 i686
Build Date: 02 May 2006
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Sun Jun 25 01:43:20 2006
(++) Using config file: "/tmp/tmpx1TQkVxorg.config"
dlopen: /usr/lib/tls/libnvidia-tls.so.1: cannot restore segment prot after reloc: Permission denied
(EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: cannot restore segment prot after reloc: Permission denied
(EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found
 found
I still think the drivers are simply installing in the wrong place but I have no idea what to change the path to. If anyone would assist me with this it would be greatly appreciated, because using Linux w/ no video drivers is getting old, can't stand how choppy everything is when I move a window or something.

Edit: This may be a problem, but I was initially having problems where it was giving me a kernel error when trying to install the drivers and after doing "yum install gcc gcc-c++ kernel-devel" and that not fixing it I just typed in

yum install kernel*

That fixed it and installed the drivers (after a 750 mb download) but could it have messed something up?

Last edited by trancekid; 06-25-2006 at 03:04 AM.
 
Old 06-25-2006, 04:47 AM   #2
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Hi
Quote:
2.6.17-1.2139_FC5
Did you install this kernel via yum update? If so, the nVidia-kernel-module that conincides with the new kernel sometimes lags behind a few days. I have received this same error a number of times. It simply means the nVidia driver does not match the kernel. This often happens when something is installed via yum and a dependent module installed by a different means in Fedora Core.

I would uninstall the nVidia module you installed and check the Livna repository for the RPM that matches your kernel. In FC5 (if you have the Livna repository active), you will be updated for nVidia via PUP when it is available.

Hope this helps

Bob
 
Old 06-25-2006, 05:32 AM   #3
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
UPDATE: I just did the same update on my FC5 system and the nVidia kernel module was included with the update. This is by far the easiest way to install the nVidia driver. It just worked fine on my system.

Uninstall the module you were working with and install it with yum

Bob
 
Old 06-25-2006, 06:18 AM   #4
trancekid
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Well thats make me feel retarded that I was doin it the hard way, but in the past 2 hours I figured it out. I had to include selinux=0 on the kernel line in /etc/grub.conf.

Thanks for the help though guys, it will be helpful later in life when I reinstall
 
Old 07-10-2007, 11:31 PM   #5
Black Mamba
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
Hey guys,
I'm having similar problems......but just adding selinux=0 to grub.conf didn't help.

In my Xorg.0.log file I can only see one error.....however there are a couple of warnings.

Here's the two problem parts:
Code:
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Videocard0"
(WW) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
(**) |-->Input Device "Keyboard0"
(==) |-->Input Device "<default pointer>"
(WW) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
(WW) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
	unix/:7100,
	built-ins
(==) RgbPath set to "/usr/share/X11/rgb"
and

Code:

(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
	Screen to screen bit blits
	Solid filled rectangles
	8x8 mono pattern filled rectangles
	Indirect CPU to Screen color expansion
	Solid Lines
	Scanline Image Writes
	Offscreen Pixmaps
	Setting up tile and stipple cache:
		32 128x128 slots
		32 256x256 slots
		16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) AIGLX: Screen 0 is not DRI capable
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
This is my xorg.conf.backup file....which is where it said it saved my original xorg.conf file too once it failed.
Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "AddARGBGLXVisuals" "True"
	Option	    "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "800x600" "640x480"
	EndSubSection
EndSection

Section "Extensions"
	Option "Composite" "Enable"
EndSection
Any help would be much appreciated, as this happens every time I start up Fedora Core 6.....then I go through the process of saying, Yes restart X server....here is my root password....Yes, start with these settings......and then it works....

Please help me....this is getting frustrating....
 
Old 07-26-2007, 12:29 AM   #6
Black Mamba
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
*bump
Can someone please help me? I'm still having problems
 
Old 09-26-2008, 09:15 PM   #7
gumuruhsspj
LQ Newbie
 
Registered: Sep 2008
Posts: 24

Rep: Reputation: 15
Angry that's right ...seems my Fedora 8 also

OMG

it's same like me

Quote:

screen not found

after my NVIDIA is being installed through Internet
from some rpm i dont know
it's used something AT* i forgot...

so how could we start again the X Server ???
if it;s stuck like this...??

it's all CLI command Line Interface now
can't use the GUI anymore...

help us..........!!!!!!
 
Old 09-27-2008, 09:26 AM   #8
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Log in as root at the CLI
Search for the xorg.conf file (maybe in /etc/X11 or elsewhere)
In it change a line from

Section "Device"
Driver "nvidia"

to

Section "Device"
Driver "nv"

Save the file and run startx.
or reboot the machine.

That should permit you to have your GUI back.
Then you could downgrade the proprietary driver to the one which worked.

Next time, try to avoid reopening an old thread, begin a new one instead, and only reference the old one in your post.

And next time also be more precise, avoid "I don't know" how I installed it, "I forgot" what I used. You have to know what you are doing especially when you use Linux.

Last edited by berbae; 09-27-2008 at 09:33 AM.
 
Old 09-27-2008, 11:46 AM   #9
gumuruhsspj
LQ Newbie
 
Registered: Sep 2008
Posts: 24

Rep: Reputation: 15
Thumbs down i'm sorry for the inconvenience

so then like what u suggest on me;

Quote:
Search for the xorg.conf file (maybe in /etc/X11 or elsewhere)
In it change a line from

Section "Device"
Driver "nvidia"

to

Section "Device"
Driver "nv"

Save the file and run startx.
or reboot the machine.
and after i saved it, reboot...
nothing changed!

still X Server is failed to start ( your graphics interface )


OMG fren
 
Old 09-27-2008, 11:58 AM   #10
gumuruhsspj
LQ Newbie
 
Registered: Sep 2008
Posts: 24

Rep: Reputation: 15
even i found from others said that
Quote:
I am using Fedora 8 and got the same problem, which brought me here.

I however, managed to correct the bug, by reinstalling Xorg-server from the non-Gui mode.

I mounted the DVD,
mkdir /media/dvd
mount /dev/cdrom /media/dvd

Then i searched for the Xorg-server installation file (which has an rpm extension, unlike .deb in Ubuntu)

Then i installed the Xorg-Sever-x.x.x.rpm:
rpm -ivh Xorg-Sever-x.x.x.rpm

When i rebooted my machine , my GUI was okay..

I hope that can help you for Ubuntu, though the syntax is a lil bit different..

Good Luck
but for me having lots of files conflicts when dealing his suggestion...

OMG...help
 
Old 09-27-2008, 12:37 PM   #11
gumuruhsspj
LQ Newbie
 
Registered: Sep 2008
Posts: 24

Rep: Reputation: 15
Wink i just have the solution to use the Standard Graphic Card

even we want to install the NVIDIA driver
but what we need to do now is switch back first into the GUI
even NVIDIA is not detected yet ,,, again.

so to do that...what i got
is log as root on CLI

then type
Quote:
setup
choose the latest option
which is similar with X Configuration...

something like that will make you reConfigure your monitor-related
settings...

so turn it back into a small resolution for a working one
800 x 600

and the Hardware should be choose as the Standard one there

OK to confirm...
and then reboot.

Normal again, at least u got the GUI back.
Even the NVIDIA driver may not be installed yet, again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Nvidia Ge force drivers - X server mike9287 Linux - Newbie 9 06-18-2006 05:58 PM
Installing nvidia drivers from nvidia website on mepis 3.3 xbennyboy Linux - Hardware 4 04-23-2005 10:19 AM
nvidia drivers, gcc-version-check failed Seiken Slackware 26 02-25-2005 10:50 PM
newbie> nvidia drivers: failed to.. and x won't start mandrakemikael Linux - Software 10 08-31-2004 05:25 AM
After installing new NVIDIA drivers, X-Windows won't start glock19 Linux - General 4 12-19-2001 11:31 PM


All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration