LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2008, 10:11 PM   #1
sbalvir
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
Unhappy Failed dependencies:libstdc++.so.6 is needed by hp-snmp-agents-8.1.1


Hi All,

I'm new to Linux world and really sorry if asking silly question. Appear to be common errors as seen on net but unsure about its solution.

As part of PSP - HP snmp agents installation, it is getting failed during dependency check for library libstdc++.so.6. I have done below steps but all in vain.

===============================================================
root@lxbwyaflmobstg1:/home/wipro# uname -a
Linux lxbwyaflmobstg1 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
root@lxbwyaflmobstg1:/tmp/in# rpm -Uvh hp-snmp-agents-8.1.1-22.rhel4.x86_64.rpm
error: Failed dependencies:
libstdc++.so.6 is needed by hp-snmp-agents-8.1.1-22.rhel4.x86_64
libstdc++.so.6(CXXABI_1.3) is needed by hp-snmp-agents-8.1.1-22.rhel4.x86_64
libstdc++.so.6(GLIBCXX_3.4) is needed by hp-snmp-agents-8.1.1-22.rhel4.x86_64
root@lxbwyaflmobstg1:/tmp/in#
================================================================


1. This library is present under /usr/lib64 so unsure why it is not getting picking up. Tried adding this library to $LD_LIBRARY_PATH but no luck.
========================================================================
root@lxbwyaflmobstg1:/home/wipro# ls -latr /usr/lib64/libstdc++.so.6
lrwxrwxrwx 1 root root 18 Nov 12 13:14 /usr/lib64/libstdc++.so.6 -> libstdc++.so.6.0.3
========================================================================

2. Tried upgrading gcc package and getting "IndexError: list index out of range"
===================================
root@lxbwyaflmobstg1:/home/wipro/PSP/PSP/compaq/csp/linux# yum install glibc.x86_64
Setting up Install Process
-------
-
-
--> Processing Dependency: glibc-common = 2.3.4-2.39 for package: glibc
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 138, in main
(result, resultmsgs) = base.buildTransaction()
File "__init__.py", line 401, in buildTransaction
File "depsolve.py", line 226, in resolveDeps
File "depsolve.py", line 357, in _processReq
File "depsolve.py", line 418, in _requiringFromInstalled
File "__init__.py", line 1479, in getInstalledPackageObject
IndexError: list index out of range
=======================================================================


Would really appreciate if someone could help me on this please.

Thanks

Last edited by sbalvir; 11-12-2008 at 11:47 PM. Reason: This problem got sorted out by executing "yum install libstdc".
 
Old 11-12-2008, 11:45 PM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
You may just have a missing symlink; software often expects a series of links like this:
libblah.so -> libblah.so.6 -> libblah.so.6.minor.version (last one is the actual lib).

So if you have:
libblah.so -> libblah.so.6.minor.version but not libblah.so.6, the test may fail.

Of course the authoritative reason for the failure is to be found by reading through the code which does the test and finding out where it goes wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SNMP agents automatically installed on switches, routers and servers? hondo Linux - Networking 3 08-13-2007 08:31 PM
libstdc++ : circular dependencies? yekrahs Linux - Software 21 10-23-2005 11:57 AM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 03:13 PM
Installing net-snmp, dependencies? onewhoknows Linux - Software 1 06-02-2004 03:08 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration