LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2014, 05:33 AM   #1
Sweta Kant
LQ Newbie
 
Registered: Nov 2014
Posts: 1

Rep: Reputation: Disabled
Facing problem at the time of validate in ns 2.34


I have gone through these steps and i am facing those problems . .
Steps:-
$ sudo apt-get install g++-4.4


In a new folder in /home/your folder/ :

$ tar xvfz ns-allinone-2.34.tar.gz

$ cd ns-allinone-2.34/


$ patch -p0 < otcl_ns234_gcc-4.4.patch


$ export CC=gcc-4.4 CXX=g++-4.4 && ./install

$ cd ns-2.34

$./validate

Error :-
unning test ungentle:
../../ns test-suite-red.tcl ungentle QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test gentle:
../../ns test-suite-red.tcl gentle QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test gentleEcn:
../../ns test-suite-red.tcl gentleEcn QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test gentleEcn1:
../../ns test-suite-red.tcl gentleEcn1 QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test ungentleBadParams:
../../ns test-suite-red.tcl ungentleBadParams QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test gentleBadParams:
../../ns test-suite-red.tcl gentleBadParams QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test q_weight:
../../ns test-suite-red.tcl q_weight QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test q_weight_auto:
../../ns test-suite-red.tcl q_weight_auto QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test congested:
../../ns test-suite-red.tcl congested QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test congested_mark_p:
../../ns test-suite-red.tcl congested_mark_p QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test congested1_mark_p:
../../ns test-suite-red.tcl congested1_mark_p QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test congested2_mark_p:
../../ns test-suite-red.tcl congested2_mark_p QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Some test failed.
Wed Nov 12 02:33:17 PST 2014
Wed Nov 12 02:33:19 PST 2014
*** ./test-all-adaptive-red
Tests: red1 red1Adapt red1ECN red1AdaptECN red1AdaptFeng fastlink fastlinkAutowq fastlinkAutothresh fastlinkAdapt fastlinkAllAdapt fastlinkAllAdaptECN fastlinkAllAdapt1 longlink longlinkAdapt longlinkAdapt1 red2 red2Adapt red2A-Adapt red2-AdaptFeng red3 red3Adapt red4Adapt transient transient1 transient2 notcautious cautious cautious2 cautious3
Running test red1:
../../ns test-suite-adaptive-red.tcl red1 QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
Running test red1Adapt:
../../ns test-suite-adaptive-red.tcl red1Adapt QUIET
./test-all-template1: 110: ./test-all-template1: ../../ns: not found
 
Old 11-13-2014, 04:41 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Welcome to LQ.
Quote:
./test-all-template1: ../../ns: not found
No executable 'ns' in ns-allinone-2.34/ns-2.34/ :
That's a failed build.
? Which "Linux OS" are you using ?
* Please specify your OS
http://www.linuxquestions.org/linux/...Ask_a_Question
I.e. a) The output from the command $ uname -m
b) OS name and version.


Quote:
$ tar xvfz ns-allinone-2.34.tar.gz
`tar xvf' will do, unless your 'tar' command
is older than the year 2004 version.

-
 
  


Reply

Tags
ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem by validate a manefest file thomas2004ch Solaris / OpenSolaris 5 07-11-2013 06:57 PM
1st time using Linux and facing alot of problem. blackvirus Linux - Newbie 6 01-31-2013 02:10 PM
problem facing in ubuntu 10.04 dipu.singh2008@gmail.com Linux - Newbie 4 02-12-2012 09:55 PM
I am facing problem with openOffic dellxcard Linux - General 3 06-16-2008 08:23 AM
Facing The Problem When I upgraded My PC girish_sawlekar Fedora 2 06-11-2007 11:41 PM


All times are GMT -5. The time now is 04:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration