LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2005, 02:02 AM   #1
coldwater
LQ Newbie
 
Registered: May 2005
Posts: 3

Rep: Reputation: 0
/etc/fstab problem


hello.

i've installed ubuntu, and have a small lan consisting of two pcs, one pure winXP, and my with winXP/ubuntu. i have a fat32 partition for sharing and i can't get to it from linux [it looks empty]. i googled a little and changed the /etc/fstab to look like this:

/dev/hda5 /winblows vfat user,rw,noauto 0 0

at first it looked ok, i could do anything as a regular user. but now [a few days after], again i see nothing, and i as far as i can remember, i haven't changed a thing. what could be the problem?

also, a question about samba, how to allow windows user to access my linux share folder? he's prompted for username/password every time, and he can't get pass that even with my linux usernames, root also.
 
Old 05-12-2005, 02:37 AM   #2
grayFalcon
Member
 
Registered: Jan 2003
Distribution: Debian
Posts: 69

Rep: Reputation: 15
I can't help you with the vfat thing (works fine with me...).

I have samba running at home though, and here's what I did:

First, I created a new user account on the linux box that was identical with the user account name on the windows box. Then, in webmin, there's an option to synchronise samba accounts/passwords with system accounts/passwords. After I did this, everything worked.
 
Old 05-12-2005, 04:06 AM   #3
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
change it to:

/dev/hda5 /winblows vfat umask=0222 0 0

and you'll be able to access it as a user in linux, but you'll need to be root to write to it, which for me is a nice safety thing.

Last edited by detpenguin; 05-12-2005 at 04:07 AM.
 
Old 05-12-2005, 03:36 PM   #4
coldwater
LQ Newbie
 
Registered: May 2005
Posts: 3

Original Poster
Rep: Reputation: 0
yes, but i wanted to be able to keep my docs so that i can change them from linux and windows, a friend told me linux won't see ntfs so i put fat32. maybe ntfs is a better solution?
 
Old 05-12-2005, 04:59 PM   #5
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
NTFS write support is experimental at best. FAT32 is the best option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
Please help - fstab problem mickeyboa Fedora 16 02-25-2005 06:12 PM
fstab problem imdeemvp Slackware 3 09-29-2004 04:37 AM
/etc/fstab problem mokojin Slackware 8 08-31-2004 01:34 PM
/etc/fstab problem intraining Linux - General 5 04-28-2003 08:30 AM


All times are GMT -5. The time now is 05:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration