LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-27-2005, 07:10 PM   #1
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Rep: Reputation: 0
Question Dual-boot install: "Could not find kernel image: linux / boot:"


I have been trying for weeks now to create a dual-boot with Red Hat Linux 9.1 and Windows 2000, without any luck.

I'm very close to a solution, but I've finally run into a situation that I cannot figure out. Here's what I have:

A brand new 40 GB SEAGATE hard drive with a windows partition of 8 GB (NTFS) on /dev/hda1

A 100 MB Linux /boot partition on /dev/hda2 - note: the boot partition is entirely within the 1024 cylinder limit

A bunch of other linux partitions

I installed GRUB on the first sector of /boot partition to avoid the problems with Windows booting when the MBR has been changed and created a boot disk.

However, when I reboot with the disk this is what I get:

Could not find kernel image: linux
boot:

I tried the command "linux /dev/hda2" at the boot prompt, but I just got the same text again (I've never used Linux before so I'm not even sure if that command made sense, other than I've seen it referenced - however, I do know my boot partition is on hda2).

I'd be REALLY grateful for any help with this!!
 
Old 01-27-2005, 07:23 PM   #2
avarus
Member
 
Registered: Apr 2004
Location: Oxford, UK
Distribution: Ubuntu, Debian, various
Posts: 230
Blog Entries: 5

Rep: Reputation: 32
Hi,

So just to clarify, you boot from the boot disk, and this chainloads GRUB from /dev/hda2 - are you sure that bit is working?

Then you type 'linux /dev/hda2' - I'm not sure where you got that from but it looks nothing like a GRUB boot command. You will need something more like the following sequence:

root (hd0,1)
kernel /vmlinuz devfs=mount root=/dev/hda2
initrd /initrd.img
boot

But your kernel image is probably called something else and you probably need more parameters. There should be a file called /boot/grub/menu.lst with the necessary stuff in it, and in fact you should be seeing a menu. This suggests that you have a problem with your boot disk or that you have corrupted your boot partition.

TIM
 
Old 01-27-2005, 07:25 PM   #3
avarus
Member
 
Registered: Apr 2004
Location: Oxford, UK
Distribution: Ubuntu, Debian, various
Posts: 230
Blog Entries: 5

Rep: Reputation: 32
Actually, on second thoughts, try this at the prompt:

root (hd0,1)
chainloader +1
boot
 
Old 01-27-2005, 08:41 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I would recommend that you google for: NT grub boot "how to"
There are many how-to's on how to use the Windows NTLDR loader to boot into linux. This won't alter the MBR, which sounds like what you want. You need to copy the boot area of /boot and save that file in C:\ and add an entry to C:\BOOT.INI. The how-to's will give the step-by-step options.
 
Old 01-28-2005, 07:24 PM   #5
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for all your help. Unfortunately, I don't think I made myself clear. The problem is that I don't think I'm booting correctly, and the text I included in my original post is the dead end I run in to. I know I need to do some things with GRUB and the NTLDR file, but I can't get in to Linux to mount a floppy drive to copy the boot sector on to disk. Could it be my boot disk, or my install? I don't know, I've installed it several times now and I keep running in to the same thing.

Or is what's supposed to happen actually happening? What do I type to advance past the boot prompt???

What does the "can not find kernel image: linux" mean??

JEB
 
Old 01-28-2005, 10:09 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Do you have a grub menu at all. It is possible to enter a command mode where you can enter the commands that avaras mentioned.
root (hd0,1)
chainloader +1
boot

If the grub loader is installed on tlhe second partition then this should work. Sometimes the second partition is actually /dev/hda5 because it is in an extended partition. In that case, use 'root(hd0,4)' instead.

If that doesn't load up linux, but you can get into the grub command mode, use the tab key, auto completion feature, to find the kernel and initrd file.

If you don't have any boot menu at all, the boot up to the first install disk and enter parameter 'rescue' to enter the rescue mode.

Here is a link to a grub manual:
http://www.gnu.org/software/grub/manual/

Last edited by jschiwal; 01-28-2005 at 10:28 PM.
 
Old 01-29-2005, 08:31 AM   #7
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Original Poster
Rep: Reputation: 0
I tried using the command sequence two of you suggested:

root (hd0,1)
chainloader +1
boot

But, this is what I get: "Could not find kernel image: root"

I tried (hd0,1) all the way through (hd0,8) to try to find the root directory, though
I'm fairly certain that my boot is on hda2 and my root is on hda3

I also tried entering all those commands in one line, as well.

I tried this, too: "grub-install /dev/hda2"
and this is what I got: "Could not find kernel image: grub-ins.tal"

I'm not even trying to get to GRUB, yet. I just want to get in to Linux - I'm perfectly fine using a boot disk for now. I've got three books on Linux from the library and none of them mention any problems with using a boot disk - it should be a no-brainer.

Something is not right here, any more ideas??
 
Old 01-29-2005, 01:47 PM   #8
avarus
Member
 
Registered: Apr 2004
Location: Oxford, UK
Distribution: Ubuntu, Debian, various
Posts: 230
Blog Entries: 5

Rep: Reputation: 32
You say 'I'm not even trying to get to GRUB, yet. I just want to get in to Linux'

That's like saying 'I don't want to go to the airport, I just want to catch a plane'

Anyway, it looks to me like you made a LILO boot disk, which is why none of the suggested commands are working. LILO cannot chainload unless it was configured in advance, and clearly it is not configured properly. If I were you I would make a new boot disk using this program:

http://btmgr.sourceforge.net/

You can download an executable for either Linux or Windows, and you just run it and it installs to a floppy disk. When you boot from that disk you get a nice menu asking what device you want to boot from - which is exactly what you seem to need.

Hope this is useful

- TIM
 
Old 01-29-2005, 03:41 PM   #9
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Nope, I definitely chose GRUB - it's the default option on install of RedHat Linux 9.1, and I did nothing to change that. Perhaps somebody can tell me:

What should happen when I boot up off the boot disk for the VERY FIRST time?

Nobody has mentioned this, nor do any of my books mention anything about booting off a disk for the first time. Again, it seems like this should work easy - I have scanned linuxquestions for similar issues, but I can't find anyone having the same problem!
 
Old 01-29-2005, 03:51 PM   #10
dijkstra
LQ Newbie
 
Registered: Jan 2005
Location: Madison Heights VA
Distribution: SuSe
Posts: 13

Rep: Reputation: 0
if you boot from a boot disk, it's not going to automagically screw anything up until you mess with it. It might help if you use the boot disk, get into a shell, run fdisk -l and post the output. I just had to do something like this w/XP
 
Old 01-29-2005, 06:05 PM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Another option is to use the autocompletion feature of grub to locate the kernel.

Enter 'c' to get in the command mode.

Enter: kernel (
Press the tab option to get a list of the devices. Suppose that (hda0,1) exists. Try: kernel (hda0,1)/
Press the tab key. If 'boot' is listed, add that to the end: kernel (hda0,1)/boot/
and press the tab key again. Type in the first few charactors of the kernel file name and press tab to complete, then press enter.

Do the same for the initrd file. Then enter the command 'boot'.
 
Old 01-31-2005, 11:38 AM   #12
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Original Poster
Rep: Reputation: 0
OK, I can try a couple of these things when I get home, but I'm still not sure people are understanding that every command I enter at the boot: prompt just comes back with "Could not find kernel image: xxxxx" where xxxx is the stuff I entered in. For example, when I enter "c" as suggested by jschiwal this is what will happen - "Could not find kernel image: c"

Two posts back, dijkstra's suggestion was to enter the shell mode - first, I don't know how to enter the shell mode (remember I've never even SEEN Linux before) and second - I predict I won't be able to enter any shell mode b/c I haven't even been able to successfully boot into Linux off the boot disk.

I'll give these things a try when I get home and will post my results - hopefully I'm wrong and something will open up.
 
Old 02-01-2005, 07:28 PM   #13
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Well, just as I suspected neither of the last two suggestions worked. It behaved just as I predicted - when I entered c at the boot: prompt this is what I got:

"Could not find kernel image: c"

Can anybody out there tell me how to get past the freakin' boot: prompt???

Keep in mind that I'm using a boot disk, am trying to set up multi-boot system with Win2000, and that NOTHING is working. I don't have access to LINUX or even GRUB, yet, so any suggestions about shells, getting in to GRUB, etc. are useless until somebody can help me get past the boot disk.

I'm really anxious to resolve this so I can use Linux for the first time ever, and I would really like to blame my problems on Windows like a lot of other people, but quite honestly I think this one's on Linux. I did the installation "by the book".
 
Old 02-01-2005, 09:03 PM   #14
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Press the 'esc' key when the first boot menu comes up. There should be a
boot: _
prompt at the top, and at the bottom, a message saying enter 'c' to enter the command mode.
You want to get into the command mode to continue.

I just had to do this yesterday. For some reason, the bios decided to put the keydrive in the first boot position ahead of the other drives, even though usb boot was disabled.
 
Old 02-01-2005, 10:20 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,491

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Quote:
Originally posted by jschiwal
Press the 'esc' key when the first boot menu comes up. There should be a
boot: _
prompt at the top, and at the bottom, a message saying enter 'c' to enter the command mode.
You want to get into the command mode to continue.
Seems like sensible advice.
Personally I'd use a LiveCD - Knoppix is good - to do it. Everything you need is right there, except that Knoppix mounts the drives R/O. Don't know about the floppy - too many years since I used one ;-)
Easy enough to remount.

As you are no doubt aware by now, this dd of the boot sector record should have been done after grub install and prior to re-boot.
You might also like to think about setting up a shared partition. I like to have a 2 Gig Fat32 partition to move files back and forth.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to "dual boot" linux (debian) and Freebsd using Grub? hkl8324 Debian 4 06-15-2005 03:32 PM
Dual boot XP/FC2 probs aftter FC2 install - "cannot find operating system" bcal Fedora - Installation 4 01-30-2005 04:38 PM
I Dual Boot, Is there Compatable "Drive imaging" that works with linux joncolby Linux - Software 6 06-21-2004 04:11 AM
Seeing Linux as a "Drive" from Windows OS on a dual boot System teclipse Linux - Newbie 4 09-29-2003 11:19 AM
dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot markus1982 Linux - General 4 09-21-2002 02:16 PM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration