LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2007, 04:56 AM   #1
unde
LQ Newbie
 
Registered: May 2007
Posts: 2

Rep: Reputation: 0
Question Display driver changes for Matrox on reboot with two display adapters


Hi,

I have been configuring xorg.conf to work with nVidia GeForce 4 TI 4200 (NV25) and Matrox Millennium 2 (MGA 2164W). Everything is fine until I reboot the system. Somehow the Matrox display adapters driver changes to 'nvidia' (from 'mga').

I assume there is some display-config software that runs on boot changeing the driver. How could I stop the driver from changeing automatically.

It is changeing just before the graphical l/p-screen appears.

I am using Fedora Core 6.

Best Regards,
Unde

Last edited by unde; 05-30-2007 at 01:22 PM.
 
Old 05-31-2007, 06:52 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 69
Quote:
Originally Posted by unde
Hi,

I have been configuring xorg.conf to work with nVidia GeForce 4 TI 4200 (NV25) and Matrox Millennium 2 (MGA 2164W). Everything is fine until I reboot the system. Somehow the Matrox display adapters driver changes to 'nvidia' (from 'mga').

I assume there is some display-config software that runs on boot changeing the driver. How could I stop the driver from changeing automatically.

It is changeing just before the graphical l/p-screen appears.

I am using Fedora Core 6.

Best Regards,
Unde
That almost sounds like the point where X figures out the default display device check in your BIOS for the INIT first display or similarly named this is where you set whether the PCI or AGP card is initialized first this will be used by X when picking the primary monitor or at least it always has on my machines running dual cards. Also it could be udev screwing up if it is that then I can be of no help never used it now if it not the BIOS setting and somehow your xorg.conf is getting changed there is something really weird going on you might want to post the file so we can see it at any rate.
 
Old 06-03-2007, 06:50 AM   #3
unde
LQ Newbie
 
Registered: May 2007
Posts: 2

Original Poster
Rep: Reputation: 0
reply to reply

Quote:
Originally Posted by HappyTux
That almost sounds like the point where X figures out the default display device check in your BIOS for the INIT first display or similarly named this is where you set whether the PCI or AGP card is initialized first this will be used by X when picking the primary monitor or at least it always has on my machines running dual cards. Also it could be udev screwing up if it is that then I can be of no help never used it now if it not the BIOS setting and somehow your xorg.conf is getting changed there is something really weird going on you might want to post the file so we can see it at any rate.
In bios I have selected the PCI card as a primary display adapter. After boot, the driver for matrox-card is changed to 'nvidia'. I login and change it back to 'mga', logout and login again, and then it is working ok. I'll attempt to trace the point when the driver gets changed.

Thank you for the help,
unde

Here is the full xorg.conf-file:
================================

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Acer"
ModelName "Acer AL707"
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "Acer"
ModelName "Acer AL707"
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor3"
VendorName "Acer"
ModelName "Acer AL707"
Option "dpms"
EndSection

Section "Device"
Identifier "nvidia0"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV25 [GeForce4 Ti 4200]"
Option "Twinview" "true"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "matrox0"
Driver "mga"
VendorName "Matrox"
BoardName "Matrox Millennium II"
BusID "PCI:0:8:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "matrox0"
Monitor "Monitor1"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "nvidia0"
Monitor "Monitor2"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024"
EndSubSection
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem withChanging DISPLAY environment variable to display on someone else's screen wantsri Linux - Networking 1 10-25-2005 12:14 PM
success with matrox g400/XF86 Dualhead 2 monitor display in Debian arjay Linux - Hardware 0 08-14-2005 07:12 AM
xlsfonts is dependant on DISPLAY setting not working on one display with Redhat iainsear Linux - General 0 12-21-2004 07:19 AM
can I recover from disk full - without reboot ? can't open display dtimms Linux - Software 3 09-19-2004 01:27 AM
RH9 Shrike /sbin/loader display problem with SIS 630 laptop - display is blank ! johnvoisey Red Hat 4 11-01-2003 07:52 AM


All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration