LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-12-2006, 07:42 AM   #1
subhranath
LQ Newbie
 
Registered: Jan 2006
Location: Kolkata -> Pune -> New Delhi
Distribution: Ubuntu
Posts: 17

Rep: Reputation: 0
Disable GRUB to rewrite MBR


How do I disable GRUB from rewriting the MBR each time it is loaded?
 
Old 01-12-2006, 08:05 AM   #2
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
Grub rewrite the MBR when it was installed not when it loaded.
Then what is your problem?
 
Old 01-12-2006, 08:08 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,497

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Grub only updates the MBR when installed to the MBR.
That is, you are telling it to.

To ensure it is written where you want (presumably a partition rather than the MBR), use the command line. Then you have total control.
See the grub documentation on the gnu.org site.
 
Old 01-12-2006, 08:17 AM   #4
subhranath
LQ Newbie
 
Registered: Jan 2006
Location: Kolkata -> Pune -> New Delhi
Distribution: Ubuntu
Posts: 17

Original Poster
Rep: Reputation: 0
I had Windows 98, Windows XP installed.
Recently I installed Linspire which installed the GRUB boot-loader with it and rewrote th MBR.

But I wanted the Windows XP boot-loader as the default boot-loader so I restored the Windows boot-loader and added an entry to the boot.ini file to load the GRUB boot-loader, and this worked fine to enter into Linux.

But my problem is that, each time I load into the Linux, GRUB rewrites the MBR and sets itself as the default boot-loader.(And thus I have to restore the original MBR to set NTLDR as the default boot-loader)

So I want to disable the setting which is making GRUB rewrite the MBR each time I enter Linspire.
 
Old 01-12-2006, 08:33 AM   #5
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
I'm not sure that this helps you, but it may get you looking in the right direction. As far as I know, there is no GRUB setting which will cause it to rewrite the MBR all the time. Typically GRUB will only rewrite the MBR if it is asked to. I would look for more information about a linspire setting and not so much for a grub setting.
 
Old 01-12-2006, 09:02 AM   #6
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
I would agree with the other posters. Either GRUB is installed in the MBR or it is in another partition. Whatever boot loader comes up when you start the computer is what is installed in the MBR. If what you are describing is that GRUB comes up when you choose the Linspire entry from WinXP, this is normal operation. AFAIK you cannot boot Linux directly from WinXP, it must go through GRUB first.

Bill
 
Old 01-12-2006, 09:34 AM   #7
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
I think it is Linspire 's problem, not grub.
To tell the truth, I don't know how can you use boot.ini to load linux.
But I suggest you using grub to load both linspire and XP.
I think it is easier
 
Old 01-12-2006, 05:08 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,497

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
I agree - this is not normal grub or Linux behaviour.
Ask this question on the linspire.com support page - sounds like they "look after" you in the initscripts somewhere.

And using ntldr is a valid way of multi booting. The distro should not unilaterally take over this decision. Ask them, and allow them to explain.
Did you leave the "Install to MBR" box ticked during the install ???.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
L 80 80 ... How to rewrite MBR? manudath Linux - Software 2 02-27-2005 11:00 AM
Grub on MBR vivekian Suse/Novell 13 02-20-2005 10:49 PM
GRUB MBR overwritten by WIN98 MBR TOuseef Linux - General 7 11-14-2004 05:25 PM
Can I rewrite lilo to mbr? spongebob Slackware 5 03-12-2003 11:20 AM
mbr had over write so lilo is gone how to rewrite lilo to mbr mch Linux - Software 4 10-25-2002 03:55 PM


All times are GMT -5. The time now is 12:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration