LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-02-2006, 03:00 AM   #1
CobraBytez
LQ Newbie
 
Registered: Aug 2006
Posts: 1

Rep: Reputation: 0
Digital Audio on AC'97


I just installed my first linux distro (SUSE 10) and the soundcard seemed to install with no problems. I have it attracted through optical cable (digital) to my Logitech 5.1 speakers. The speakers say "No Digital Data" so I assume that somewhere I have to tell Linux to output digitally instead of through analog signals. Does SUSE even support that?

Thanks!
 
Old 08-02-2006, 08:00 PM   #2
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
I have the same setup running, SusE does support this function, actually it is ALSA that provides the support so if you are running ALSA it should work in any distribution. There are a few obstacles that you have to be aware of:

1. The digital out is treated as a separate HW device, so you need to setup a corresponding device for ALSA. (in /etc/asound.conf). This is actually quite convenient since you can listen to music through SPDIF while talking on the phone (like Skype)using your analog HW. I don't have the sample config file on hand since I am in the office right now. If you need it let me know I will post it later today.

2. I suggest to test the output using aplay. you can specify the ALSA device directly. "aplay -D dmix-digital file.wav"

3. Most likely you will hear no sound, even if the aplay command launched successfully, because i found one very strange behavior: Whenever a new application starts using the Digital Output the IEC958 switch in the mixer will get enabled, which in return will mute the sound. So you need to use alsamixer to to set this switch to mute. Alsamixer is the most reliable way of doing it during testing. KMIX seems to be buggy in this regard and does not reflect the status correctly, but once you have everything running well you can use KMIX as well. (this behavior maybe fixable with the ALSA hook plugin, though I never had enough spirit to test it)

If you want to Route all your output to SPDIF you need to make the digital device the default device for ALSA. There are a few applications, which do not support ALSA natively where a struggle to get the output routed to SPDIF, although it must be possible somehow. The Flash Plugin Sound for example I think I have managed once but could never reproduce. If someone has an idea how to do that, I would appreciate the help.

Cheers X


I use a build in sound card Nforce 2.

Here my /etc/asound.conf

# Override the default output used by ALSA.
# If you do not override the default, your default
# device is identical to the (unmixed) analog device
# shown below. If you prefer mixed and/or digital
# output, uncomment the appropriate four lines below
# (only one slave.pcm line).
pcm.!default {
type plug
## Uncomment the following to use mixed analog by default
#slave.pcm "dmix-analog"
## Uncomment the following to use unmixed digital by default
# slave.pcm "digital-hw"
## Uncomment the following to use mixed digital by default
slave.pcm "dmix-digital"
}

# Alias for analog output on the nForce2 (hw:0,0)
# - This is identical to the device named "default"--which
# always exists and refers to hw:0,0 (unless overridden)
# - Therefore, we can specify "hw:0,0", "default", or "analog"
# to access analog output on the nForce2

pcm.analog {
type plug
slave.pcm "analog-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog {
type hw
card 0
}

# Alias for (rate-converted) mixed analog output on the
# nForce2 (hw:0,0)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the dmix plugin
# (in this case 48000Hz)
pcm.mixed-analog {
type plug
slave.pcm "dmix-analog"
}

#test fuer aoss skype scheint auch so zu helfen.

pcm.dsp0 {
type plug
slave.pcm "dmix-analog"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-analog {
type hw
card 0
}

# Alias for analog output on the BT headset (hw:1,0)
pcm.headset {
type plug
slave.pcm "headset-hw"
}
# Control device (mixer, etc.) for the BT headset
ctl.headset {
type hw
card 1
}
# Alias for (rate-converted) mixed analog output on the
# headset (hw:1,0)
pcm.mixed-headset {
type plug
slave.pcm "dmix-headset"
}

# Alias for (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.digital {
type plug
slave.pcm "digital-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital {
type hw
card 0
}

# Alias for mixed (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.mixed-digital {
type plug
slave.pcm "dmix-digital"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-digital {
type hw
card 0
}

# The following devices are not useful by themselves. They
# require specific rates, channels, and formats. Therefore,
# you probably do not want to use them directly. Instead use
# of of the devices defined above.

# Alias for analog output on the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.analog-hw {
type hw
card 0
# The default value for device is 0, so no need to specify
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog-hw {
type hw
card 0
}

# Alias for digital (S/PDIF) output on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.digital-hw {
type hw
card 0
device 2
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital-hw {
type hw
card 0
}

# Alias for analog output on the BT Headset (hw:1,0)
pcm.headset-hw {
type hw
card 1
device 0
}
# Control device (mixer, etc.) for the BT Headset
ctl.headset-hw {
type hw
card 1
}
# Direct software mixing plugin for analog output on
# the BT headset (hw:1,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-headset {
type dmix
ipc_key 2234
slave {
pcm "headset-hw"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

# Direct software mixing plugin for analog output on
# the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-analog {
type dmix
ipc_key 1234
slave {
pcm "analog-hw"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-analog {
type hw
card 0
}

# Control device (mixer, etc.) for the BT headset
ctl.dmix-headset {
type hw
card 0
}

# Direct software mixing plugin for digital (S/PDIF) output
# on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-digital {
type dmix
ipc_key 1235
slave {
pcm "digital-hw"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-digital {
type hw
card 0
}

Last edited by Xplosion; 08-03-2006 at 09:54 AM.
 
Old 08-06-2006, 07:17 PM   #3
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
Some feedback on success would be appreciated.

Cheers X
 
Old 08-19-2006, 05:28 PM   #4
cjspinelli
LQ Newbie
 
Registered: Feb 2005
Location: CA
Distribution: SUSE 10.1
Posts: 19

Rep: Reputation: 0
Thumbs down Thanks for help, but still does not work.

Xplosion,

I have an ASUS A7N8X Deluxe motherboard with the SoundStorm on-board sound. I am using SUSE 10.1. Since the nVIDIA driver does not work with the current kernel I am trying to get digital sound back out of my computer. I block copied your /etc/asound.conf file into my own. However, when I tried aplay here is what I got:

cjspinelli@ASUS-A7N8X-Deluxe:~/Documents> aplay -D dmix-digital CRICKET.WAV
ALSA lib pcm_direct.c:224make_local_socket) connect failed: : Invalid argument
ALSA lib pcm_dmix.c:895snd_pcm_dmix_open) unable to connect client
aplay: main:547: audio open error: Invalid argument

Any thoughts? Also, can you tell me what you have in your /etc/modprobe.d/sound file. Here is mine:

#alias snd-card-0 snd-intel8x0
#alias sound-slot-0 snd-intel8x0

###################
### Sound Stuff ###
###################

# ALSA portion
alias snd-card-0 snd-intel8x0
options snd-intel8x0 ac97_clock=47470
# OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

One last question. Are you using a .asoundrc file in your /home/<user> directory? If so what is in it? Thanks for your help!

Chris
 
Old 08-21-2006, 09:18 AM   #5
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
Hello Chris,


I recently upgraded to 10.1 (installed from scratch due to HD crash) as well but the setup remained the same.

I copied the old /etc/asound.conf onto the new system and all run well the
/etc/modprobe.d/sound was created by yast using autodetect and setup. No manual tweaking.

Here its is:

options snd-intel8x0 enable=1 index=0

# H0_h.P9eEQRV1gX9:nForce2 AC97 Audio Controler (MCP)
alias snd-card-0 snd-intel8x0


I don't use a local .asoundrc, because I have no reason for user specific settings.

Reagarding your failure with aplay I need to guess a little, but output looks like the alsa driver has problems to access the HW. Could this be because you load other sound drivers ? From your /etc/modprobe.d/sound it looks like you are using oss drivers or emulation as well. That maybe be a conflict but I have no real expereince with this.

To provide more info do an

aplay -l

Output like this:

**** List of PLAYBACK Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 2: Intel ICH - IEC958 [NVidia nForce2 - IEC958]
Subdevices: 0/1
Subdevice #0: subdevice #0

This will show your alsa devices. You can see from mine that card 0 device 2 is the digital output; hich matches the asound.conf.


If you do

hwinfo --sound (as root)

you get a summary of your sound devices and also information on which driver is used.

Here is mine

22: PCI 05.0: 0401 Multimedia audio controller
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_10de_6b
Unique ID: CvwD.ROy3Sw2kIzD
SysFS ID: /devices/pci0000:00/0000:00:05.0
SysFS BusID: 0000:00:05.0
Hardware Class: sound
Model: "Micro-Star International nForce Audio Processing Unit"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x006b "nForce Audio Processing Unit"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7960
Revision: 0xa2
Memory Range: 0xe0000000-0xe007ffff (rw,non-prefetchable)
IRQ: 5 (no events)
Module Alias: "pci:v000010DEd0000006Bsv00001462sd00007960bc04sc01i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown

23: PCI 06.0: 0401 Multimedia audio controller
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_10de_6a
Unique ID: H0_h.P9eEQRV1gX9
SysFS ID: /devices/pci0000:00/0000:00:06.0
SysFS BusID: 0000:00:06.0
Hardware Class: sound
Model: "Micro-Star International nForce2 AC97 Audio Controler (MCP)"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x006a "nForce2 AC97 Audio Controler (MCP)"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7960
Revision: 0xa1
Driver: "Intel ICH"
I/O Ports: 0xe400-0xe4ff (rw)
I/O Ports: 0xe800-0xe87f (rw)
Memory Range: 0xe0080000-0xe0080fff (rw,non-prefetchable)
IRQ: 185 (50670 events)
Module Alias: "pci:v000010DEd0000006Asv00001462sd00007960bc04sc01i00"
Driver Info #0:
Driver Status: i810_audio is not active
Driver Activation Cmd: "modprobe i810_audio"
Driver Info #1:
Driver Status: snd_intel8x0 is active
Driver Activation Cmd: "modprobe snd_intel8x0"
Config Status: cfg=yes, avail=yes, need=no, active=unknown


Have you tried aplay -D mixed analog file.wav? Just to see if at least your analog output works.


I like to provide more help, right now I don't know where to look further. If you provide some more details I will check what I can find for you.

Until Then

Cheers X (Ulf)




Additional Updates

aplay -D mixed-digital file.wav is the correct way to use since it takes also care of rate conversion.


BTW I stripped the /etc/asound.conf to minimal config. (I don't use BT Headset) Furthermore since I discovered some issue with my analog output I needed to change the ipc_key for dmix-analog. I lack the understanding why! The key seemed unique to me.



Here is the new version.

# Override the default output used by ALSA.
# If you do not override the default, your default
# device is identical to the (unmixed) analog device
# shown below. If you prefer mixed and/or digital
# output, uncomment the appropriate four lines below
# (only one slave.pcm line).
pcm.!default {
type plug
## Uncomment the following to use mixed analog by default
#slave.pcm "dmix-analog"
## Uncomment the following to use unmixed digital by default
# slave.pcm "digital-hw"
## Uncomment the following to use mixed digital by default
slave.pcm "dmix-digital"
}

# Alias for analog output on the nForce2 (hw:0,0)
# - This is identical to the device named "default"--which
# always exists and refers to hw:0,0 (unless overridden)
# - Therefore, we can specify "hw:0,0", "default", or "analog"
# to access analog output on the nForce2

pcm.analog {
type plug
slave.pcm "analog-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog {
type hw
card 0
}

# Alias for (rate-converted) mixed analog output on the
# nForce2 (hw:0,0)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the dmix plugin
# (in this case 48000Hz)
pcm.mixed-analog {
type plug
slave.pcm "dmix-analog"
}


# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-analog {
type hw
card 0
}


# Alias for (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.digital {
type plug
slave.pcm "digital-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital {
type hw
card 0
}

# Alias for mixed (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
# - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.mixed-digital {
type plug
slave.pcm "dmix-digital"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-digital {
type hw
card 0
}

# The following devices are not useful by themselves. They
# require specific rates, channels, and formats. Therefore,
# you probably do not want to use them directly. Instead use
# of of the devices defined above.

# Alias for analog output on the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.analog-hw {
type hw
card 0
# The default value for device is 0, so no need to specify
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog-hw {
type hw
card 0
}

# Alias for digital (S/PDIF) output on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.digital-hw {
type hw
card 0
device 2
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital-hw {
type hw
card 0
}


# Direct software mixing plugin for analog output on
# the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-analog {
type dmix
ipc_key 1634
slave {
pcm "analog-hw"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-analog {
type hw
card 0
}


# Direct software mixing plugin for digital (S/PDIF) output
# on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-digital {
type dmix
ipc_key 1235
slave {
pcm "digital-hw"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-digital {
type hw
card 0
}
 
Old 08-24-2006, 11:24 PM   #6
cjspinelli
LQ Newbie
 
Registered: Feb 2005
Location: CA
Distribution: SUSE 10.1
Posts: 19

Rep: Reputation: 0
Thumbs up Working, but still have questions. . .

Sorry for the delay, I have been very busy. In fact I will be out of town next week so there might be another delay in my response...

Here is the output from aplay -l :

**** List of PLAYBACK Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 2: Intel ICH - IEC958 [NVidia nForce2 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0

It is almost exactly like yours. The only difference is on the "Subdevices: 1/1" line under "device 2". Yours says "Subdevices: 0/1" not "1/1" like mine.

Here is the listing from hwinfo --sound :

22: PCI 05.0: 0401 Multimedia audio controller
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_10de_6b
Unique ID: CvwD.qyqz+ivM2bE
SysFS ID: /devices/pci0000:00/0000:00:05.0
SysFS BusID: 0000:00:05.0
Hardware Class: sound
Model: "ASUSTeK nForce Audio Processing Unit"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x006b "nForce Audio Processing Unit"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x0c11
Revision: 0xa2
Memory Range: 0xe7000000-0xe707ffff (rw,non-prefetchable)
IRQ: 5 (no events)
Module Alias: "pci:v000010DEd0000006Bsv00001043sd00000C11bc04sc01i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown

23: PCI 06.0: 0401 Multimedia ainfo udio controller
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_10de_6a
Unique ID: H0_h.AyAc5dtQ3r5
SysFS ID: /devices/pci0000:00/0000:00:06.0
SysFS BusID: 0000:00:06.0
Hardware Class: sound
Model: "ASUSTeK nForce2 AC97 Audio Controler (MCP)"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x006a "nForce2 AC97 Audio Controler (MCP)"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x8095
Revision: 0xa1
Driver: "Intel ICH"
I/O Ports: 0xd000-0xd0ff (rw)
I/O Ports: 0xd400-0xd47f (rw)
Memory Range: 0xe7080000-0xe7080fff (rw,non-prefetchable)
IRQ: 193 (2931 events)
Module Alias: "pci:v000010DEd0000006Asv00001043sd00008095bc04sc01i00"
Driver Info #0:
Driver Status: i810_audio is not active
Driver Activation Cmd: "modprobe i810_audio"
Driver Info #1:
Driver Status: snd_intel8x0 is active
Driver Activation Cmd: "modprobe snd_intel8x0"
Config Status: cfg=yes, avail=yes, need=no, active=unknown

Once more the output is almost identical to yours, minus the differences in motherboard manufacturers.

I tried the aplay command again and here is the output:

first the digital:

ASUS-A7N8X-Deluxe:/home/cjspinelli # aplay -D dmix-digital makinguphistory.wav
aplay: test_wavefile:731: can't play not PCM-coded WAVE-files

then the analog:

ASUS-A7N8X-Deluxe:/home/cjspinelli # aplay -D dmix-analog makinguphistory.wav
aplay: test_wavefile:731: can't play not PCM-coded WAVE-files

By the way I played the makinguphistory.wav file in XMMS and it sounded great. On another note, I wanted to let you know that I am getting some sound out of my system. I hear the boot-up sound and shut-down sound. Also, the error sounds during normal operations are coming through fine. I fact I can even get sound out of Xine when I play DVDs but it is stereo, NOT digital. I am trying to get the digital part to work. I wanted to make sure you knew where I was at in this process.

Ok I tried I different .wav file and it worked!

ASUS-A7N8X-Deluxe:/home/cjspinelli # aplay -D mixed-digital CRICKET.WAV
Playing WAVE 'CRICKET.WAV' : Unsigned 8 bit, Rate 11025 Hz, Stereo

It sounded great! However, when I tried the "mixed-analog" version, aplay said it was playing but no sound came out of the speakers. Also, it says "Stereo", but I want "S/PDIF" output. Is there a way to get the S/PDIF?

One last note, I tried Xine again with a DVD (Pirates of the Caribbean) and still only get the Stereo output. Thanks for all of your help, I hope to get digital output from this motherboard again in Linux sometime soon!

Chris

Last edited by cjspinelli; 08-24-2006 at 11:27 PM.
 
Old 08-26-2006, 01:45 AM   #7
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
I am a little confuised now.
>
>
>Ok I tried I different .wav file and it worked!
>
>ASUS-A7N8X-Deluxe:/home/cjspinelli # aplay -D mixed-digital CRICKET.WAV
>Playing WAVE 'CRICKET.WAV' : Unsigned 8 bit, Rate 11025 Hz, Stereo

If this works as you say, than you are alomost there. The reason why it says stereo is because aplay plays only stereo.
But can you confrim that you can hear sound using the the digital output (optical SPDIF) by this method.
If so we can work out how to setup xine to play 5.1 sound.

Ulf
 
Old 08-26-2006, 01:47 AM   #8
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
> ASUS-A7N8X-Deluxe:/home/cjspinelli # aplay -D dmix-digital makinguphistory.wav
> aplay: test_wavefile:731: can't play not PCM-coded WAVE-files

This is a file format issue only!
 
Old 08-26-2006, 08:57 AM   #9
cjspinelli
LQ Newbie
 
Registered: Feb 2005
Location: CA
Distribution: SUSE 10.1
Posts: 19

Rep: Reputation: 0
X,
My computer is connected to a Cambridge SoundWorks DTT3500 decoder via a coaxial cable, not an optical cable. Do I need to use an optical cable? The digital output has worked before without an optical cable.
When the Cambridge hardware detects a digital signal a little green light comes on at the bottom of the unit. Although I am hearing sound out of the speakers (the front left and front right, nothing out of the center or rear speakers), the light does not illuminate. I want the computer to send a digital signal that the Cambridge hardware will decode, (i.e, "passthrough"). This might not be possible, which is fine, because the Cambridge hardware will also take an already decoded signal and play it as well.
I do not have any anything connected to the analog outputs on the back of the computer, that is why I do not hear any sound why I try to use "mixed-analog". Bottom line: I am getting sound out through the digital channel (i.e., coxial cable), I just can not seem to get 5.1 sound, only stereo. Let me know if you have more questions.

Chris
 
Old 08-26-2006, 12:02 PM   #10
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
That explains why your aplay -l shows additinalo subdevices. I don't have a coaxial jack, so no such subdevice. I use optical only.

Reagrding the passthrough. I need to double check, Whenenver I want to use passthrough I use mplayer.

It is too late today for me to check this out and document. I post it soon. Regarding xine and passthrough I need to research myself, I don't think I had this working.

Ulf
 
Old 08-26-2006, 11:06 PM   #11
cjspinelli
LQ Newbie
 
Registered: Feb 2005
Location: CA
Distribution: SUSE 10.1
Posts: 19

Rep: Reputation: 0
Cool Thanks!!!

X,

Thanks for the help! Do you think I should get an optical cable? I will get one anyway, just for testing purposes. I am leaving tomorrow morning early, and will not be back until late Thursday evening, so you won't hear from me until then. Thanks again!

Chris
 
Old 08-27-2006, 02:12 AM   #12
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
It should work with either optical or coaxial.

Have a good trip

I will need to do some reaerch myself and I will post some test case later.

Best Regards

Ulf
 
Old 08-30-2006, 06:10 AM   #13
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
Chris

I tested the following.

Using mplayer and an AC3 encoded AVI.

mplayer -ao alsa:device=default -ac hwac3 Lucas Art Thx Test (Divx 5.01) Ac3 384kbps.avi

or

mplayer -ao alsa:device=hw=0.2 -ac hwac3 Lucas Art Thx Test (Divx 5.01) Ac3 384kbps.avi

I get passthrough sound and my amplifier reports Dolby Digital Signal. (equivalent to your green light I guess).

Now xine.... 3 days later

In xine you can set "Speaker Arrangment" Pass Through. That should do the job but it crashes my xine.

>Dies ist xine (X11 gui) - Ein freier Video-Player v0.99.4cvs.
>(c) 2000-2004 Das xine Team.
>xiTK received SIGSEGV signal, RIP.

I did a little debugging but could resolve the issue yet. Though I have a few ideas. Be patient with me I am a little busy right now.

Cheers

Ulf
 
Old 08-31-2006, 09:29 AM   #14
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
Next Update:


For xine I needed to setup the following.

In the audio settings: (needs expert level setting in the GUI Tab)

For Mono hw:0,2
For Stereo hw:0,2
For 5.1 (Pass Through) hw:0,2
Speaker Arrangement: Pass Through

All the rest I left (needed to leave in default).

Some web sites suggest to set it to iec958 or spdif, but that does not seem to work for my setup nforce2.

Cheers Ulf
 
Old 08-31-2006, 09:32 AM   #15
Xplosion
LQ Newbie
 
Registered: Aug 2006
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
And don't forget to set the IEC958 switch to off. (alsamixer). I need to do this everytime a new application accesses the digital out.

Ulf
 
  


Reply

Tags
asound, asoundconf, digital, nforce2, sound, spdif, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC'97 Conexant audio (aka, AC-Link Audio) (Gateway 7510GX) Vexamus Linux - Hardware 25 10-07-2009 09:15 PM
LXer: Device Profile: Trinity Audio Group portable digital audio workstation LXer Syndicated Linux News 0 07-07-2006 01:03 AM
Realtek AC'97 Audio Help PaiinKiilla Linux - Hardware 3 06-17-2006 12:29 PM
Audio AC'97 Problem linux_freak01 Linux - Hardware 3 02-09-2005 05:46 PM
Configuring AC'97 Audio on RHL8.0 divoibs Linux - Software 5 09-07-2004 04:57 PM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration