LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-29-2007, 09:20 AM   #1
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Rep: Reputation: 15
Create Folders /shared partition VFAT


Hi everyone.
I can`t create folder in my /shared partition VFAT. (I am using a dual boot system). Is there a solution?

Kind Regards
 
Old 12-29-2007, 09:34 AM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Hi,

Why can't you create the folder?

If you don't say what errors are you seeing, we can't help, just make asumptions...


I'll will go with the options you're using to mount that partition, either you're mounting the partition without rw option or with an umask that is blocking write access to users (this will be true if you can only write by being root in that partition)

The more information you give about errors, more helpfull answers you'll get.




Regards
 
Old 12-29-2007, 10:11 AM   #3
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
I agree with Acron. You may want to read this: How to ask a question.
 
Old 12-29-2007, 11:19 AM   #4
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Acron_0248 View Post
Hi,

Why can't you create the folder?

If you don't say what errors are you seeing, we can't help, just make asumptions...


I'll will go with the options you're using to mount that partition, either you're mounting the partition without rw option or with an umask that is blocking write access to users (this will be true if you can only write by being root in that partition)

The more information you give about errors, more helpfull answers you'll get.




Regards
Hi Acron_0248.
I am newbie so I am not doing it from the command line yet. The purpose of this partition is to share data between Windows and Linux. I saved files to /shared partition already and it`s possible, I did with wget command. I can`t show an error message for this but only for a similar situation when I copy&paste a file from /home partition for example to /shared the following message occurs:
"error while copyinf to /shared you don`t have permission to write to this folder".
when exploring folders when I open /shared partition in the file menu I am unable to to select "create folder".
I am know it`s a basic question, sorry for being vague and for my english language.

Regards
Thanks in Advance.
 
Old 12-29-2007, 12:04 PM   #5
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by Kryptos View Post
"error while copyinf to /shared you don`t have permission to write to this folder".
Are you sharing a directory from a Windows XP Professional or Windows 2000 system? They have some extra permission settings that can prevent sharing their directories easily. We have this problem at work when we try to share directories on Windows XP Pro machines.

The only way I know to fix the problem is to boot the machine in rescue mode and login as Administrator. When you do this, some hidden settings for directories show up when you look at the properties tabs.
 
Old 01-05-2008, 03:42 PM   #6
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by David1357 View Post
Are you sharing a directory from a Windows XP Professional or Windows 2000 system? They have some extra permission settings that can prevent sharing their directories easily. We have this problem at work when we try to share directories on Windows XP Pro machines.

The only way I know to fix the problem is to boot the machine in rescue mode and login as Administrator. When you do this, some hidden settings for directories show up when you look at the properties tabs.
Hi David1357,
When I installed Fedora 8 I didn`t know what would be the behavior of the system and I tried to create a partition dedicated to share data between Windows XP and Linux. Actually I noticed that I can read and write to Windows partition by default which is NTFS. My problem it`s another one now, I want to install a program and don`t have enough disk space to do it unless I use that partition dedicated to share data with windows or try to install it in the Windows partition. The problem as I explained before it`s about permissions, I need to know how to change them, I don`t understand how can I create folders, delete files and everything in the windows NTFS partition but I can`t do it with the /shared VFAT partition.
I didn`t understand clearly why should boot the machine in rescue mode. How do I boot in rescue mode? If the hidden settings for directories appear I just need to change them? Is there another way to do it?
If I save the program in NTFS (which have a lot of space) would exist any risk for the OS or the software?

Thanks Again.
Regards.
 
Old 01-05-2008, 04:23 PM   #7
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
How are you mounting the vFat partition?

You could try using this from command line as root:
Code:
mount -t vfat -o umask=0000 /dev/device /mount/point
Or use the fstab with a line like:
Code:
/dev/device   /mount/point    vfat    umask=0000   0  0
That should give you read and write access in the vfat partition. Replace /dev/device for the correct path to device in your system and /mount/point with the path you want to mount the partition


And no, save the program in the ntfs partition, shouldn't be risky for the OS or the software




Regards

Last edited by Acron_0248; 01-05-2008 at 04:24 PM.
 
Old 01-05-2008, 05:07 PM   #8
marciobarbalho
Member
 
Registered: Dec 2007
Location: Brazil
Distribution: slackware 13
Posts: 151

Rep: Reputation: 30
customize your fstab like this:

Code:
/dev/hdaX  /mnt/partition vfat defaults,users,uid=1000,umask=000   0 0
reboot system!
it never fails!

Last edited by marciobarbalho; 01-05-2008 at 05:12 PM.
 
Old 01-06-2008, 01:36 PM   #9
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Acron_0248 View Post
How are you mounting the vFat partition?

You could try using this from command line as root:
Code:
mount -t vfat -o umask=0000 /dev/device /mount/point
Or use the fstab with a line like:
Code:
/dev/device   /mount/point    vfat    umask=0000   0  0
That should give you read and write access in the vfat partition. Replace /dev/device for the correct path to device in your system and /mount/point with the path you want to mount the partition


And no, save the program in the ntfs partition, shouldn't be risky for the OS or the software




Regards
Hi.
I am a very inexperienced Linux user, so everything must very detailed in order to perform a task, sorry about my ignorance.
When I installed Linux I typed a mounting point for that partition in question: /shared.
I will try to give you information about permissions, checking the permission tab for /shared we have:

Owner: root, Folder Access: create and delete files (I can`t do it using GUI I just can read file or copy&paste them to another partition, but curiously if I type in the command line wget -P /shared/1 www.sapo.pt I can save a webpage there, that`s a contradiction.)

Group: root, Folder Access: access files

Others, Folder Access: access files

Execute: allow executing files as program

As I am explaining I can read files from /shared.

I tried to follow your instructions but I can`t remember how to check the path to the device in my system, and the mounting point desired would be the same: /shared. how do I check the device path?

On the other hand I don`t know how to use fstab.
I typed /etc/fstab in the terminal as root and it says always:
-bash: /etc/fstab: Permission denied
If I could edit fstab should just write there /dev/device /shared vfat umask=0000 0 0 or this is typed in the command line?
After that, I just close the terminal? Should I save the file? Please clarify...

Thanks Again,
Regards
 
Old 01-06-2008, 01:56 PM   #10
marciobarbalho
Member
 
Registered: Dec 2007
Location: Brazil
Distribution: slackware 13
Posts: 151

Rep: Reputation: 30
open the terminal
as root:
type "su" (no ", of course)
type "the password"
choose a text editor like vim, gedit, kwrite ...

type:
vim /etc/fstab
press "i" (insert) to edit fstab
edit fstab like this:
Code:
/dev/hdaX  /mnt/partition  vfat defaults,users,uid=1000,umask=000   0  0
"X" can be 1, 2, 3 ... it depends on your system, or, maybe sda1, sda2, sda3...

"partition" can be any folder you did choose or create previously (as root, mkdir /mnt/shared)

press "ESC" then type :wqa, fstab file will be saved and vim editor closed.

logout from system and reboot your machine!

Last edited by marciobarbalho; 01-06-2008 at 02:05 PM.
 
Old 01-08-2008, 10:24 AM   #11
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Hi marciobarbalho.
the output for vim /etc/fstab is:

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
/dev/VolGroup00/LogVol01 /home ext3 defaults 1 2
LABEL=/shared /shared vfat defaults 0 0
LABEL=/boot1 /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda3 swap swap defaults 0 0
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"/etc/fstab" [readonly] 9L, 686C 1,1 All

I don`t know how to write the code here. Would I replace the code for /shared, VFAT for what? I don`t know what hdX or sdX means and what will be the value of X. can you help me? Why in your advice we use /mnt/shared instead of /shared? I would like that the path for that partition would be only /shared, is that possible? I am talking about the line of code you suggested:
/dev/hdaX /mnt/partition vfat defaults,users,uid=1000,umask=000 0 0
Can you help me?

Thanks Again,
Regards.

Last edited by Kryptos; 01-08-2008 at 10:25 AM.
 
Old 01-08-2008, 10:46 AM   #12
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Please, post the output of:
Code:
# fdisk -l


Regards
 
Old 01-08-2008, 12:47 PM   #13
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Acron_0248 View Post
Please, post the output of:
Code:
# fdisk -l


Regards
Hi Acron_0248.

the output is:
[root@localhost ~]# fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbd30bd30

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2611 20972826 7 HPFS/NTFS
/dev/sda2 2612 2624 104422+ 83 Linux
/dev/sda3 2625 2879 2048287+ 82 Linux swap / Solaris
/dev/sda4 2880 4864 15944512+ 5 Extended
/dev/sda5 2880 4211 10699258+ 8e Linux LVM
/dev/sda6 4212 4864 5245191 b W95 FAT32

Disk /dev/dm-0: 7314 MB, 7314866176 bytes
255 heads, 63 sectors/track, 889 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 3590 MB, 3590324224 bytes
255 heads, 63 sectors/track, 436 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table
[root@localhost ~]#


Now I know that /shared is /dev/sda6.
I must type: /dev/sda6 /mnt/shared VFAT defaults, users, uid=1000, umask=000 and I am able to change fstab, am I right? Do you agree with need solution? Please answer my last questions...

Thanks.
 
Old 01-08-2008, 01:06 PM   #14
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Just to clarify...

Don't refer /shared as /mnt/shared, aren't the same...

This " / " is root, where /bin, /usr, /var, /sbin and so on are at, if you go to the console and type:
Code:
mkdir /shared
You'll create /shared, not /mnt/shared

I'm telling you this so you don't get any errors trying to mount something in the wrong mount point

And yes, the solution is good you could avoid using uid=1000 since first of all, you can't assume that in your system the User IDentification number is 1000, even when is common to most distributions, could be 1001, secondly because using 'users' in the fstab will refer to uid=xxxx and finally because umask=xxxx set the access rights to users so, you 'could say' that umask replace the options 'users' and 'uid'




Regards

Last edited by Acron_0248; 01-08-2008 at 01:09 PM.
 
Old 01-12-2008, 11:07 AM   #15
Kryptos
Member
 
Registered: Nov 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Not solved yet.

Quote:
Originally Posted by Acron_0248 View Post
Just to clarify...

Don't refer /shared as /mnt/shared, aren't the same...

This " / " is root, where /bin, /usr, /var, /sbin and so on are at, if you go to the console and type:
Code:
mkdir /shared
You'll create /shared, not /mnt/shared

I'm telling you this so you don't get any errors trying to mount something in the wrong mount point

And yes, the solution is good you could avoid using uid=1000 since first of all, you can't assume that in your system the User IDentification number is 1000, even when is common to most distributions, could be 1001, secondly because using 'users' in the fstab will refer to uid=xxxx and finally because umask=xxxx set the access rights to users so, you 'could say' that umask replace the options 'users' and 'uid'




Regards
Hi,
I can edit fstab and type:
/dev/sda6 /mnt/shared vfat umask=0000 0 0
but I can`t close and save fstab.
by the way, should I do this first:
mkdir /mnt/shared
????
Please tell me how to do without edit fstab.
may be my problem now it`s related with vim.

Regards
 
  


Reply

Tags
access, partitions, vfat, write


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Create a dual boot with shared vfat Oh Cisco Debian 15 02-09-2006 09:07 PM
Samba can create new files and folders but access denied in any new folders k.king Linux - Networking 2 01-15-2006 07:14 AM
vfat or fat32 for shared partition? daTerminehtor Linux - Newbie 11 01-12-2006 07:13 PM
Permission problems in a vfat shared partition ReachingFarr Linux - Newbie 4 10-04-2004 08:09 AM
Create bootable VFAT partition from Linux ugenn Linux - Software 2 04-29-2004 01:27 PM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration