LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2004, 07:57 PM   #1
hybrid0006
LQ Newbie
 
Registered: Jul 2004
Location: Washington
Distribution: Knoppix-std
Posts: 7

Rep: Reputation: 0
Configuring Wireless


Okay, I finally got Knoppix 3.4 running and I am wondering how I connect to my wireless. I am using my laptop and I have a integrated wireless card. Where do I go to configure or whatever I need to do to connect.
 
Old 07-15-2004, 10:09 PM   #2
czechknight93
Member
 
Registered: Aug 2003
Location: Weatherford, OK
Distribution: openSUSE 10.1
Posts: 95

Rep: Reputation: 15
You first need to determine if you have the proper drivers. To find the proper drivers, you will need to determine the chipset of your wireless adapter (this can be determined by going to the compatibility chart on the web site below). A lot of them are in a package called "wireless-tools" and it is found on most Linux distributions. The wireless-tools package is very necessary for wireless networking in Linux (Knoppix may have this built in). You may also need to visit the Linux wlan project at www.linux-wlan.org. This site has a lot of info on wireless adapters and drivers, along with a compatibility chard for nearly every wi-fi adapter. I don't have much to say about setting up the network. I have always purchased a wi-fi card that is known to work in Linux, like the Lucent Orinoco Gold 802.11b card (expensive, but Linux likes it). I have never had to worry about connection, because Linux is good about handling that, if you have the proper drivers. If Knoppix detects your wireless adapter, which it is very good at doing, you will need to locate and run the network utility. I am not sure what it is called in Knoppix because I use Mandrake with the GNOME desktop. I hope that I have helped you in some way. Good luck!

Billy
 
Old 07-15-2004, 10:52 PM   #3
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
if you dmesg > grep "manfid" you get some output that may help, with this output add something like

card "Prism Wireless card"
manfid 0x50c2, 0x7300
bind "orinoco_cs"

to the wireless section of /etc/pcmcia/config file, trying different bindings till you get one that takes! Hope this helps
 
Old 07-16-2004, 04:36 PM   #4
hybrid0006
LQ Newbie
 
Registered: Jul 2004
Location: Washington
Distribution: Knoppix-std
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks guys. I will have to test some of this stuff out.
 
Old 07-18-2004, 04:41 AM   #5
manticore
LQ Newbie
 
Registered: Jul 2004
Location: /planet Earth
Distribution: Mandrake10 Official
Posts: 4

Rep: Reputation: 0
knoppix on satelliteA10

I ran knoppix 3.4 on a satelliteA10 and it configures the wireless by itself flawlessly, Identifying the driver as orinoco_cs for the intersil card. I did an install and to the HD and it works great, except I was only able to do this with the 128-bit encryption on my D-LinkDI-714P+ turned off. So I tried to set the WEP key up by using wlcardconfig as suggested in another thread that I had read. I followed through the steps and then rebooted the laptop after setting the encryption back on. Now it told me that it could no longer find eth0, I tried it again and I'm pretty sure I set the it up correctly and still nothing. Has anyone had a similar problem and then found a solution?
 
Old 07-18-2004, 03:54 PM   #6
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
set it up with the encryption turned off, then use something like iwconfig to set the encryption key?
 
Old 07-20-2004, 02:54 PM   #7
hybrid0006
LQ Newbie
 
Registered: Jul 2004
Location: Washington
Distribution: Knoppix-std
Posts: 7

Original Poster
Rep: Reputation: 0
Well I got it to work with an internet cable but wireless is still not working. I am using a Dell Wireless 1450 card a/b/g card. If that helps. If anyone has any other responses/ideas please inform me. THanks
 
Old 07-20-2004, 03:13 PM   #8
czechknight93
Member
 
Registered: Aug 2003
Location: Weatherford, OK
Distribution: openSUSE 10.1
Posts: 95

Rep: Reputation: 15
Somehow you need to set your gard to "b" only mode. As far as I am aware, Linux does not support "a" or "g" wireless or even "a/b/g" wireless. Have you checked www.linux-wlan.org to see if your card is supported in the project? If so, you may need to download the project and configure the packages. The website offers a great tutorial on their home page. Look for the FAQs and the ReadMe file. I'll tell you that these packages may be confusing or tough for a newbie, but if you go along with the ReadMe, you'll do just fine. If you have any more questions, feel free to ask. You can also check the forum on LinuxQuestions.org for Linux Wireless networking. It is located under networking on the forum page.

Billy
 
Old 07-22-2004, 09:18 AM   #9
manticore
LQ Newbie
 
Registered: Jul 2004
Location: /planet Earth
Distribution: Mandrake10 Official
Posts: 4

Rep: Reputation: 0
OK, back to Knoppix and wireless. Still trying to get the system to accept the WEP key. I've tried a few times now to set this up with "Wavelan configuration" under the applications menu; "knoppix">"internet">"wavelan". Doesn't anybody know what I'm talking about? I've tried to set it up in this way, and when I do it somehow deletes the driver or configuration for the wireless card. Wireless no longer works and it no longer wants to detect the wireless card. Now when I go through this setup should I be leaving all the values blank except for the WEP key? It asks for stuff like ESSID, which it advises not toleave blank for "any"; should I type in "any" instead of the actual ESSID name? I put in "managed" mode, cause I know this is the default setting. I guess I'm just gonna have to keep trying different things until it works, except its a pain to have to keep reinstalling knoppix everytime I go through this and the wireless gets messed up. Hey, I'm still fairly new to linux so in many ways I feel like much of this is guesswork.
BTW, the wireless laptop belongs to my girlfriend; its a Toshiba SAtellite A10 P4, 512 RAM. Like me my girl got sick of windows and when she saw me using linux she said "ooh! I want that!" Yeah, so we've tried Mandrake(and it didn't work for wireless) and now knoppix. Suggestions would be much appreciated. Thanks in advance!!!
 
Old 07-22-2004, 06:30 PM   #10
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
heck, i'm using mandrake, and wireless right now... but i am afraid i can't help you with knoppix, but could you set your wep with iwlist wi0 key or iwconfig ie:
iwconfig eth0 key 0123-4567-89
iwconfig eth0 key restricted [3] 0123456789
iwconfig eth0 key 01-23 key 45-67 [4] key [4]
 
Old 07-23-2004, 02:34 AM   #11
czechknight93
Member
 
Registered: Aug 2003
Location: Weatherford, OK
Distribution: openSUSE 10.1
Posts: 95

Rep: Reputation: 15
manticore,

Quote:
Yeah, so we've tried Mandrake(and it didn't work for wireless) and now knoppix.
Mandrake is one of the best for wireless, in my experience. I have tried many distributions, such as: Red Hat, Suse, Knoppix, SLAX, and of course Mandrake. Of all of them, Mandrake has been the EASIEST to set up a wireless network. That's what I'm using right now to post this reply. I have Mandrake 10.0 PowerPack with a Lucent Orinoco 802.11b PCMCIA card. All I did was plug it in and answer a few questions and viola, I am browsing the wireless way. The problem with Linux (this includes ALL distributions) is that in order for wireless networking to work, you first have to have the right card (this is important) and second, the proper drivers (equally or more important). This is true for Knoppix and even Mandrake. You have to make sure you are using a supported chipset. I know this can be a pain, but it makes your life easier when you decide to use a wireless network. I purchased this particular wireless adapter for the sole reason that it was nearly plug-n-play with Linux. I am glad I made that decision because I don't have to configure a wireless connection. It's all built in to the drivers of the Orinoco card I use.

Quote:
It asks for stuff like ESSID, which it advises not toleave blank for "any"; should I type in "any" instead of the actual ESSID name? I put in "managed" mode, cause I know this is the default setting. I guess I'm just gonna have to keep trying different things until it works, except its a pain to have to keep reinstalling knoppix everytime I go through this and the wireless gets messed up.
My card is set with ALL defaults except a couple of things. For the ESSID, I actually typed "any" in the field. For the mode, I selected "Auto." Like you said, a lot of it can be guess work, if you don't have a supported card. As far as your WEP key goes, I personally don't use one. I have seen posts on this site of bad stories of unsuccessful WEP keying. If you want one or need one, I cannot be of much help to you. I really hope you get your wireless working. Good Luck!

Billy
 
Old 07-23-2004, 08:24 AM   #12
manticore
LQ Newbie
 
Registered: Jul 2004
Location: /planet Earth
Distribution: Mandrake10 Official
Posts: 4

Rep: Reputation: 0
Thanks for the feedback! Yeah I did get wireless working with mandrake10 on the laptop, however everytime I'd reboot the computer it would tell me that eth1 had been removed and would I like to set it up again. I often wondered if it was doing this because I have the free download version? Anyway, I'll keep trying with Knoppix for now, heh heh! I'll keep you guys posted on any breakthroughs as is seems I'm not the only one here who has some trouble setting up wireless.
 
Old 07-25-2004, 07:07 PM   #13
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
mine does the same thing, i usually leave it out till i hit the kde splash screen, then pop it in, it works fine. I am also using the free version of mandrake 10
 
Old 08-02-2004, 10:49 PM   #14
manticore
LQ Newbie
 
Registered: Jul 2004
Location: /planet Earth
Distribution: Mandrake10 Official
Posts: 4

Rep: Reputation: 0
Eureka!! I did I re-install with knoppix, this time using option #3"full debian system, the old installer" and now wlcardconfig works fine. Just had to set ESSID name, mode(auto) and WEP key; works like a charm. and yes, the settings were saved after reboot. What may have been happening was that the option#1"Beginner installation" is set up to reconfigure drivers to default settings after a reboot; I'm still not 100% sure this is what it was, but its likely. BTW, the option#3 installation still does all the auto-detection just like knoppix, so I would counsel anyone trying it out to use option#3 for a HD installation. So glad I got that working!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Wireless abelloda Linux - Laptop and Netbook 2 11-11-2005 08:17 AM
Configuring Wireless mtecknology Linux - Software 0 07-29-2005 11:21 AM
help on configuring T-DSL wireless kalyanvgopal Linux - Laptop and Netbook 0 08-29-2004 12:43 PM
Configuring Wireless!? tuxedo-notebook Debian 9 04-21-2004 07:29 PM
configuring wireless.opts tommylkc Linux - Hardware 1 06-28-2002 01:09 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration