LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2004, 07:29 PM   #1
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Rep: Reputation: 15
Config netword card eth0 Debian


Hi everybody and thks for previous answers,
but i have a new problem,
i installed a Knoppix 3.4 Debian distrib, and i want to configure the network card to have an internet acces.
So i launch the wizard and put : (i have a router without firewall)
DHCP broadcast : nothing
IP adress : 10.0.0.100
Netmask : 255.0.0.0
Broadcast : nothing
adress Gateway : 10.0.0.138
Nameserver : plop

and it doesnt work, i dont understand, i put the same parameter on my mandrake, and it worked.
But on mandrake i put the DNS.And on the Debian they dont ask me the DNS adress.

Can anybody help me?i'm lost, thx
 
Old 05-12-2004, 07:54 PM   #2
bureado
Member
 
Registered: Oct 2003
Location: Caracas
Distribution: Knoppix 3.3 (Debian sarge/sid)
Posts: 72

Rep: Reputation: 15
Most of the modems I have seen configure automatically under Linux (also under Windows, but with lots of problems). That means that the modem does the authentication and so on and then establishes the eth0 connection. User is connected to the Internet with no further interaction. Try doing 'ifconfig' and look what is going on. If you do not see a valid 'external' IP address (that is, no 127.0.0.1 neither 10.161.53.209 neither anyone in your LAN) you are having a problem. Using wizards frequently makes more problems.
 
Old 05-12-2004, 07:59 PM   #3
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
DNS=nameserver, whatever you used with mandrake for the DNS put it where debian asks for nameserver; plop whatever that is will not work. If you do not know what your nameserver is ask either your admin or isp.

Tom
 
Old 05-13-2004, 07:59 AM   #4
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Original Poster
Rep: Reputation: 15
ok thank you very much odious, it was the probleme.
But now, i have another probleme.
I succeed to config the network card under KDE thanks to the wizard.
But know i want to configure it with the 'ifconfig' command line.
ip : 10.0.0.100
netmask : 255.0.0.0
gateway:10.0.0.138
DNS:213.36.80.1
so i know that it begin with : ifconfig eth0 10.0.0.100 netmask 255.0.0.0....
but i dont know the follow, especially how to include the nameserver(DNS)
if anyone know the perfect line, it will be great, thx again all.
 
Old 05-13-2004, 08:28 AM   #5
bureado
Member
 
Registered: Oct 2003
Location: Caracas
Distribution: Knoppix 3.3 (Debian sarge/sid)
Posts: 72

Rep: Reputation: 15
I don't really know ifconfig. Try 'man ifconfig', as every app in Linux has their manual page, with very detailed information, probably in your language.
 
Old 05-13-2004, 08:31 AM   #6
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Original Poster
Rep: Reputation: 15
Anybody has another answer?
because i know the man page but i dont find how to put the DNS in the command line.
Thanks
 
Old 05-13-2004, 09:42 AM   #7
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
Your nameserver and gateway really have nothing to do with ifconfig. Your gateway is set in your route tables via route add and nameserver in your resolv.conf file.

What are you trying to accomplish; are your loosing your settings when you reboot?

Tom
 
Old 05-13-2004, 09:48 AM   #8
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Original Poster
Rep: Reputation: 15
When i'm under KDE i don't loose my settings.
But i never succeed to set the parameter under Debian.
I don't try your advise because i'm not at home, but i'll try it later.Thanks a lot.
 
Old 05-13-2004, 12:32 PM   #9
bureado
Member
 
Registered: Oct 2003
Location: Caracas
Distribution: Knoppix 3.3 (Debian sarge/sid)
Posts: 72

Rep: Reputation: 15
(offtopic) Debian and KDE are different things. You're probably running KDE over Debian, as KDE is a window manager and Debian is an operating system.
 
Old 05-13-2004, 01:12 PM   #10
dicou
Member
 
Registered: Apr 2004
Location: Paris
Posts: 44

Original Poster
Rep: Reputation: 15
I know, but i said that i have two sessions, one with KDE and one with fluxbox, but both are under Debian.
And there are the same /etc/network/interfaces and /etc/resolv.conf files in KDE and fluxbox.But i have to reconfigure at each new boot.
When i use the wizard with KDE it works.But with fluxbox i don't success.
I don't understand why...
Thx
 
Old 05-21-2004, 06:58 PM   #11
turbines
LQ Newbie
 
Registered: Apr 2004
Distribution: RedHat 9
Posts: 3

Rep: Reputation: 0
I have connection problem with 3.4 too

I am running Knoppix 3.4 on HDD. When I first boot I have no connection and ifconfig gives the following;

root@knopbox:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:18F:B1:36
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:590 (590.0 b) TX bytes:342 (342.0 b)
Interrupt:20 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:500 (500.0 b) TX bytes:500 (500.0 b)

The I go to the Knoppix Network Card configuration and select eth0 and yes to DHCP. I am then connected OK and ifconfig gives the following;

root@knopbox:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:18F:B1:36
inet addr:192.168.100.11 Bcast:192.168.100.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:349 errors:0 dropped:0 overruns:0 frame:0
TX packets:407 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:139191 (135.9 KiB) TX bytes:70000 (68.3 KiB)
Interrupt:20 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:700 (700.0 b) TX bytes:700 (700.0 b)

When I reboot I have to point to the eth0 card again beefore I connect. How do I make save these settings to boot?

Thank you very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't "make config" whilst attempting wifi card install on Debian Sarge. Keychain Linux - Hardware 3 09-19-2008 11:24 AM
Netword connection Alan Lakin Yoper 4 11-28-2004 08:37 PM
Network card config Debian dicou Linux - Newbie 1 05-13-2004 08:45 AM
Netword Card Installation Help LinuxNewbieGear Linux - Networking 2 09-26-2003 07:30 PM
Mouse, Sound, Netword card problems ludeKing Linux - Newbie 1 07-31-2003 07:38 PM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration