LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2011, 10:55 PM   #1
Fritz_Doll
LQ Newbie
 
Registered: Dec 2010
Posts: 20

Rep: Reputation: Disabled
chmod directory issue


Having trouble with chmod... need to
Code:
sudo chmod 755 -R directory
but whatever I do it doesn't change from 700 and when I try from Properties->Permissions it refuses to change to the requested permissions, I'll change permission for Others to 'Access Files' but it'll immediately change back to 'None'. What is going on here? It is an external-HD but I doubt that has anything to do with it.
 
Old 02-06-2011, 11:49 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
What filesystem is on the external hard drive? If it's (V)FAT, that filesystem does not support owner/group/other permissions. Instead, "global" permissions are set when the drive is mounted (either by an entry in /etc/fstab or with options to the mount command).
 
Old 02-07-2011, 12:08 AM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,356

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
It may also be being mounted read-only...
 
Old 02-07-2011, 12:12 AM   #4
Fritz_Doll
LQ Newbie
 
Registered: Dec 2010
Posts: 20

Original Poster
Rep: Reputation: Disabled
Yup, it was FAT. What filesystem formats allow owner/group/others? Then I'll just change to that.
 
Old 02-07-2011, 12:14 AM   #5
hasmeet.singh337
LQ Newbie
 
Registered: Jan 2011
Posts: 18

Rep: Reputation: 0
Quote:
Originally Posted by Fritz_Doll View Post
Yup, it was FAT. What filesystem formats allow owner/group/others? Then I'll just change to that.
make it ext2 or ext3
 
Old 02-07-2011, 12:16 AM   #6
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 252Reputation: 252Reputation: 252
Ext2, Ext3, Ext4, ReiserFS Reiser4, the list goes on and on. Basically, don't use a Microsoft filesystem.
If you need to access this from a Microsoft box...that's a different problem.
 
1 members found this post helpful.
Old 02-07-2011, 12:24 AM   #7
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by Fritz_Doll View Post
Having trouble with chmod... need to
Code:
sudo chmod 755 -R directory
but whatever I do it doesn't change from 700 and when I try from Properties->Permissions it refuses to change to the requested permissions, I'll change permission for Others to 'Access Files' but it'll immediately change back to 'None'. What is going on here? It is an external-HD but I doubt that has anything to do with it.
Try to remount the external-HD with RW mode and check.
 
Old 02-07-2011, 09:35 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,794

Rep: Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162Reputation: 4162
Quote:
Originally Posted by divyashree View Post
Try to remount the external-HD with RW mode and check.
Uhh, no...the OP posted it was a FAT file system..the problem has nothing to do with RW mode.
 
Old 02-07-2011, 10:28 AM   #9
Fritz_Doll
LQ Newbie
 
Registered: Dec 2010
Posts: 20

Original Poster
Rep: Reputation: Disabled
Thanks for the help. Now the fun of looking up how to change format to ext3
 
Old 02-07-2011, 10:31 AM   #10
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 252Reputation: 252Reputation: 252
You backup your data onto something else, then you reformat the drive whilst attached to a Linux system. Check the man page for mkfs and/or mkfs.ext3.
 
1 members found this post helpful.
Old 02-07-2011, 10:38 AM   #11
Fritz_Doll
LQ Newbie
 
Registered: Dec 2010
Posts: 20

Original Poster
Rep: Reputation: Disabled
Thanks again, This is easier than windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache: difference between chmod 644 and chmod 666 and chmod 600 for output/txt/dat? frenchn00b Programming 6 04-22-2009 01:10 PM
chmod, external usb, vfat - can't chmod a directory itsjustme Slackware 2 04-02-2006 04:23 PM
chmod directory help ycamera2mank Linux - Software 3 10-03-2005 11:43 PM
chmod whole directory waynejkruse10 Linux - Software 5 08-31-2005 04:57 PM
chmod for a group on a certain directory? mfeoli Linux - Newbie 1 02-10-2004 05:13 PM


All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration