LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2004, 01:59 PM   #1
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Rep: Reputation: 30
change icon problems


Just a small problem...

I have my hard drive split between Mandrake and Windows-XP and I just wanted to have easy access to the documents in Windows. So, I just created a desktop link to: file:/mnt/win c, which works just fine. Now, how do I go about changing the icon from the default folder icon to something more personalized?
When I go to Properties and select the current icon I am allowed to browse my icons and select the one I want. The problem is that when I hit okay I get:

Could not save properties. You do not have sufficient access to write to /home/eek/Desktop/win_c/.directory.

Ownership
User: Root
Group: Root

I have read the Quick and Dirty Guide to Perimissions but still am a bit lost.

Anyone care to clear this up a bit for me?
Thanks bunch,
Eric.
 
Old 07-07-2004, 03:42 PM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
IF you know the root password, you could do the following...

su <password>
chown user:group /home/eek/Desktop/win_c/.directory

where user is your username and group is the group to which you belong. To find out what group(s) you belong to, do the following as your regular user (not root)

groups

so, if groups returned "user" as your group, and your username is dave, then it would look like this

chown dave:user /home/eek/Desktop/win_c/.directory

Now try it. If that doesn't work, change the order of user and group, as in

chown group:dave /home/eek/Desktop/win_c/.directory

I'm still a newb so I can't remember which way, but I think it's the first...

If you still can't change it, do the following as root:

chmod 775 /home/eek/Desktop/win_c/.directory

and that should help.

Hope this helps...Good luck...
 
Old 07-07-2004, 09:07 PM   #3
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Hay Jeff, thanks for helping out!

Okay this is what I have tried and what I got:

[root@eek Desktop]# chown user:group /home/eek/Desktop/win_c/.directory
chown: `user:group': invalid user

[root@eek Desktop]# chmod 775 /home/eek/Desktop/win_c/.directory
chmod: cannot access `/home/eek/Desktop/win_c/.directory': No such file or directory

[root@eek Desktop]# chown user:eric /home/eek/Desktop/win_c/.directory
chown: `user:eric': invalid user

In other words, no dice. Is it just a matter of entering it incorrectly?

Thanks for the help,
Eric.
 
Old 07-07-2004, 09:31 PM   #4
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
No problem. Here's what we need to do...

I pointed you to the wrong path for the .directory file. My bad. Do the following as root...

chown eric:eric /mnt/win_c/.directory

and if that works (well, even if it doesn't, but it should), do...

chmod 775 /mnt/win_c/.directory

and if THAT works too, you're good to go...
 
Old 07-08-2004, 10:59 AM   #5
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Again, thanks for helping out Jeff, I did you you said and this is the output.....

[eek@eek Desktop]$ su
Password:

[root@eek Desktop]# chmod 775 /mnt/win_c/.directory
chmod: cannot access `/mnt/win_c/.directory': No such file or directory

[root@eek Desktop]# chown eric:eric /mnt/win_c/.directory
chown: `eric:eric': invalid user

Does the fact that I am in the Desktop matter, say, should I be in home or something?

Eric.
 
Old 07-08-2004, 12:25 PM   #6
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Strange...

Is it possible that you don't have the partition mounted? Try doing

mount /mnt/win_c

and then re-try the chown command. If it still gives you "No such file or directory" then lets dig a little...

try doing

cd /mnt
ls -al

and post the output in a reply. Then, also post the output of

cd /mnt/win_c
ls -al

I'm trying to determine if the file even exists, and also make sure that you're mounting it correctly. Perhaps, while we're at it, you could also post the output from

less /etc/fstab

you should be able to just highlight everything it shows, and then right click it and copy it, so that you can paste it here without re-typing it...

That info should be all we need to figure out what's going on...

post as soon as you're able...
 
Old 07-08-2004, 01:30 PM   #7
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Hello again!

Here where we are....

[eek@eek eek]$ su

Password:

[root@eek eek]# mount /mnt/win_c
mount: /dev/hda1 already mounted or /mnt/win_c busy
mount: according to mtab, /dev/ide/host0/bus0/target0/lun0/part1 is already mounted on /mnt/win_c

[root@eek eek]# cd /mnt

[root@eek mnt]# ls -al
total 20
drwxr-xr-x 5 root root 4096 Jun 18 16:48 ./
drwxr-xr-x 22 root root 4096 Jul 7 14:27 ../
drwxr-xr-x 2 root root 4096 Jun 16 23:31 cdrom/
drwxr-xr-x 3 root root 4096 Jun 19 16:13 hd/
dr-xr-xr-x 1 root root 4096 Jul 1 16:07 win_c/

[root@eek mnt]#

/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda7 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro
,exec 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,
--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0


Thoughts? Ideas?
Eric.
 
Old 07-08-2004, 01:39 PM   #8
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
yep, I think I see the problem... it's this line...

/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0

you'll notice the "ro" towards the end of the line...that is setting it read-only. Edit /etc/fstab so that it is "rw" instead of "ro"

First, do

umount /mnt/win_c

make sure you dont have any windows or terminals browsing win_c before you try to umount it. Then, edit fstab, save it, and do

mount /mnt/win_c

NOw try changing the icon again and see what happens...

Good luck!
 
Old 07-08-2004, 01:42 PM   #9
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Sorry, just another question...how do I go about editing fstab?
 
Old 07-09-2004, 09:29 AM   #10
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
First:

Jeff.......thanks for the help, you were right. I've got the thing changed.

Second:

New question to any who would care to take a look...
I have just changed the icon from the default "blue folder" to a custom icon for the Windows partition, but now I cannot see the files that were there previously, even using the terminal.

Any ideas?
Eric.
 
Old 07-09-2004, 12:52 PM   #11
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Wow, that's an odd one...

First, and most importantly, do the contents re-appear if you change the icon back?

Second, and especially if the contents do not come back, try changing the line in /etc/fstab to this:

/dev/hda1 /mnt/win_c ntfs defaults 0 0

save, and do:

umount /mnt/win_c

and then:

mount /mnt/win_c

If that STILL doesn't do it, add "rw" (no quotes) after defaults, like this:

/dev/hda1 /mnt/win_c ntfs defaults,rw 0 0

And try the above again.

Let us know how it goes...and good luck....
 
Old 07-09-2004, 08:45 PM   #12
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Jeff,

This may seem a bit silly, but how do I use the konsole to edit the fstab?

Eric.
 
Old 07-09-2004, 08:52 PM   #13
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Well, if you're running KDE then use nedit to edit it, as follows:

nedit /etc/fstab &

If you're using Gnome, just replace nedit with gedit. I find these nice as they are similar to the typical windows text editors in that you can cntl-c and cntl-v and all those nifty keyboard shortcuts, and the GUIs are similar. If you like, here's some you can try by replacing the nedit in the above command:

emacs
xemacs
pico

So, once you've got fstab open, just edit the line in question and save. Then remember to do the umount/mount commands to remount the partition.

Good luck...

<edit>pico is actually a bit different, so don't expect the keyboard shortcuts or GUI in that...

Last edited by jeffreybluml; 07-09-2004 at 08:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME - problems with menu editing and icon change VertX Linux - Software 0 04-08-2005 06:49 AM
GNOME - problems with menu editing and icon change VertX Fedora 1 04-08-2005 03:39 AM
How to change a specific Icon lramos85 Linux - Newbie 1 12-05-2003 04:25 PM
change gnome icon yenonn Linux - Newbie 1 05-14-2003 04:30 PM
RedHat ICON change [rapt0r] Linux - General 4 05-03-2003 11:20 AM


All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration