LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2011, 04:27 AM   #1
institopper
LQ Newbie
 
Registered: Mar 2011
Posts: 5

Rep: Reputation: 0
Cant make new folder or copy paste in my newly created partition


I just maked an ext4 partition by the help of gparted. Ubuntu is my only OS no dual boot. Using Ubuntu Maverick
The problem is partition must be open as root to do any work else it wont even allow me to open file,create folder,cut copy paste or anything.
 
Old 03-17-2011, 04:46 AM   #2
hausmasta
LQ Newbie
 
Registered: Apr 2005
Location: Lüneburg, Germany
Posts: 7

Rep: Reputation: 1
Do directories on that partition have correct permissions that allow users other than root to read/write?
 
Old 03-17-2011, 04:47 AM   #3
Soadyheid
Senior Member
 
Registered: Aug 2010
Location: Near Edinburgh, Scotland
Distribution: Cinnamon Mint 17.3 and 18 at present.
Posts: 1,244

Rep: Reputation: 266Reputation: 266Reputation: 266
Welcome to LQ!
Have you formatted and mounted your new partition? You will be unable to use it untill you have added it to your filesystem. You'll also have to add it to fstab to have it mounted each time you boot.

Play Bonny!
 
Old 03-17-2011, 05:11 AM   #4
institopper
LQ Newbie
 
Registered: Mar 2011
Posts: 5

Original Poster
Rep: Reputation: 0
tell me how

thanx frnds but plz tell how to do the aforementioned task
I had formatted it in ext4 filesystem and mounted it too.
Any user can mount it but problem lies as i mentioned above. tell me how to add to fstab

Last edited by institopper; 03-17-2011 at 05:13 AM.
 
Old 03-17-2011, 06:03 AM   #5
hausmasta
LQ Newbie
 
Registered: Apr 2005
Location: Lüneburg, Germany
Posts: 7

Rep: Reputation: 1
What's the output of
Code:
mount
? Is the partition listed?
 
Old 03-17-2011, 06:57 AM   #6
institopper
LQ Newbie
 
Registered: Mar 2011
Posts: 5

Original Poster
Rep: Reputation: 0
output of mount

mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/rahul/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=rahul)
/dev/sda4 on /media/sda4 type ext4 (rw,noexec,nosuid,nodev)
/dev/sda3 on /media/sda3 type ext4 (rw,noexec,nosuid,nodev)

none on /proc/fs/vmblock/mountPoint type vmblock (rw)
/dev/sdc1 on /media/TARANJOT type vfat (rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush)

yep partitions are listed. i have written in bold that portion. i.e. sda3 and sda4
 
Old 03-17-2011, 08:13 AM   #7
Inkit
Member
 
Registered: Feb 2011
Location: India
Distribution: Mint 10
Posts: 142

Rep: Reputation: 15
Hi institopper,
The solution is actually quite simple. When you format a new partition, by default it is assigned to root as the owner. You will therefore have to change the permissions to allow other users to read and write.
Open terminal and type in "sudo nautilus" without the quotes. your system will ask for the admin password. type it in and a window will open. go to whichever partition you created newly. If you are not able to browse using the computer icon on top, go to filesystem > media and you should find your partition there. right click on it and click on permissions at the very bottom and another window should open. go to permissions and change the owner to your ID and close.
I don't know if I've been clear enough but you should be able to access your partition now. Just remember one thing. when you are in root be careful not to delete any files because if you do, and the file is a system required file you have just screwed your system.
 
Old 03-17-2011, 10:24 AM   #8
institopper
LQ Newbie
 
Registered: Mar 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks

It worked like a charm
thanx!!
 
Old 03-17-2011, 08:13 PM   #9
Inkit
Member
 
Registered: Feb 2011
Location: India
Distribution: Mint 10
Posts: 142

Rep: Reputation: 15
Wink

Glad I could be of help. Just one thing though, could you edit your initial post and put solved in front of it. It'll tell others if you still have the problem or not.
 
Old 07-13-2011, 10:05 PM   #10
Dahliar Ananda
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Inkit View Post
Hi institopper,
The solution is actually quite simple. When you format a new partition, by default it is assigned to root as the owner. You will therefore have to change the permissions to allow other users to read and write.
Open terminal and type in "sudo nautilus" without the quotes. your system will ask for the admin password. type it in and a window will open. go to whichever partition you created newly. If you are not able to browse using the computer icon on top, go to filesystem > media and you should find your partition there. right click on it and click on permissions at the very bottom and another window should open. go to permissions and change the owner to your ID and close.
I don't know if I've been clear enough but you should be able to access your partition now. Just remember one thing. when you are in root be careful not to delete any files because if you do, and the file is a system required file you have just screwed your system.
Thanks,it Works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Applying default permissions for newly created files within a specific folder mattydee Linux - Desktop 29 10-30-2016 09:55 PM
default size of a newly created folder dinakumar12 Linux - Server 7 12-06-2010 07:39 AM
Make newly created file executable Black Chaos Linux - General 3 08-03-2006 10:53 AM
Linux can't see newly created partition Dswissmiss Linux - Software 5 05-17-2004 08:05 AM
how do i copy a folder to a newly installed hd dsiguy Linux - General 2 09-24-2003 01:25 PM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration