LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2013, 07:15 PM   #1
iamchairs
LQ Newbie
 
Registered: Apr 2013
Posts: 8

Rep: Reputation: Disabled
Cant get internet to work with any distro.


I'm at my wits end. Ive gone through 5 distros and non of them connect to my internet. I keep going back to my windows partition to try a new one each time but never get any closer. I'm trying to use linux because I use them at work but this is after everything has been installed and such. I never do anything more complicated then file and user managment.

So I just tried to install debian using the network installer but it couldnt configure the dhcp. So I manually input the ip information and continued the install hoping that was enough. After wiping out the previous linux distro I wasnt able to complete the install because it wasnt able to connect to a mirror. I went to the console and tried wget on google but it said it was a bad host or whatever (it was a properly formed http url though). So now I'm grubless and found an old version of ubuntu 9 so I can use grub to get back into windows.

But while I'm in ubuntu 9 I should be able to setup my internet right? If I can do it in ubuntu with your help I may be able to see what I'm doing wrong and not have this problem anymore?

Looking for a little direction. I have no idea what I'm doing.
 
Old 04-07-2013, 08:22 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Are you using wired or wireless network?
Do you know what network card?
 
Old 04-07-2013, 08:28 PM   #3
iamchairs
LQ Newbie
 
Registered: Apr 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
I have both wired and wireless available and connected. An ifconfig shows lo and pan01

I don't know my network card
 
Old 04-07-2013, 08:31 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Try
Quote:
lspci
 
Old 04-07-2013, 08:34 PM   #5
iamchairs
LQ Newbie
 
Registered: Apr 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Ethernet Controller: Intel Corporation Device 1503 (rev 05)
Network Controller: RaLink Device 3090

These look relavent.
 
Old 04-07-2013, 08:42 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,089

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
What distros have you looked at ?
Quote:
But while I'm in ubuntu 9
you are aware that that is very OLD
the current is Ubuntu 12.10

a old and unsupported os will not be able to use new hardware

also those " netinstall" 100 meg images work best if you have a cable connection
dial up or dsl will be a problem

the current Mint 14
http://linuxfreedom.com/linuxmint/li...-dvd-32bit.iso

--- cinnamon desktop
linuxmint-14.1-cinnamon-dvd-32bit.iso


---------- KDE desktop -------------
-- 32 bit
linuxmint-14-kde-dvd-32bit.iso
--64 bit
linuxmint-14-kde-dvd-64bit.iso



or the current fuduntu release
http://www.fuduntu.org/get.php
"Fuduntu-2013.1-i686-LiveDVD.iso"
or
"Fuduntu-2013.1-x86_64-LiveDVD.iso"
 
1 members found this post helpful.
Old 04-07-2013, 08:50 PM   #7
iamchairs
LQ Newbie
 
Registered: Apr 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
I'm directly connected to the modem through an ethernet cable and it doesn't get past dhcp on the debian net install. What should I do?
 
Old 04-07-2013, 09:47 PM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
If it's not installed by default
Intel e1000
http://forums.fedoraforum.org/showthread.php?t=257676
http://sourceforge.net/projects/e100...stable/1.2.20/
In debian I believe that you can install during installation if you choose "Advanced OPtions>>Epert Mode" at boot menu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Distro For Just Using the Internet flybynight Linux - General 14 06-08-2011 09:48 PM
Distro Madness - Best Distro for Internet tschima Linux - Distributions 7 03-07-2011 05:32 AM
[SOLVED] Why doesn't my distro 9.0 setup work for the 13.1 distro OldBikerPete Linux - Networking 9 09-15-2010 12:06 AM
Searching the Internet for the right Distro... Punami Linux - Distributions 6 07-11-2008 01:42 PM
Internet Install Distro's waynejkruse10 Linux - Distributions 3 08-31-2005 08:36 PM


All times are GMT -5. The time now is 07:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration