LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2004, 10:37 PM   #1
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Rep: Reputation: 15
Cannot start the X server(graphical interface)


so i was messin around in XF86Config to keep my screen from going blank...

so i added the blanktime line and removed the option "dmps" line...

well...i guess that was a bad i dea...because now i get the error
"I cannot start the X server (your gtraphical interface). It is likely that it is not set up correctly. would you like to view the X server output to diagnose the problem?

<yes> <no>"


well from here on out my keyboard doesnt respond...even thogh before hand it does.


is there anything i can do???

please please please help!


im runnin whitbox..

i change the blanktime and dmps and added network mounts to fstab and made it so xmms can play mp3s...

thats what has changed since it was bone stock...

thanks again

-matt
 
Old 11-17-2004, 12:34 AM   #2
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
You must know that if you *mess around* with the XF86Config file, you MUST back it up first (maybe even multiple times) for situations such as this.. All I could recommend is try seeing if you can use the XF86Config.old file (I never tried this). Otherwise try creating a new file with
Code:
# xf86cfg <or> xf86config
to create another.

I will add: post your XF86Config file (use the [ code ][/ code ] tags --capitalized and without the spaces-- to do so (looks better ). Maybe some more informed (than me) linux user will be able to help, because I probably won't be able to see it (still post it though ).

Last edited by student04; 11-17-2004 at 12:38 AM.
 
Old 11-17-2004, 07:03 AM   #3
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Original Poster
Rep: Reputation: 15
this all happens at startup...i get the error, and i have no use of my keyboard...i cant get into the os at all...i think...
 
Old 11-17-2004, 09:55 AM   #4
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
have you tried booting into the failsafe mode (single user)? (init 1 for me)
 
Old 11-17-2004, 10:58 AM   #5
Doolspin
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Slackware 9.1/10/10.1 RedHat circa 2000, Knoppix, OpenSuse 10.0/10.1
Posts: 122

Rep: Reputation: 15
If you can't go single user, try a rescue disk, Slack10 CD 2, Knoppix and edit it that way
 
Old 11-17-2004, 10:58 AM   #6
Doolspin
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Slackware 9.1/10/10.1 RedHat circa 2000, Knoppix, OpenSuse 10.0/10.1
Posts: 122

Rep: Reputation: 15
If you can't go single user, try a rescue disk, Slack10 CD 2, Knoppix and edit it that way, that is if its not root only edit. I can't remember

Edit: Doesn't look like thats gonna work, just checked it, its root only
Edit Edit: Sorry about the double post...

Last edited by Doolspin; 11-17-2004 at 11:02 AM.
 
Old 11-17-2004, 11:04 AM   #7
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
Yes, it is possible with knoppix. su gets you root in knoppix, so you can just change /etc/inittab to start the computer in single user mode.
Code:
id:5:initdefault:
is the line you want to look at. Change that 5 to whatever your inittab file says is single-user mode, and reboot. Just DON'T put 0 or 6.
 
Old 11-17-2004, 11:53 AM   #8
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Original Poster
Rep: Reputation: 15
once i start it i get prompted for either:

'enter' boot to white box
'e' edit commands before booting
'a' mondify kernel arguments
'c' command line


should i 'c' and enter "id:5:initdefault:"
 
Old 11-17-2004, 12:15 PM   #9
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Original Poster
Rep: Reputation: 15
ok now i get Kernel panic: No init found. Try passing init= option to kernel.


how do i do this? i tried "init 1" and i believe that is what gave me the kernel panic error...

any ideas??
 
Old 11-17-2004, 12:20 PM   #10
Doolspin
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Slackware 9.1/10/10.1 RedHat circa 2000, Knoppix, OpenSuse 10.0/10.1
Posts: 122

Rep: Reputation: 15
Yes, go to command line, and edit /etc/inittab and add


Code:
id:x:initdefault:
where X is whatever your single user mode is

Last edited by Doolspin; 11-17-2004 at 04:28 PM.
 
Old 11-17-2004, 12:26 PM   #11
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Original Poster
Rep: Reputation: 15
i can hit tab and get possible commands...and i dont see anything about even changing directories...much less edititing a file...



also. im at a "grub>" promt...when i use the 'c' option

Last edited by Dr Gutiemouth; 11-17-2004 at 12:38 PM.
 
Old 11-17-2004, 02:15 PM   #12
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
If you have another computer, download knoppix, burn it, boot your *broken* computer with it, open a console, type su, and edit /etc/inittab with vi for example, and change that number.

I don't use grub, but see if you can get a normal command prompt somehow. Look at the documentation of grub for information http://www.gnu.org/software/grub/manual/grub.html .
 
Old 11-17-2004, 04:40 PM   #13
RanDrake10
Member
 
Registered: Oct 2004
Location: Florida
Distribution: Debian
Posts: 319

Rep: Reputation: 30
Not exactly sure about Slack but other distro's of linux will automatically save back up of .txt files when you make changes. Once you get to command prompt as root go to etc/X11 there should be a file XF86Config-4~. That is the backup file, copy " # cp XF86Config-4~ XF86Config-4 ". Restart this should restore orginal copy.
 
Old 11-17-2004, 05:14 PM   #14
Dr Gutiemouth
Member
 
Registered: Oct 2004
Location: ohio
Distribution: Whitebox, Gentoo, XP,
Posts: 57

Original Poster
Rep: Reputation: 15
i dont have slack. i have whitebox. which is like redhat...not sure if rdhat and slack are the same...pretty sure they arent...first i need to get to the command line. that actually works...and i'll give it a try...would a kernel panic error come up because of xf86config file?
 
Old 11-17-2004, 10:38 PM   #15
RanDrake10
Member
 
Registered: Oct 2004
Location: Florida
Distribution: Debian
Posts: 319

Rep: Reputation: 30
Burn a copy of MEPIS live CD 2004.04. Boot from CD (esc, F1, F2, F11, etc...) read BIOS boot screen for "boot options", or change in BIOS (remember to change back to HD when done).
Log-In as root
password: root

The live CD will let you view your files on the HD, you can change them back from here.

Save
Reboot

This is Linux not Windows
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical interface does not start linx win Slackware 7 01-26-2005 04:08 PM
Best Graphical Interface server boneless88 Linux - Software 3 10-25-2004 09:20 AM
HELP! Can't start graphical interface fclifton Linux - Software 2 08-19-2004 12:29 PM
HELP! Can't start graphical interface fclifton Linux - Newbie 2 08-15-2004 03:51 AM
cannot start graphical interface ave1965 Linux - Newbie 10 10-30-2003 11:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration