LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-31-2015, 02:58 PM   #1
meki
LQ Newbie
 
Registered: Dec 2015
Posts: 6

Rep: Reputation: Disabled
Question Cannot mount NFS share (Fstab special character at the end of the mount)


Hopefully this is the right place to ask this.
I have read and read everywhere about this issue and cannot figure it out.

I am trying to mount an exported mount

Code:
sudo showmount -e 192.168.1.173
Export list for 192.168.1.173:
/mnt/user/Documentaries (TV)    192.168.1.38
/mnt/user/Documentaries (Movie) 192.168.1.38
In my fstab I put
Code:
192.168.1.173:/mnt/user/Documentaries\040\050TV\051 /mnt/Documentaries_TV       nfs     noatime,vers=3,auto,rw,dev,exec,suid,rsize=32768,wsize=32768 0 0
But it wont mount
when I do
Code:
mount -a
I get this
Code:
sudo mount -a
mount.nfs: access denied by server while mounting 192.168.1.173:/mnt/user/Documentaries (TV\051
If I put another character after \051 then the next character is detected
Code:
sudo mount -a
mount.nfs: access denied by server while mounting 192.168.1.173:/mnt/user/Documentaries (TV)test
It seems that the last character is not parsed.

I am really lost here I am hoping someone can help
 
Old 01-01-2016, 08:45 AM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,601

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Welcome to the world of special characters...

They are not recommended for use.

The problem is that mount isn't the one evaluating the title - it is mount.nfs. Mount -a just passes the strings to mount.nfs, which in turn has to pass it to a remote system.

For testing purposes you can try "mount.nfs" and quoting the desired strings. This will isolate the problem to the handoff between the mount command and the mount.nfs, or between mount.nfs and server.

What distributions/versions are the client and server?
 
Old 01-01-2016, 10:36 AM   #3
meki
LQ Newbie
 
Registered: Dec 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jpollard View Post
Welcome to the world of special characters...

They are not recommended for use.

The problem is that mount isn't the one evaluating the title - it is mount.nfs. Mount -a just passes the strings to mount.nfs, which in turn has to pass it to a remote system.

For testing purposes you can try "mount.nfs" and quoting the desired strings. This will isolate the problem to the handoff between the mount command and the mount.nfs, or between mount.nfs and server.

What distributions/versions are the client and server?
I kind of caved and updated my remote share to to eliminate special characters which I REALLY didn't want to do...

It was just too much trouble, I still would like to get to the bottom of this though

Here is what half-worked:

If in fstab I added "/" at the end of the
Code:
192.168.1.173:/mnt/user/Documentaries\040\050TV\051/ /mnt/Documentaries_TV       nfs     noatime,vers=3,auto,rw,dev,exec,suid,rsize=32768,wsize=32768 0 0
Code:
mount -a
works!

BUT

Upon restarting of the system fstab mounts every other mount except the one above.

If I issue mount -a when I login it mounts fine! What gives!?!?

Now to answer your questions:

Server is Unraid OS 6.1.6 (Which is slackware based I believe)

Client is Ubuntu Server Ubuntu Server LTS 14.04.03

Do you still want me to try mount.nfs or does above stuff give you enough idea?
 
Old 01-01-2016, 11:19 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,601

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Part of the reason to try it is because there are different things doing a mount at different times.

I believe Ubuntu Server has moved to systemd, so normal mounts are no longer done by the mount utility (or the mount.nfs). Instead they are mounted by systemd... which could introduce additional incompatibilities (one being that the fstab option "_netdev" needs to be added so systemd can tell what has to wait until after the network is operational).

I was curious about whether the trims were being done by mount when reading the fstab file, or when passing the strings to mount.nfs. Using the mount.nfs would separate the issues. It almost looked like it was going through a shell somewhere, in which case the () and blank are handled uniquely - the close parenthesis gets chopped when it is parsing a subshell operation.
 
  


Reply

Tags
fstab, mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot mount NFS share (Fstab special character at the end of the mount) meki Linux - Newbie 3 01-06-2016 02:22 PM
fstab entry does not mount nfs share nanbudh Linux - Networking 13 06-07-2012 03:05 PM
Can't mount nfs share from fstab but can mount it manually - help Mountain Linux - Networking 1 03-30-2008 09:34 PM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration