LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-28-2013, 02:53 PM   #16
NikosGr
Member
 
Registered: Jun 2013
Posts: 58

Original Poster
Rep: Reputation: 0

Boris Zentner (MaxMind)

Oct 28 16:50 (ADT)

Niko,
I can't help further.
My advice is to check in general how to install a library on centos.
Run the commands I send earlier one by one and fix any errors before you run the next command.
maybe your system does not include /usr/local/lib in your ld.conf file. as far as I can see the problems are related to your system configuration.
Have a nice day
 
Old 10-28-2013, 03:41 PM   #17
NikosGr
Member
 
Registered: Jun 2013
Posts: 58

Original Poster
Rep: Reputation: 0
Can you please tell me what is goinf on here an i cant successfully install 'maxminddb' so i can use it from within my python3 scripts?
 
Old 10-29-2013, 03:34 AM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,536

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
Installing bleeding edge / beta software, like Geoip2 :
The suggestion is to use a later Fedora (CentOS 6 is Fedora 12 based)
like Fedora 19, where python-2.7.5 will handle Geoip2 OK :
# yum install python-pip

# pip install maxminddb : No issues.

# pip install geoip2 : OK

-
 
Old 10-29-2013, 03:38 AM   #19
NikosGr
Member
 
Registered: Jun 2013
Posts: 58

Original Poster
Rep: Reputation: 0
The only operating system that is appropriate for installing cPanel/WHM is CentOS 6.4.
I do not like it but i ahve to live with it if iam to use cPAnel.

So i have to work with that, is there anythign that can be done?
 
Old 10-29-2013, 07:38 AM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,536

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
Ref. #18, #19 .

CentOS 6 : GeoIP version 1.4.8 is available from the EPEL repository..
http://download.fedoraproject.org/pu...l-release.html
> epel-release-6-8.noarch >>
http://ftp.crc.dk/fedora-epel/6/i386...6-8.noarch.rpm
# rpm -Uvh epel-release-6-8.noarch.rpm
# yum install GeoIP
... ( If you haven't destroyed yum with the alien Python3.)


GeoIP 2 : You can install Fedora 19 on
a spare partition / a spare hard disk / a spare computer.

-
 
Old 10-29-2013, 07:48 AM   #21
NikosGr
Member
 
Registered: Jun 2013
Posts: 58

Original Poster
Rep: Reputation: 0
Its ok i deciced to use geoip version 1 (that is 'pygeoip')

Can you please:

1. Help me unistall current Python 3.3.2 because the support team wrongly putted it inside /usr/local
2. install proplery Python 3.3.3

?
 
Old 10-29-2013, 05:28 PM   #22
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,536

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 21 .

It will probably be easier to delete the python3 files,
when you have the new Python 3.3.x present in /opt/.
Then you can identify exactly which files to delete in /usr/local/.

Installing Python-3.3.x :
( There is no Python-3.3.3 AFAIK. 3.3.2 is the stable version )
3.3.2 http://www.python.org/ftp/python/3.3...n-3.3.2.tar.xz
( http://www.python.org/download/ )
$ tar xvf Python-3.3.2.tar.xz
$ cd Python-3.3.2/
$ ./configure --prefix=/opt/python3
$ make ( A few minutes to finish, on my Intel i7 920.)
$ su <Enter-root-password>
# make install

Using : $ /opt/python3/bin/python3.3 <etc. etc.>

-

Last edited by knudfl; 10-29-2013 at 05:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install autoconf-2.68 nicknuck Linux - Newbie 6 01-09-2012 06:14 AM
I can't install autoconf! zzcranjo Linux - Software 3 05-19-2009 08:43 AM
*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2. arubin Slackware 6 09-24-2008 03:31 AM
Need autoconf 2.5 but can't install old one TCv1 Mandriva 2 03-25-2004 05:39 PM
Can I install two version of autoconf on my RH8 with cd7809 Linux - Software 1 10-09-2003 04:39 AM


All times are GMT -5. The time now is 05:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration