LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-07-2004, 12:11 PM   #1
fries321
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Cannot dual boot Windows XP with Red Hat 9


I just installed Red Hat 9 (yes, I know it is old) on a spare FAT32 partition
ona machine that had been factory pre-loaded with WinXP Home Edition,
SP1. The installation went well, Linux boots fine, but I cannot boot WinXP
any more.


********* HERE ARE THE DETAILS ***********

======= Prior to Linux install

I had two physical drives, with two partitions on the first physical drive
(yes, I know C: is the 2nd partition):

C: IDE Master Drive 0 Partition 1 NTFS ~110GB
D: IDE Master Drive 0 Partition 0 FAT32 ~5GB
E: IDE Slave Drive 1 Partition 0 NTFS ~80GB

======= After Linux install

Loaded Linux onto D: (called /dev/hda2 in Linux)

Used manual partitioning to find the D: drive (hda2) and specified that is
where I wanted Linux loaded. I specified dual-booting and left GRUB
as the default


From the System Tools => Hardware Browser => Disk Drives screen:

device start end size type
/dev/hda
1 1 <1 Free space
hda1 1 583 4570 ext3
hda2 583 14595 109915 ntfs
14595 14597 13 Free space
/dev/hdb
hdb1 1 9964 78160 ntfs


From the /boot/grub/grub.conf file:

default=0
timeout=10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=/ hdd=ide-scsi
initrd /boot/initrd-2.4.20-8.img
title Windows XP
rootnoverify (hd0,1)
makeactive
chainloader +1


======== When I try to boot my PC

I get the GRUB spash screen with the boot options. When I select Linux,
the PC boots without a problem. However, when I select Windows XP, I
see the commands in grub.conf being executed, but then the boot just
hangs after "chainloader +1".

Some people, in response to a non-booting XP, have suggested adding:

map (hd0) (hd1)
map (hd1) (hd0)

to the Windows XP section. However, I think that only swaps the drives,
not the partition on a drive.


HELP !?!?!?!?!?!?!?

Mark D. Fries
mark.fries@med.ge.com
 
Old 09-09-2004, 02:24 PM   #2
blueCow
Member
 
Registered: Feb 2004
Location: Florida
Distribution: FreeBSD, CentOS, Debian, Mint
Posts: 111

Rep: Reputation: 17
If I remember correctly, windows must be installed on (hd0,0).

It will not work if it is configured (hd0,1)
 
Old 09-09-2004, 03:01 PM   #3
fries321
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Cannot boot . . . problem solved

You would appear to be correct. Unfortunately, this required me
to re-load WinXP. Here is what I did . . .

I re-loaded WinXP and, during the load, I made two partitions:
(Partition 0) was 110-GB for WinXP containing a NTFS file system
and (Partition 1) was 6-GB for Linux containing a FAT32 file
system. The WinXP load was very uneventful and resulted in
the Windows boot loader being installed in the MBR of Partition 0.

I then re-loaded Linux on Partition 1. I told Linux to ignore Partition
0 (on /dev/hda1), deleted the FAT32 partition (on /dev/hda2, using
Druid) to get free space, and added 4 EXT3 partitions for "/boot"
(on /dev/hda2, 100-MB), "/" (on /dev/hda3, 4-GB), "/home" (on
/dev/hda4, 1.5-GB), and "SWAP" (400-MB).

On the same screen, I specified that GRUB was to be the Linux boot
loader and that there would be only a Linux boot, NOT A DUAL BOOT.
However, in the "Advanced Boot Loader Options" screen, I specified
that the boot loader should be loaded onto the boot sector mounted
on /dev/hda2, NOT ONTO THE MBR.

I made sure that I created a Linux boot floppy (two actually) so that
I could re-boot to Linux. Remember, I told Linux that there was no
dual boot.

After Linux was loaded, I re-booted to Linux using the floppy and made
a file that was the GRUB boot loader with the following commands:

cd /boot/grub
dd if=/dev/hda2 of=linux.bin size=512 count=1

I inserted a blank, but DOS formatted floppy into the floppy drive and
copied the GRUB boot loader file onto the floppy with the following
commands:

mount -t msdos /dev/fd0 /mnt/floppy
cp linux.bin /mnt/floppy
umount /dev/fd0

I removed the floppy and re-booted and WinXP came up (since it has
no knowledge of the Linux load anyway.) I re-inserted the floppy,
then added the Linux boot loader TO THE WINDOWS BOOT LOADER by
doing the following:

copy a:\linux.bin c:\
edited c:boot.ini and appended c:\linux.bin="Linux Red Hat 9" to
the end of the file.

That made the Linux boot loader the second menu entry in the Windows
boot sequence.

Problem solved.
 
Old 09-09-2004, 03:15 PM   #4
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
MY friend, the way you are trying to install Linux, is the more complicated way....the best way in which Windows is almost guaranteed to work after Linux installation is the following:

First Install Windows.....1 partition, 1 hardrive.

Then install Linux. If you have 1 drive only, then make 2 partitions AFTER the Windows partition
If you have 2 drives, then leave the MAster drive for Windows, then leave the salve for Linux, and give a drive to each one of them.....this is 99% foolproof.
 
Old 07-26-2006, 08:09 AM   #5
armenon1
LQ Newbie
 
Registered: Jul 2006
Posts: 1
Blog Entries: 1

Rep: Reputation: 0
After the installation of linux, bootloader was working fine. When I booted into the Win XP home, it ran the system restore. I did go with the system restore. N now I find that the linux grub does not start. It boots into the windows by default. I did not opt to store the boot file onto the floppy. Im stuck... What could be done?
 
Old 08-03-2006, 08:28 AM   #6
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
armenon1,

Where did you install the bootloader?

in the MRB? or in the First part of the partition?
 
Old 08-03-2006, 09:24 AM   #7
lazyFoot_theMighty
LQ Newbie
 
Registered: Jul 2006
Location: Canberra Australia
Posts: 28

Rep: Reputation: 16
Either way, as it is, the best solution seems to be to reinstall grub onto the mbr then use it to boot linux and start the windows bootloader. The system restore most likley would have overwritten whatever was on the mbr and the windows boot loader was not really made to boot oss' of other types. I've tried it. square block, round hole.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Red Hat 7.2/ Windows XP dual boot mobok7v Linux - General 10 11-27-2006 02:47 PM
Dual Boot Problem (Windows XP & Red Hat 8) sypkensj Linux - Newbie 50 07-13-2006 02:31 PM
dual boot Windows XP Pro and Red Hat Fedora Core 2 j2linux2 Fedora 5 10-01-2004 09:32 AM
how can i dual boot between windows and red hat? phancom Linux - Newbie 2 09-17-2003 09:53 AM
Dual Boot, Lilo Windows / Red Hat kbhadsten Linux - Newbie 15 06-21-2002 06:30 AM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration