LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2004, 10:09 PM   #1
mst700
Member
 
Registered: Jun 2004
Location: Ascension Island SAO
Distribution: FC2 2.6.8 Kernel, FreeBSD Unix, Gentoo 2004-2, WinXP SP2
Posts: 46

Rep: Reputation: 15
Unhappy Can't connect to the internet


I have just downloaded fedura2, my machine is a 2.8 P4 with a chaintech motherboard. I have 2 eithernet cards built-in the mother board. the RH10 sees both as eth0 and eth1, np there. My problem is I can't see the internet gateway. I have a amd3400 with xp pro as my internet gateway IP address 192.168.0.1. Standard stuff for XP. I can hit the internet with my Apple G3 laptop(10.2os), I can hit the internet with other windows machines, but I can't seem to get the Linux machine to play well with others. I have tried to use the command route without success. I have told my eth0 to use 192.168.0.1 as the gateway without success. I can see all the other computers on the network and ping them and they can see me. Please advise.
 
Old 06-26-2004, 10:13 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Give us the output of the following commands:

/sbin/ifconfig -a
/sbin/route

Also try pinging your gateway (192.168.0.1). If you can do that OK, ping a host on the Internet by IP address (not name). If you can do that, then you don't have your DNS servers set.

BTW are you using DHCP on the network -- if so, you'll need to configure your ethernet adapter to use DHCP and if everything is set properly this all should be set up automatically.
 
Old 06-26-2004, 11:11 PM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
you can use

#netstat -nr

command too to get the route tables.

Hope the network cable is connected to eth0 and not eth1 by mistake.

Last edited by ppuru; 06-26-2004 at 11:12 PM.
 
Old 06-28-2004, 12:07 AM   #4
mst700
Member
 
Registered: Jun 2004
Location: Ascension Island SAO
Distribution: FC2 2.6.8 Kernel, FreeBSD Unix, Gentoo 2004-2, WinXP SP2
Posts: 46

Original Poster
Rep: Reputation: 15
WOOT, Thanks guys (or ladies) got ti fixed. I figured out that my problem was DNS server was pointing at the wrong machine. When I did the
/sbin/ifconfig -a
/sbin/route
it told me that I was pointing to my Other XP machine, the gateway status said:

default 192.168.0.1 0.0.0.0 UG

after I fixed it. WOOT again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM
Can't connect to Internet Galphar Linux - Newbie 13 08-24-2003 04:14 PM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration