LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-26-2004, 09:16 PM   #1
Guigo
LQ Newbie
 
Registered: Aug 2003
Location: Brazil
Distribution: Red Hat 9.0 / Fedora Project Core 1
Posts: 12

Rep: Reputation: 0
Question Can't Bring Ethernet Up / Can't Active Ethernet /


Hello guys,

I am very new in Linux and I am not confortable with Linux Prompt (text mode), so I usually use the X-Window.

I used to work with Red Hat 9.0 and everything was perfect. Now I did an upgrade in my Linux to Fedora Core 1 and I am having some problems with my Internet, in fact I can't connect to the Internet.

Here is what is happening: I installed Fedora Core 1 and I have no problem during the instalation, everything was successfull. However, when I reboot the machine, the system coudn't bring the Ethernet up. This problem occurs each time the computer starts or reboot.

When I saw the problem above I tryied to Active the Ethernet (logged as root) from inside the X-Window, but I fail when trying to Active the Ethernet.

What can I do to solve this problem?? I hope you can help me... Please, give me very detailed instructions (if you can...).

Thank you very much!!!


Obs.: Here is the messages that I receive:

* Activating network device eth0, please wait...

Determining IP information for eth0...

SIOCSIFFLAGS: Device or resourse busy
SIOCSIFFLAGS: Device or resourse busy
failed


* Bringing up interface eth0:
SIOCSIFFLAGS: Device or resourse busy
SIOCSIFFLAGS: Device or resourse busy
failed
 
Old 02-26-2004, 09:24 PM   #2
closet geek
Member
 
Registered: Apr 2003
Location: England
Posts: 146

Rep: Reputation: 15
su to root in a shell and try bring the network down, then up again... doubt it'll help much but who knows...

ifconfig eth0 down

ifconfig eth0 up

then run pump --interface eth0 to get an IP (if RH still use pump that is) if not try dhclient eth0

cg
 
Old 02-26-2004, 09:33 PM   #3
Guigo
LQ Newbie
 
Registered: Aug 2003
Location: Brazil
Distribution: Red Hat 9.0 / Fedora Project Core 1
Posts: 12

Original Poster
Rep: Reputation: 0
Thumbs down

Didn't work....

Another suggestions??
 
Old 02-27-2004, 09:05 AM   #4
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
Are you set up for DHCP or static? Could something as easy as this be preventing it? If static and have another same ip address that could be the problem.
 
Old 02-27-2004, 01:45 PM   #5
Guigo
LQ Newbie
 
Registered: Aug 2003
Location: Brazil
Distribution: Red Hat 9.0 / Fedora Project Core 1
Posts: 12

Original Poster
Rep: Reputation: 0
Question

My DHCP is set up... but I have already tried with an static IP and it didn't work as well...

Here is the results of some configuration files:

/etc/sysconfig/network
NETWORKIN=yes
HOSTNAME=localhost.localdomain

/etc/sysconfig/network-scripts/ifcfg-eth0
#Realtek | RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=dhcp
HWADD=00:60:67:06:24:55
onBOOT=yes
TYPE=Ethernet
DHCP_HOSTNAME=localhost.localdomain
USERCTL=yes
PEERDNS=no

/etc/modules.conf
alias eth0 8139too
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias souund-slot-emu10k1

ping -c1 localhost everything is fine... OK!!!

ifconfig eth0 up
SIOCSIFFLAGS: Device or resource busy


What can I do to solve this problem??
Please help me...
 
Old 03-21-2004, 05:30 AM   #6
ploesse
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
It's really easy... you just need to disable "Plug and play OS" in BIOS.
I experienced exactly the same problems as you, but this little trick seems to do the job...
 
Old 03-21-2004, 07:00 AM   #7
Pres
Member
 
Registered: Jun 2002
Location: Australia
Distribution: Slack 9.1
Posts: 232

Rep: Reputation: 30
If that doesn't work, perhaps you just need to bring up your driver :

"modprobe 8139too", perhaps in a script somewhere.
 
Old 03-23-2004, 01:27 PM   #8
Guigo
LQ Newbie
 
Registered: Aug 2003
Location: Brazil
Distribution: Red Hat 9.0 / Fedora Project Core 1
Posts: 12

Original Poster
Rep: Reputation: 0
Thumbs up Thank's!!!

It's true... it's really easy!!!

Everything was perfect (network and soundcard configuration was OK). I hadn't had to change anything.

The only thing I had to do was disable "Plug N' Play OS" in the BIOS. When I did this both (network and soundcard) worked perfectly well!!!

Thank you all guys!!!
 
Old 04-03-2004, 09:31 AM   #9
legendaryfox
LQ Newbie
 
Registered: Apr 2004
Distribution: Fedora Core 1
Posts: 16

Rep: Reputation: 0
Hrm, when I checked the BIOS, Plug and Play O/S was already disabled....any help?

I'm using Fedora, btw...thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to bring up ethernet interface sparks_lu Linux - Networking 5 03-27-2005 11:57 AM
Online, Ethernet active, but Mozilla won't take me anywhere? JWHolloway Linux - Networking 7 01-21-2005 03:51 PM
ethernet active, but no access to internet nouwen Linux - Newbie 3 06-14-2004 01:38 PM
Active ethernet card, no connection toegrim Linux - Networking 1 10-15-2003 04:55 PM
Can't bring up Ethernet dalraidia Linux - Networking 3 02-16-2003 02:26 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration