LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2006, 11:29 AM   #1
philips217
LQ Newbie
 
Registered: Nov 2006
Posts: 22

Rep: Reputation: 15
Burning with cdrecord


Hi guys,
I am having some trouble when trying to burn some files onto a CD in vmware. When I type:
Code:
cdrecord dev=ATAPI –scanbus
I get:
Code:
…
scsibus0:
	0,0,0	0) ‘LITE-ON ‘ ‘DVDRW SHW-1635S ‘ ‘YSON’ Removable CD-ROM
	0,1,0	1) *
…
So I am suspsoe to use 0,0,0
When I try:
Code:
cdrecord –v –eject speed=8 dev=ATAPI:0,0,0 /path/to/my/file/
I get some stuff at the start then:
Code:
…
cdrecord: WARNING: Total disk size unknown , Data may not fit on disk.
Forcespeed is OFF.
Starting to write CD/DVD at speed 8 in real TAO mode for single session.
Last chance to quit, starting real write	0 seconds. Operation starts.
Waiting for reader to fill input buffer … input buffer ready.
BURN-Free is OFF.
Performing OPC…
Starting new track at sector: 0
Track 01:	0 MB written.cdrecord: Is a directory. Read error on input file
Writing time:	0.204s
Cdrecord: fifo had 1 puts and 1 gets.
Cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.
Do I need to mount the cdrom?
if I try:
Code:
mount /dev/hdc –t iso9660 –w /cdrom
I get:
Code:
mount: block device /dev/hdc is write-protected but explicit ‘-w’ flag given
Are the permissions wrong?
when I do:
Code:
ls –l /dev/hdc 
ls –l /cdrom
I get:
Code:
brw-rw----
drwxr-xr-x
Any help would be greatly appreciated.
Thanks in advance.
 
Old 11-23-2006, 11:50 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Try using; cdrecord device=/dev/hdc /path/to/the/files/

For mounting, no need to specify the '-w' writing switch (does not apply or work anyhow in this case). If the drive is already known in the /etc/fstab file the just use something like;

mount -t auto /dev/hdc
 
Old 11-23-2006, 12:08 PM   #3
philips217
LQ Newbie
 
Registered: Nov 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks for the reply.

However, I get:
...
cdrecord: Is a directory. read error on input file

Any ideas?
 
Old 11-23-2006, 12:15 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Yah ... you need to use mkisofs to create an ISO-image of your files
and then burn THAT using cdrecord (or do it on the fly as the man-page
explains).
Code:
example:
mkisofs -R -o cdimage.raw /home/joerg/master/tree
cdrecord -v speed=2 dev=2,0 cdimage.raw


example:
mkisofs -R /master/tree | cdrecord  -v  fs=6m  speed=2 dev=2,0 -

Cheers,
Tink
 
Old 11-23-2006, 01:09 PM   #5
philips217
LQ Newbie
 
Registered: Nov 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks, I think it started working but now a vmware box showed up saying:
Quote:
Your virtual machine has send an ATAPI (CD-ROM) command that is supported only when
programming the drive via DMA. You will need to configure your guest operating system
to use DMA when communicating with DVD/CD-ROM devices.
Note that some operating systems will report DMA is available without actually using it. In
those cases, normal CD-ROM operations will still be available, but special features will
only be available if you reconfigure the virtual device as a SCSI device.
Do I need to recompile my kernel? Just to burn CDs?

Any ideas or links for help?
 
Old 11-24-2006, 08:45 AM   #6
philips217
LQ Newbie
 
Registered: Nov 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Okay, I figured it out.
Thanks a lot guys!
 
Old 03-24-2007, 07:52 AM   #7
markkeegan17
LQ Newbie
 
Registered: Mar 2007
Location: Montreal, Canada
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
you said you figured it out (the dma thing in VMware)...

may I ask HOW?

I have the same problem and (even though) DMA is enabled on my linux machine, I still get the same VMware error message when booting Windows 2000.

Thanks.
 
Old 03-26-2007, 07:59 AM   #8
philips217
LQ Newbie
 
Registered: Nov 2006
Posts: 22

Original Poster
Rep: Reputation: 15
In your wmware settings for the machine change your cdrom from IDE to SCSI.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems burning CDs using cdrecord frankie_DJ Slackware 3 05-24-2006 06:23 PM
Problems Burning an ISO with cdrecord bmccorm2 Linux - General 10 12-07-2005 12:19 PM
questions on burning cd with mkisofs and cdrecord xround Linux - General 1 03-09-2005 11:51 AM
Problems burning cd's using the cdrecord command Snerkel Linux - Hardware 1 09-26-2004 07:37 PM
cdrecord error burning iso image mooreted Linux - General 8 04-19-2004 11:57 AM


All times are GMT -5. The time now is 05:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration