LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2004, 04:00 AM   #1
mitchb
LQ Newbie
 
Registered: Jun 2004
Location: Philippines
Posts: 16

Rep: Reputation: 0
build and configure lynx


hi i just installed lynx from source and i cant make it to run these are the steps i followed:

Install Lynx by running the following commands.

./configure --prefix=/usr --libdir=/etc --with-zlib &&
make &&
make install &&
make docdir=/usr/share/doc/lynx-2.8.5/lynx_doc \
helpdir=/usr/share/doc/lynx-2.8.5/lynx_help install-doc &&
make docdir=/usr/share/doc/lynx-2.8.5/lynx_doc \
helpdir=/usr/share/doc/lynx-2.8.5/lynx_help install-help

I followed all the dependencies and typed in the command which i posted above. it only apprears in a gray screen that says: looking up to- the site i t typed in. how can i make lynx work? thanks in advance

-mitch b
 
Old 07-26-2004, 02:30 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,498

Rep: Reputation: 90
So it did compile and install normally?

If it did, it sounds like you might have a DNS problem. Can you ping internet servers? Something like (in an X-terminal)

ping www.linuxquestions.org

Do you get a response? If you do not, you might have not configured DNS.

On my Rh9 system, this is done by editing /etc/resolv.conf and putting the IP adresses that your ISP provided you with for their nameservers in there, like so:

nameserver 192.41.10.31
nameserver 191.45.101.21

or whatever they provided you with.

Now, when you try to serve to a named internet site (and the rest of your setup is configured correctly!) any browser, including Lynx, should now first do a DNS lookup.

The reason why you probably get no response is that your browser "thinks" that it is waiting for the DNS server to respond, and will thus timeout after awhile that it cannot find the site, when in fact there are no DNS IP's for it to query.

Hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto build (configure) a simple router? carboncopy Slackware 21 03-16-2004 11:44 PM
lynx all the way!! mcd Linux - Newbie 1 08-30-2003 06:05 PM
Lynx joseph Linux - General 2 08-28-2003 02:55 AM
Kazaa lite 2.0 build 2 and 2.02 build 5 walterw Linux - General 1 02-04-2003 04:12 PM
Need to 'configure' my kernel to build a driver for my wireless NIC 2016 Linux - Newbie 5 01-01-2003 02:51 PM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration