LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2003, 09:31 PM   #1
Moses420ca
Member
 
Registered: Jul 2003
Distribution: Ubuntu
Posts: 142

Rep: Reputation: 15
booting suse into console instead of x?


How can I boot suse into a console instead of right into X? Also, I have a windows domain with active directory. With my mandrake box, I could very easly connect to my network with the mandrake control centre. I want to mount -t smbfs -o username=user,password=pass,domain=domain //windoze/share /mnt/folder
 
Old 08-26-2003, 09:46 PM   #2
andrew001
Member
 
Registered: Nov 2002
Distribution: Slackware 9.0
Posts: 321

Rep: Reputation: 30
You need to change the default runlevel. Look in /etc/inittab
 
Old 08-26-2003, 09:55 PM   #3
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
As root, edit the file /etc/inittab
Change the line
id:5:initdefault:
or in the case of Slackware
id:4:initdefault:
to
id:3:initdefault:
 
Old 08-27-2003, 08:00 AM   #4
Moses420ca
Member
 
Registered: Jul 2003
Distribution: Ubuntu
Posts: 142

Original Poster
Rep: Reputation: 15
suse is quite different from Mandrake. All the programs are in different places and I'm having trouble running programs as root. I tried this.

Code:
drew@linux:~> su root
Password:
linux:/home/drew # kwrite /etc/inittab
bash: kwrite: command not found
linux:/home/drew # cd /opt/kde3/bin
linux:/opt/kde3/bin # ./kwrite /etc/inittab
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kwrite: cannot connect to X server :0.0
linux:/opt/kde3/bin #
I can start kwrite from the console as my user but not as root.

Thanks for any help.
 
Old 08-27-2003, 03:26 PM   #5
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
use vim
vim /etc/inittab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
booting into console or GUI - Solaris 10 chexmix Solaris / OpenSolaris 12 06-07-2013 02:26 PM
FC4 not booting w/ message "ERROR opening /dev/console!!!!: 20" Dimension User Fedora 5 10-24-2005 05:03 PM
Booting to console? sdouble Linux - Newbie 3 09-19-2004 12:36 PM
Booting up in X server... how do I disable it or fall back to console mode? Delmarc Linux - Newbie 3 09-06-2003 08:23 PM
console keyboard configuration\ terminal switching off \ faster booting jamaso Linux - Newbie 5 10-27-2001 08:59 AM


All times are GMT -5. The time now is 02:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration