LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-03-2014, 07:10 PM   #1
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Rep: Reputation: Disabled
Question Boot Ubuntu 14.04 64bit with greyed out Secure Boot disable option in BIOS?


Hi everyone,

I have created a working bootable usb drive (verified on a different laptop) with Ubuntu 14.04 64bit. When I try to boot it on my Gigabyte S1082 Slate I get a red Secure Boot violation error. But my Aptio Setup Utility 2.15.1229. will not let me disable secure boot. It's greyed out.

So what could I do about that? Is there any chance I could get Ubuntu to work without disabling secure boot? Or am I missing something in my BIOS?

The only thing that is not greyed out under the security tab is 'Delete all Secure Boot variables' but that doesn't sound like a good idea to me.

Thanks for your help
 
Old 05-03-2014, 08:54 PM   #2
maples
Member
 
Registered: Oct 2013
Location: IN, USA
Distribution: Arch, Debian Jessie
Posts: 813

Rep: Reputation: 264Reputation: 264Reputation: 264
Really? Try looking to disable UEFI boot entirely, and see if that works?

It might be helpful if you could take a pic or two of your UEFI options and the error and attach it.
 
Old 05-04-2014, 04:22 AM   #3
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks for your reply, maples.

I took photos of every BIOS tab I have except save & exit and of the error.

Disabling UEFI boot altogether sounds promising but unfortunately I have absolutely no idea how to do that. (All the tutorials I checked require disabling secure boot)

When I press enter after the error appears the machine normally boots to Windows 8.
Attached Thumbnails
Click image for larger version

Name:	IMG_3237.jpg
Views:	172
Size:	254.6 KB
ID:	15419   Click image for larger version

Name:	IMG_3239.jpg
Views:	148
Size:	253.2 KB
ID:	15420   Click image for larger version

Name:	IMG_3241.jpg
Views:	147
Size:	254.9 KB
ID:	15421  

Last edited by hanspeterii; 05-04-2014 at 04:47 AM. Reason: Forgot something
 
Old 05-04-2014, 04:25 AM   #4
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Original Poster
Rep: Reputation: Disabled
Ther rest of the images:
Attached Thumbnails
Click image for larger version

Name:	IMG_3242.jpg
Views:	62
Size:	257.8 KB
ID:	15422   Click image for larger version

Name:	IMG_3243.jpg
Views:	60
Size:	256.4 KB
ID:	15423   Click image for larger version

Name:	photo (6).jpg
Views:	66
Size:	256.6 KB
ID:	15424  
 
Old 05-04-2014, 07:52 AM   #5
maples
Member
 
Registered: Oct 2013
Location: IN, USA
Distribution: Arch, Debian Jessie
Posts: 813

Rep: Reputation: 264Reputation: 264Reputation: 264
My best guess would be to look at the two "Boot Option" entries under the "Boot" tab. I would look for something similar to "no OS verification."

If there isn't anything like that, my next thought would be to change the "OS Type" under the "Boot" tab. One of the options should be similar to "Legacy BIOS." If you use that option, it will boot like a non-UEFI computer.

I hope this helps!
 
Old 05-04-2014, 08:22 AM   #6
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Original Poster
Rep: Reputation: Disabled
Yeah, I tried that too. Under the boot options entries I can choose

Windows Boot Manager (long string of numbers and letters)

UEFI: Spaceloop 4GB 8.07 (My bootable USB)

Disabled

Selecting disabled would leave me with no boot order, so that propably would not work.

Under OS Type I can select:

UEFI OS

That's it. That's why I started this thread. :/
 
Old 05-04-2014, 08:47 AM   #7
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,048

Rep: Reputation: 286Reputation: 286Reputation: 286
This might be why it is greyed out.
Quote:
For most PCs, you can disable Secure Boot through the PC’s firmware (BIOS) menus. For logo-certified Windows RT 8.1 and Windows RT PCs, Secure Boot is required to be configured so that it cannot be disabled.
according to this http://technet.microsoft.com/en-us/l.../dn481258.aspx
 
Old 05-04-2014, 11:21 AM   #8
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Original Poster
Rep: Reputation: Disabled
I looked at that too, I am running the normal non-RT Windows 8; it has the desktop and the ability to run old windows applications. But you might be right because it says that they rquire all RT machines to have 'locked' Secure Boot which does not mean that all non-RT machines are 'unlocked'. While most are, mine might not be 'unlocked'.

So, assuming that I can't get rid of Secure Boot, is there any way to get Ubuntu (or any other Linux distribution) running?
 
Old 05-04-2014, 12:37 PM   #9
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,151

Rep: Reputation: 237Reputation: 237Reputation: 237
I'm rather concerned by Microsofts activities for any future PC.

Is the procedure outlined in http://www.theregister.co.uk/2013/02...fi_workaround/ useful?
 
Old 05-04-2014, 02:32 PM   #10
hanspeterii
LQ Newbie
 
Registered: May 2014
Distribution: Ubuntu 14.04
Posts: 6

Original Poster
Rep: Reputation: Disabled
I'm concerned too.

It sure sounds good. I'll definately give that a shot, thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I run a boot CD from a PC that doesnâ??t have a BIOS CD-ROM Boot option? garryg68 Linux - Newbie 4 12-31-2011 02:58 AM
virt-manager 0.8.2 local ISO and PXE boot install option greyed out on pv dom0 tkmsr Linux - Virtualization and Cloud 2 03-01-2011 04:09 AM
AHCI option greyed out in BIOS (nForce 630i) TechLiam Linux - Hardware 8 05-12-2010 10:19 AM
Have to change boot order in BIOS to boot ubuntu/winxp Minn3h Linux - Software 7 04-01-2006 05:17 PM
How to Disable APM Bios Detection on Boot leeach Mandriva 4 10-01-2003 08:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration