LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2016, 01:34 AM   #1
aviralgarg
LQ Newbie
 
Registered: Mar 2016
Posts: 6

Rep: Reputation: Disabled
Bodhi Linux Live USB not booting on preinstalled Windows 10 laptop-- already tried secure/fast boot on/off


I am using the Windows 10 home laptop.

Created live USB with rufus for bodhi linux 64 bit.

it doesn't boot up. Tried so many different settings. didn't work.

please help. let me know if you need details.

------------------------------------------------------------
Edit:

Hardware: http://www.staples.ca/en/Venturer-WT...8_2-CA_1_20001

Rufus settings, Basic information about my computer, hardware details: http://imgur.com/a/oCa7H

Last edited by aviralgarg; 03-25-2016 at 01:16 PM. Reason: providing more details about the issue
 
Old 03-25-2016, 04:25 AM   #2
Envoy of Goats
LQ Newbie
 
Registered: Mar 2016
Distribution: Arch
Posts: 9

Rep: Reputation: Disabled
Could you provide more information about what you mean by it doesn not boot up? Does the system just boot Windows instead?

Do you have any sign that bodhi is even starting the boot process?

Have you succesfully booted any other non-windows OS on this machine?

Are you sure you have your EFI/Bios setup to prioritize external storage over the windows instalation? Have you tried manually selecting the device to be booted from?

Did you allow rufus to verify it wrote .iso file correctly?

Have you tried a different USB stick?
 
Old 03-25-2016, 07:53 AM   #3
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,132

Rep: Reputation: Disabled
Live USB not booting in Windows 10 <-- not a proper evaluation of what is really going on.

Because it does not boot up in Windows, it boots up before it even sees Windows, or accesses the Hard drive Windows is on. Knowing that bit of information should now change your way of looking at what the real problem could be in order to find out what the real problem really is.

Get a different Linux Live distro to try as well as what @Envoy of Goats suggested/asked of you.

Set BIOS to MBR boot or reset to defaults, save. make sure you're having the BIOS look at your USB Port first. try a different USB Port (should not matter) but if one is faulty. try the other one, just in case.

slap it to show it who's boss then try it again.

Try looking into how old your system is, and see if their is a BIOS update out their for your BIOS to update that.

Last edited by BW-userx; 03-25-2016 at 08:06 AM.
 
Old 03-25-2016, 09:26 AM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
When you initially boot, you should see a message which is usually at the bottom of the screen when you see the manufacturer logo that tells you which key to press to enter setup. That is where you need to go to set the boot priority to access your usb first. These settings are differenet on different machines so posting some information on your hardware would be a good starting point.

Booting methods have changed recently and now UEFI/GPT is common on new computers and a pre-installed windows 10 most likely uses it. If yours does, then you need to install Bodhi using UEFI/GPT. Take a look at the link below which describes requirements for dual booting windows and Linux. It's specific to Ubuntu but Bodhi is derived from Ubuntu so it should all apply.

https://help.ubuntu.com/community/UEFI

Also, as suggested above, specific steps you took to try to boot and exactly what happened would help. The comment below from your post doesn't help anyone to help you. Not enough info.

Quote:
Tried so many different settings. didn't work
 
Old 03-25-2016, 01:03 PM   #5
aviralgarg
LQ Newbie
 
Registered: Mar 2016
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Envoy of Goats View Post
Could you provide more information about what you mean by it doesn not boot up? Does the system just boot Windows instead?
The system just boots Windows instead.

Quote:
Originally Posted by Envoy of Goats View Post
Do you have any sign that bodhi is even starting the boot process?
What signs should I look for?

Quote:
Originally Posted by Envoy of Goats View Post
Have you succesfully booted any other non-windows OS on this machine?
No.

Quote:
Originally Posted by Envoy of Goats View Post
Are you sure you have your EFI/Bios setup to prioritize external storage over the windows instalation? Have you tried manually selecting the device to be booted from?
I am sure I have the USB prioritized over the windows installation. I have also manually selected to be booted from by using the boot overide feature in bios (if that's what you meant)

Quote:
Originally Posted by Envoy of Goats View Post
Did you allow rufus to verify it wrote .iso file correctly?
How to do that?

Quote:
Originally Posted by Envoy of Goats View Post
Have you tried a different USB stick?
Yes two USB sticks. exact same result.
 
Old 03-25-2016, 01:22 PM   #6
aviralgarg
LQ Newbie
 
Registered: Mar 2016
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
Live USB not booting in Windows 10 <-- not a proper evaluation of what is really going on.
Corrected, let me know if it is to be made even better.

Quote:
Originally Posted by BW-userx View Post
Because it does not boot up in Windows, it boots up before it even sees Windows, or accesses the Hard drive Windows is on. Knowing that bit of information should now change your way of looking at what the real problem could be in order to find out what the real problem really is.
I am trying to boot linux Live USB to boot, windows is botting up fine. Sorry, didn't make it clear earlier.

Quote:
Originally Posted by BW-userx View Post
Get a different Linux Live distro to try as well as what @Envoy of Goats suggested/asked of you.
I don't want any other distro

Quote:
Originally Posted by BW-userx View Post
Set BIOS to MBR boot or reset to defaults, save. make sure you're having the BIOS look at your USB Port first. try a different USB Port (should not matter) but if one is faulty. try the other one, just in case.
how to set BIOS to MBR boot? Also, only one USB port on this machine.

Quote:
Originally Posted by BW-userx View Post
slap it to show it who's boss then try it again.
HAHAHA but it didn't work

Quote:
Originally Posted by BW-userx View Post
Try looking into how old your system is, and see if their is a BIOS update out their for your BIOS to update that.
Recently purchased. Small company (Venturer) so I couldn't even find any information on any BIOS update available for this machine
 
Old 03-25-2016, 01:28 PM   #7
Teufel
Member
 
Registered: Apr 2012
Distribution: Gentoo
Posts: 510

Rep: Reputation: 120Reputation: 120
Apart from secure boot there are some other BIOS options that should be enabled
Did you activated CSM? Did you switched BIOS to legasy (non-UEFI) mode? Did you changed hard drives boot order to get USB as the first boot HDD?
When you've changed BIOS option it may require to save changes and reboot to get other options editable. I.e. if you disabled secure boot you may have to save it and reboot to get CSM option switchable (Initially it greyed as non-switchable)
 
Old 03-25-2016, 01:28 PM   #8
aviralgarg
LQ Newbie
 
Registered: Mar 2016
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
When you initially boot, you should see a message which is usually at the bottom of the screen when you see the manufacturer logo that tells you which key to press to enter setup. That is where you need to go to set the boot priority to access your usb first. These settings are differenet on different machines so posting some information on your hardware would be a good starting point.
Edited my question to give more details about hardware. Also, I did change the boot priority to access my USB first.
 
Old 03-25-2016, 01:56 PM   #9
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,132

Rep: Reputation: Disabled
Quote:
Originally Posted by aviralgarg View Post
Corrected, let me know if it is to be made even better.

I am trying to boot linux Live USB to boot, windows is botting up fine. Sorry, didn't make it clear earlier.
that it more to the true of it, yes.


Quote:
I don't want any other distro
It is for TESTING purposes. you are now in trouble shooting mode. you need to go though process of elimination until you find the offending "error"
Quote:
how to set BIOS to MBR boot? Also, only one USB port on this machine.

HAHAHA but it didn't work
All Home Computers have a BIOS.
Quote:
Recently purchased. Small company (Venturer) so I couldn't even find any information on any BIOS update available for this machine
that is why man invented the search engine one of them is called GOOGLE -- you'd be surprised at what information one can get on them now days.
 
Old 03-25-2016, 04:31 PM   #10
Envoy of Goats
LQ Newbie
 
Registered: Mar 2016
Distribution: Arch
Posts: 9

Rep: Reputation: Disabled
It has been touched on in a few posts, but the issue is probably with your Bios/UEFI settings.

When your computer is powered on you should be presented with a splash screen of the manufacturer's logo. On this screen a message will usually appear telling you you can press some key to edit your motherboard's settings. If there is no such message, use google to find which key/combination your motherboard uses. There are some motherboards that are locked down in such a way as to make it impossible to boot anything other than the windows that comes with the machine, but these are pretty rare.

Once inside the menu look for something regarding default boot order or boot overide if you just want to boot from a different device this one time.

If you still cannot get the machine to boot anything but windows, but are able to point the boot process at the USB stick then I would try a different distro just to make sure it isnt something about how Bodhi's bootloader is configured. Some EFI deviates from standards in significant ways which can cause normaly safe assumptions made by a default grub instalation to fail. I would try something like Ubuntu that is designed to run out of the box on as many devices as possible with no issues.

If you tried multiple USB sticks then you shouldn't have to worry about rufus writing incorectly. (For future reference, there is a checkbox in rufus that makes it verify that the data on the device is what rufus believes it wrote to the device.) I would also consider verifying that the ISO you downoaded is not corrupt, since if this is the case rufus has no way of knowing that something went wrong. There is plenty of information about how to do this online, but it might be faster to just redownload the ISO than to learn and implement the process of verifying the ISO.
 
Old 03-25-2016, 04:36 PM   #11
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Did you do an md5 checksum on the downloaded Bodhi iso to verify integrity?
When you ran the rufus software, did it indicate it completed successfully?
Do you have another computer available to try booting the flash drive to eliminate that as a problem?

Often, the flash drive is shown as an option under hard drives in the BIOS. If you set it to boot the usb first and you are still booting windows on the hard drive, you changed the wrong setting. Take a better look at the options in the BIOS.
 
Old 03-26-2016, 05:31 PM   #12
aviralgarg
LQ Newbie
 
Registered: Mar 2016
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Teufel View Post
Apart from secure boot there are some other BIOS options that should be enabled
Did you activated CSM? Did you switched BIOS to legasy (non-UEFI) mode? Did you changed hard drives boot order to get USB as the first boot HDD?
When you've changed BIOS option it may require to save changes and reboot to get other options editable. I.e. if you disabled secure boot you may have to save it and reboot to get CSM option switchable (Initially it greyed as non-switchable)
How to activate CSM? I did switch BIOS to legacy mode. I did change the boot order. I can't even find the CSM option in the blue screen (BIOS screen?)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Live USB not booting in Windows 10 aviralgarg Linux - Laptop and Netbook 6 04-12-2016 06:09 PM
[SOLVED] Booting live USB/DVD on Aspire 5560 john_erlandsson Linux - Laptop and Netbook 2 04-14-2015 03:28 PM
Problems booting LG3D from live USB 12padams Linux - General 1 05-16-2013 05:52 PM
[SOLVED] Booting various live cd from an USB Lantius Linux - General 13 12-03-2009 03:03 PM
Fedora 11 Live USB linux - Booting freezes.... kamaleshpradhan LinuxQuestions.org Member Intro 0 08-06-2009 02:33 PM


All times are GMT -5. The time now is 12:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration