LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2012, 01:38 PM   #1
Jacob843
LQ Newbie
 
Registered: Aug 2012
Posts: 9

Rep: Reputation: Disabled
Exclamation Bind9 Errors after reboot.


Hello! My name is Jacob and I recently just setup my DNS servers. Last night, I successfully setup my two DNS servers, but then I shutdown the Ubuntu Lucid(1) and turned it back on today. I tried to start BIND9 from command line, like usual, but it failed. I then went into webmin and found out my problem:

Quote:
The following errors were found in the BIND configuration file /etc/bind/named.conf or referenced zone files ..

/etc/bind/named.conf.options:19: unknown option '68.37.86.61'
What did I do! I really need some help guys! Thanks!


1:
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
 
Old 08-28-2012, 02:36 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,870
Blog Entries: 14

Rep: Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112
If you open the file /etc/bind/named.conf.options with your favorite editor (e.g. vim, nano or emacs) what does it have a line 19? Do you see the IP it complains about at that line or just above or below it?

It seems to be saying you put an option in with that IP that isn't valid. Perhaps you meant to have it as part of another line but it ended up on its own line by accident? Without seeing the options file its hard to guess.
 
Old 08-28-2012, 02:59 PM   #3
Jacob843
LQ Newbie
 
Registered: Aug 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Question

Quote:
Originally Posted by MensaWater View Post
If you open the file /etc/bind/named.conf.options with your favorite editor (e.g. vim, nano or emacs) what does it have a line 19? Do you see the IP it complains about at that line or just above or below it?

It seems to be saying you put an option in with that IP that isn't valid. Perhaps you meant to have it as part of another line but it ended up on its own line by accident? Without seeing the options file its hard to guess.
I configured it all in Webmin, which was fine until I rebooted the system.

This is my config file (named.conf.options):

Quote:
options {
directory "/var/cache/bind";

// If there is a firewall between you and nameservers you want
// to talk to, you may need to fix the firewall to allow multiple
// ports to talk. See http://www.kb.cert.org/vuls/id/800113

// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.

// forwarders {
// 0.0.0.0;
// };

auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };
68.37.86.61;
};

Thanks!
 
Old 08-28-2012, 03:25 PM   #4
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,870
Blog Entries: 14

Rep: Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112
I don't use Webmin so can't tell why/how it messed it up but the error is complaining about this line:

68.37.86.61;

All by itself on a line in options an IP address or range has no meaning. You can resolve the error you saw by commenting out that line. Also the address above is an IPV4 format address so it wouldn't be related to listen-on-v6 statement. (You're specifying "any" for that which means any interface that is IPV6.)

It may be you intended to put in a standard listen-on in format:
listen-on { 68.37.86.61; };
 
Old 08-28-2012, 03:34 PM   #5
Jacob843
LQ Newbie
 
Registered: Aug 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
This is my new config file:

Quote:
options {
directory "/var/cache/bind";

// If there is a firewall between you and nameservers you want
// to talk to, you may need to fix the firewall to allow multiple
// ports to talk. See http://www.kb.cert.org/vuls/id/800113

// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.

// forwarders {
// 0.0.0.0;
// };

auth-nxdomain no; # conform to RFC1035
listen-on { 68.37.86.61; };
};

When I check the error log I get these:

Quote:
zone imposinghosting.com/IN: NS 'ns2.imposinghosting.com' has no address records (A or AAAA)
zone imposinghosting.com/IN: not loaded due to errors.
_default/imposinghosting.com/IN: bad zone
zone admin.imposinghosting.com/IN: ns2.admin.imposinghosting.com/NS 'ns2.imposinghosting.com.admin.imposinghosting.com' has no address records (A or AAAA)
I am trying to fix up the last error now. I will report back soon. Ideas?
 
Old 08-28-2012, 03:42 PM   #6
Jacob843
LQ Newbie
 
Registered: Aug 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
EDIT! I think I fixed it! I just added ns2.imposinghosting.com to the Address list with my IP and it started up fine. I need to wait about an hour for it to catch up; I will report back soon!
 
Old 08-28-2012, 09:58 PM   #7
Jacob843
LQ Newbie
 
Registered: Aug 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Erm. Now my nameservers won't resolve to anything. It is like they aren't even there...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SATA Error -> sys hard reboot on Suse 11.3. board+hdd changed, still errors. chh4l123 Linux - Hardware 7 02-01-2011 10:34 AM
Random errors after reboot teufelhund Linux - Desktop 3 04-11-2007 04:54 PM
FC4 hangs after reboot. Is it possible to manually reboot to find problem hathmann Fedora 5 08-13-2006 03:57 AM
Errors, Errors, and more Errors (KDE 3.4.x GUI Errors) Dralnu Linux - Software 2 05-13-2006 08:30 AM
No keyboard/mouse after reboot. Requires second reboot to work. rottie Linux - Hardware 6 01-16-2006 05:04 AM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration