LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-08-2005, 10:24 AM   #1
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
Alternative to disk quota's


Hi all,

I have a gentoo linux server at home, it runs Proftpd, apache2 etc.
but i want to give some users limited space to have on their folder.
(so their home map they are jailed in can't be greater than 2 gb's)

i found out about disk quota's. but if i'm correct i need to have a difirent partition with its own filesystem in order to use disk quota's?

so i'm asking if anyone knows an alternative so i can get this working?

thanks in advance.

greets Hum4ngus.
 
Old 09-08-2005, 10:38 AM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
No, you should be able to add quotas to an existing filesystem. HowTo.
 
Old 09-08-2005, 11:48 AM   #3
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
Ahh thnx.

but, i can't seem to get it working.
i already emerged quota-tools and then rebuiled my kernel so it supports quota's(and copied bzimage to /boot and edited /boot/grub/grub.conf), then i did rc-update add quota default.
and edited Fstab, this is what it looks like:

/dev/hda1 /boot ext2 suid,dev,noatime,exec,noauto 0 1
/dev/hda3 / ReiserFS noatime,usrquota 0 0
/dev/hda2 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0

but for example, when i do this "edquota -u testftp" it sais

No filesystems with quota detected.

and when i do this:

# /usr/sbin/quotacheck -avug
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.

hope you can help me
 
Old 09-08-2005, 12:39 PM   #4
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Did you START quota in addition to adding it to the default runlevel? (/etc/init.d/quota start)
 
Old 09-08-2005, 12:45 PM   #5
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
yes it does start, it prints out this at boot:

* Checking quota's (may take a while)...
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
* Starting quota [ok]
 
Old 09-08-2005, 12:52 PM   #6
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
You may, though I'm not sure, need to touch /aquota.user and restart the quota service.
 
Old 09-08-2005, 01:13 PM   #7
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
hmm, That file is empty. i don't know what to do with it.
 
Old 09-08-2005, 01:24 PM   #8
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
All it should need to do is exist.
 
Old 09-08-2005, 03:18 PM   #9
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
yes it does exist. but when i restart quota is prints out:

* Stopping quota... [ ok ]
* Checking quotas (may take a while)...
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option. [ ok ]
* Starting quota... [ ok ]

so i think it has something to do with quota not being enabled on the filesystem?
 
Old 09-08-2005, 03:22 PM   #10
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
What is the output of 'mount'?
 
Old 09-08-2005, 03:37 PM   #11
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
I can't see any errors at boot, i did try this.

# umount /dev/hda3
umount: /: device is busy
umount: /: device is busy
# mount /dev/hda3 /
mount: /dev/hda3 already mounted or / busy
mount: according to mtab, /dev/hda3 is already mounted on /

or did you mean something else?
 
Old 09-08-2005, 04:42 PM   #12
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
just 'mount' by itself. It will show the state of currently mounted filesystems.
 
Old 09-08-2005, 05:10 PM   #13
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
oh ok, here it is

/dev/hda3 on / type ReiserFS (rw,noatime,usrquota)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev type ramfs (rw)
none on /dev/pts type devpts (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/bus/usb type usbfs (rw)
 
Old 09-08-2005, 05:19 PM   #14
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Hrrm, as an interesting thought, you did enable quota support for reiserfs, right?
 
Old 09-08-2005, 05:32 PM   #15
Hum4ngus
LQ Newbie
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
yes it is enabled in the kernel, here's an image

http://humster.nl/public/quota.jpg
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quota's jpsekhar Linux - Hardware 1 10-18-2005 05:53 AM
IE alternative jkassemi Linux - Software 12 04-11-2005 11:35 PM
No Alternative to MS? nuka_t General 6 01-14-2005 01:32 PM
disk quota's Snerkel Linux - Software 1 10-27-2004 09:26 PM
du alternative plisken Linux - General 3 07-09-2003 11:28 PM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration