LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2015, 03:51 PM   #1
allagar
LQ Newbie
 
Registered: May 2014
Posts: 7

Rep: Reputation: Disabled
after rebuild of tslib Qt failed with error ts_config() 'no such file or dir'


I downloaded tslib-1.1.tar.gz and configured to cross compiled for my ARM target machine.

Was able to build and make install on my Ubuntu host machine successfully. On my taget machine I copied created a backup of my original libts-1.0.so.0.0.0 and SFTP'd from my host the version I built to my target machine and over wrote current libts-1.0.so.0.0.0 to keep the links.
reboot my taget and now get

QWSTslibMouseHandlerPrivate: ts_config() failed with error: 'No such file or directory'
Please check your tslib installation!

running ldd on the taget against the backup (.bu version) and new versions shows the same dependancies.

root@at91sam9m10g45ek:~# ./ldd /usr/lib/libts-1.0.so.0.0.0
libdl.so.2 => /lib/libdl.so.2 (0x4000b000)
libc.so.6 => /lib/libc.so.6 (0x40016000)
/lib/ld-linux.so.3 (0x2a000000)
root@at91sam9m10g45ek:~# ./ldd /usr/lib/libts-1.0.so.0.0.0.bu
libdl.so.2 => /lib/libdl.so.2 (0x4000b000)
libc.so.6 => /lib/libc.so.6 (0x40016000)
/lib/ld-linux.so.3 (0x2a000000)

Using nm verified ts_config() existed in the new version.

Any suggestions why I am getting the error?
 
Old 02-05-2015, 10:21 AM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,614

Rep: Reputation: 703Reputation: 703Reputation: 703Reputation: 703Reputation: 703Reputation: 703Reputation: 703
It's not printing the name of the config file that it can't find?
 
Old 02-05-2015, 01:56 PM   #3
allagar
LQ Newbie
 
Registered: May 2014
Posts: 7

Original Poster
Rep: Reputation: Disabled
What I have found is that if I "export set TSLIB_PLUGINDIR=/usr/lib/ts" then my build of libts-1.0.so.0.0.0 does work. Question is how does one set ./configure options to provide this when building libts-1.0.so.0.0? The original version that was installed did not need the environment variable so I assume it must have been configured as part of the build.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bacula-dir not starting ; Unit bacula-dir.service entered failed state zalgo Linux - Software 2 04-09-2015 03:32 AM
Server won't boot with compiled kernel: switchroot: mount failed: No such file or dir abefroman Linux - Server 8 03-04-2013 11:09 AM
Can you force tslib to reload pointercal file? gsinde Linux - Software 0 10-05-2011 10:06 AM
distcc ERROR: compile dir.c on <server ip> failed DragonM15 Linux - Software 1 01-08-2009 04:24 PM
[Emerge xf86-video-vesa failed] :no such file or dir ade05fr Linux - Distributions 2 01-08-2009 08:40 AM


All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration