LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2009, 07:56 AM   #1
smaj84_1
Member
 
Registered: Jul 2009
Location: Pakistan
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
About Configuring PHP


Hi to all Friends..

While I m configuring the php I received this message when I tried to start apache...

------------------------------------------------------------------------------------------------------------------------------------------------------

[root@localhost bin]# ./apachectl start
httpd: Syntax error on line 53 of /usr/local/mansoor/apache/conf/httpd.conf: Cannot load /usr/local/mansoor/apache/modules/libphp5.so into server: /usr/local/mansoor/apache/modules/libphp5.so: undefined symbol: ap_hook_pre_config
------------------------------------------------------------------------------------------------------------------------------------------------------

guide me plz..I have searched google but didnt find the solution..
 
Old 07-28-2009, 08:33 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You do not start apache this way. Either you do this

apachectl start

or

/etc/init.d/httpd start or /etc/init.d/apache2 start depending on your distribution.
 
Old 07-28-2009, 08:44 AM   #3
smaj84_1
Member
 
Registered: Jul 2009
Location: Pakistan
Distribution: Fedora
Posts: 71

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
You do not start apache this way. Either you do this

apachectl start

or

/etc/init.d/httpd start or /etc/init.d/apache2 start depending on your distribution.
By your mentioned method apache started but that was not THAT apache which i want to run...i want to run /usr/local/mansoor/apache/bin..and by ur method /usr/sbin/httpd started

because I actually want to run PHP so plz guide me y the following error comes

[root@localhost bin]# ./apachectl start
httpd: Syntax error on line 53 of /usr/local/mansoor/apache/conf/httpd.conf: Cannot load /usr/local/mansoor/apache/modules/libphp5.so into server: /usr/local/mansoor/apache/modules/libphp5.so: undefined symbol: ap_hook_pre_config
 
Old 07-28-2009, 08:57 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
That looks to me as if I will not be able to decode it as it shows error in file somewhere in mansoor directory that I can not have in my machine.
 
Old 07-28-2009, 09:23 AM   #5
smaj84_1
Member
 
Registered: Jul 2009
Location: Pakistan
Distribution: Fedora
Posts: 71

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
That looks to me as if I will not be able to decode it as it shows error in file somewhere in mansoor directory that I can not have in my machine.
Here are the output of mansoor directory
----------------------------------------------------------------------------------------------------------------------------
[root@localhost mansoor]# ls
apache httpd-2.2.11 httpd-2.2.11.tar.gz php php-5.3.0 php-5.3.0.tar.gz
[root@localhost mansoor]# cd apache
[root@localhost apache]# ls
bin cgi-bin error icons lib man modules
build conf htdocs include logs manual php5
[root@localhost apache]#
----------------------------------------------------------------------------------------------------------------------------
now tell me where u think error IS..?
 
Old 07-28-2009, 10:02 AM   #6
smaj84_1
Member
 
Registered: Jul 2009
Location: Pakistan
Distribution: Fedora
Posts: 71

Original Poster
Rep: Reputation: 15
I think I didnt ask about the rocket science...Y senior members or other LINUX GURUS are not replying? Is this too hard for them?? If this is true then they should stop using LINUX as they dont know even the basics...
 
0 members found this post helpful.
Old 07-28-2009, 10:14 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by smaj84_1 View Post
I think I didnt ask about the rocket science...Y senior members or other LINUX GURUS are not replying? Is this too hard for them?? If this is true then they should stop using LINUX as they dont know even the basics...
Perhaps people have better things to do than reply to your threads? This is a volunteer site, so you can't expect people to help you on demand. Also, it's "Linux", not "LINUX".
 
Old 07-28-2009, 10:20 AM   #8
smaj84_1
Member
 
Registered: Jul 2009
Location: Pakistan
Distribution: Fedora
Posts: 71

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Nylex View Post
Perhaps people have better things to do than reply to your threads? This is a volunteer site, so you can't expect people to help you on demand. Also, it's "Linux", not "LINUX".

Oh great then "darn!!" <<profanity removed>>..

Last edited by pixellany; 07-28-2009 at 01:55 PM. Reason: de-profanitized
 
Old 07-28-2009, 11:43 AM   #9
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
I think you are looking for a piece of cake .. which Linux is absolutely not!..

You should have read the /docs file in your mansoor folder.. and I think you need to configure your apache from conf folder before running it..

I have never heard running PHP from a .tar file. any ways.. use a package manager to install PHP with apache.


Linux means Do it your self.

and mind your language.. I hope as of this writing a moderator has kicked you out ..

Cheers!!
 
Old 07-28-2009, 02:04 PM   #10
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
smaj84_1;
Watch the language please---consider this an informal warning.

Quote:
.Y senior members or other LINUX GURUS are not replying? Is this too hard for them?? If this is true then they should stop using LINUX
If someone has knowledge of various subtleties of Linux, how does that imply that they are sitting at their desk waiting for your questions? I, for example, am on the forum in chunks of time anywhere from 10 minutes to 2 hours. I will very often look for things that I can answer without doing any tests, research, etc. Then--when I have time--I will pick an interesting problem to dig into more deeply. Some days I'll read for an hour without answering anything.

The reason that you get any help at all is simply the number of people here---statistically, someone usually gets to you, but it can take a day or more.

The best way to get help here is:
Clear questions
Patience
Follow up--answer questions
Courtesy
 
Old 07-28-2009, 02:27 PM   #11
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,971
Blog Entries: 1

Rep: Reputation: 208Reputation: 208Reputation: 208
Quote:
Originally Posted by smaj84_1 View Post
Oh great then "darn!!" <<profanity removed>>..
I would help...but you're being rude so I choose not to now...

Good Luck...with that attitude; you'll need it!

-C
 
Old 07-29-2009, 02:24 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Mind your language man....we are a group of people who volunteer our time. I have a lot of better work to do than answer your questions. Anyhow...

This is what I can figure out from what you have posted. Look into it. This is what help I can extend with this attitude of yours. And anyhow I am not yelling at your face that I am a Linux guru. Keep in mind for the sake I am NOT. And no I am NOT going to give up using Linux.

Look what you can figure out from this.

Quote:
httpd: Syntax error on line 53 of /usr/local/mansoor/apache/conf/httpd.conf: Cannot load /usr/local/mansoor/apache/modules/libphp5.so into server: /usr/local/mansoor/apache/modules/libphp5.so: undefined symbol: ap_hook_pre_config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
re-configuring PHP airswit Programming 5 02-05-2006 08:28 PM
Configuring PHP linux_pioneer Linux - Software 3 01-21-2005 11:19 AM
configuring php fayax1 Linux - General 4 11-02-2004 03:03 PM
configuring php haobaba1 Linux - Networking 1 07-28-2003 03:43 AM
re-configuring PHP linoob Linux - General 1 07-02-2003 11:39 PM


All times are GMT -5. The time now is 02:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration