LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-22-2010, 10:34 AM   #1
zrnaqvi
LQ Newbie
 
Registered: Nov 2009
Posts: 12

Rep: Reputation: 0
[FIXED] having trouble adding Clariion SAN disks to RHEL 5U4 box


I am trying to connect some Clariion SAN LUNs to a RHEL 5U4 box, but not having much luck. Is there any Clariion specific configuration I need to do on the Linux box. I have powerpath installed but it locks up the box if I run it with the Clariion disk attached, without the Clariion powerpath is fine.
Also I have some Symmetrix SAN drives attached to this box and they seem to be fine, no issues with that.
Any help or pointers to EMC recommendations etc. would be great help.

thanks.

Last edited by zrnaqvi; 01-23-2010 at 08:51 PM.
 
Old 01-22-2010, 11:44 PM   #2
TBC Cosmo
Member
 
Registered: Feb 2004
Location: NY
Distribution: Fedora 10, CentOS 5.4, Debian 5 Sparc64
Posts: 355

Rep: Reputation: 43
By no luck, do you mean that there are no san luns in fdisk -l output? How about any DGC labeled devices in /proc/scsi/scsi?

The EMC host connectivity guide on powerlink will help you set up the host. If you have more than one path to the LUNs, you might try native Linux multipath as explained in that guide. Current dm-multipath provides the clariion hardware handler. f you use multipath, you may need to blacklist the symmetrix LUNS. But I've never mixed those LUNS so it's a guess.

Now that I think more on it, isn't the symmetrix an active/active controller? I would certainly consult with the compat matrix and EMC. I'm not sure how the different failover modes will interop.

Last edited by TBC Cosmo; 01-23-2010 at 12:05 AM.
 
1 members found this post helpful.
Old 01-23-2010, 08:51 PM   #3
zrnaqvi
LQ Newbie
 
Registered: Nov 2009
Posts: 12

Original Poster
Rep: Reputation: 0
the problem is fixed. Turns out you need PowerPath 5.3 or newer for RHEL5. So an upgrade of PP and disconnecting the Symmetrix drives fixed the issue.

Last edited by zrnaqvi; 01-23-2010 at 08:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Buffer I/O errors on SAN disks Phil Craike Linux - General 1 01-11-2010 08:27 PM
Difficulty booting from replicated Boot-from-SAN (CLARiiON) LUN with RHEL4u7 nosoop4u Linux - Software 0 08-14-2009 03:51 PM
SAN disks not detecting ravikumar_c25 Red Hat 1 08-03-2009 03:25 PM
How to install a DAS / SAN box on RHEL 4 nimdasmetsys Linux - Enterprise 1 09-21-2006 11:24 AM
Adding RHEL to a Windows XP machine: Having trouble getting ISO disk recognized kanncro Linux - General 5 01-30-2006 06:22 PM


All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration