LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-06-2004, 09:05 AM   #1
ravilohot
LQ Newbie
 
Registered: Sep 2004
Location: NASIK
Posts: 6

Rep: Reputation: 0
windows 98 m/c ping to ip address of red hat server but fails to ping hostname


Hi all

I am facing a problem will connecting to red hat linux , i have assign and local ip for the server 192.168.4.1 & hostname as precise.nasik.com
I have a network which have m/c of multiple windows os e.g win95/98 /xp /2000. I have modified the host file on all the os and added the ip address and hostname in it , i havent enable dns on any machine.
now for the problem ....
i can ping the red hat server through all windows os
i can ping for the hostname only through windows XP
WIN 95/98/2000 DOES NOT PING WHEN I TYPE HOSTNAME precise.
as my application oracle need domain name to be typed in IE to get the access , my windows 95 /98 machine should ping by hostname
the error message i get is also different on different system with same OS.
on max windows 98 machines i get error as unknown host ,
in one machine i get reply but thro, the same machines ip .i.e. if i ping precise from 192.168.4.142 . i get reply successfully but not from 192.168.4.1 but from 192.168.4.142.

i tried applying all the patches of windows 98 available on microsoft site , i also upgraded the IE to 6 but in vain ,

I personally think , the problem is between red hat server and windows 95/98 . windows 98 is unable to resolve the name of the linux server .
Also i cant down the server , and my graphics screen is in hang mode . so i have to try everthing in dos mode ,

as i am not facing any problem with XP i think allthe settings on server are ok , but that something which xp has and windows 98 doesn't , which , Enable XP to resolve the Linux Server name is missing , i finding that link ,

please help

sorry for being too descriptive but that allows to all to understand my problem clearly .

Thankx in advance

raj
 
Old 09-06-2004, 09:56 AM   #2
bruj3w
Member
 
Registered: Mar 2004
Location: england
Distribution: slackware
Posts: 164

Rep: Reputation: 30
this is boardering on being a windows question :>

a cheap and dirty way would be to add an entry to your \sysroot\system32\drivers\etc\hosts file on your win9x machine that points to your redhat box.

ipofyourredhatbox youredhatmachinename
192.168.1.1 local.server

for example should do it.
 
Old 09-07-2004, 05:57 AM   #3
ravilohot
LQ Newbie
 
Registered: Sep 2004
Location: NASIK
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bruj3w
this is boardering on being a windows question :>

a cheap and dirty way would be to add an entry to your \sysroot\system32\drivers\etc\hosts file on your win9x machine that points to your redhat box.

ipofyourredhatbox youredhatmachinename
192.168.1.1 local.server

for example should do it.

well in win9x the hosts file is in c:\windows dir. and i have already entered the ip and machinename in it pointing towards the red hat box. but still it does not works
funny no , but its true , i get reply from the red hat box when i ping for its ip address and get unknown host reply when i ping for its hostmane ( machine name )

raj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't ping domain name, but can ping ip address dtra Linux - Networking 4 04-03-2013 06:02 PM
Strange Ping Issue - Can't ping localhost but can ping others on LAN code_slinger Linux - Networking 13 03-17-2011 03:47 AM
can't ping the server itself by ip or hostname h_h_q Linux - General 1 01-12-2005 02:24 AM
Red Hat - Browser does not fetch website but ping works learningkid Red Hat 3 09-13-2004 12:34 AM
Can't ping windows machines by hostname explorer Linux - Networking 10 03-06-2003 01:44 PM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration