LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-09-2005, 11:06 AM   #1
arrgh95
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Rep: Reputation: 0
Windows 2000/XP and RedHat Linux Samba Server


I have a small peer-to-peer network that uses a Samba server to serve
files. There is little to no security with the file server. Currently connect to this server is a Win95 machine, 2 Win98SE machines, 2 Win2000PRO machines, and 3 WinXPPro machines. One of the Win2000 and one of the WinXP machines will only read files on the server as READ-ONLY if they have not created them. However, the files that they do create are READ-ONLY for all of the other machines. This is very annoying since it is defeating the purpose of sharing the files. Has anyone come accross this problem? Is this a Samba issue or a Windows issue?
 
Old 08-09-2005, 11:23 AM   #2
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
what does your smb.conf look like?
 
Old 08-09-2005, 12:25 PM   #3
mheymann
LQ Newbie
 
Registered: Jun 2005
Location: Pittsburgh
Distribution: Red Hat ES
Posts: 18

Rep: Reputation: 0
Try using the options

create mask = 0777
directory mask = 0777

on the shares. This wiil set the folder and file permissions for any
new folders and files to be accessable to all
 
Old 08-09-2005, 02:00 PM   #4
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
yeah, you can put those in fstab in the options bit

h
 
Old 08-09-2005, 03:08 PM   #5
arrgh95
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Here is the smb.conf

[global]
path = /usr/server
smb passwd file = /etc/samba/smbpasswd
hide dot files = no
passwd program = /usr/bin/passwd %u
force directory mode = 755
pam password change = yes
printing = lprng
dns proxy = no
force create mode = 755
encrypt passwords = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
wins support = true
max log size = 0
obey pam restrictions = yes
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
writeable = yes
security = share
unix password sync = Yes
server string = Samba Server
workgroup = WORKGROUP
map archive = no
netbios name = Server
log file = /var/log/samba/%m.log
delete readonly = yes
load printers = yes
os level = 20
public = yes
locking = no
default case = upper
nt acl support = no

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes

[server]
comment = FILE SERVER
oplocks = no
force directory mode = 000
mangle case = yes
force create mode = 000
write list = nobody
 
Old 08-09-2005, 03:28 PM   #6
mheymann
LQ Newbie
 
Registered: Jun 2005
Location: Pittsburgh
Distribution: Red Hat ES
Posts: 18

Rep: Reputation: 0
Change the [server] share from this

[server]
comment = FILE SERVER
oplocks = no
force directory mode = 000
mangle case = yes
force create mode = 000
write list = nobody

to this

[server]
comment = FILE SERVER
oplocks = no
directory mask = 0777
mangle case = yes
create mask = 0777
read only = no
 
Old 08-10-2005, 01:22 PM   #7
arrgh95
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I had a chance to implement those changes to the smb.conf. However, my problem remains unresolved. I now have an access denied when I go to save in a folder on the server that was created by another machine yesterday. But, I can save in a directory that was created a long time ago.
 
Old 08-10-2005, 03:14 PM   #8
mheymann
LQ Newbie
 
Registered: Jun 2005
Location: Pittsburgh
Distribution: Red Hat ES
Posts: 18

Rep: Reputation: 0
Try this smb.conf file just make sure you rename the other smb.conf file to something like
smb.bak or smb.conf.bak to have a backup copy of your origional file.

I took the your smb.conf file and made some changes to it and deleted some
config options that probably are not necessary but you may be wanting options
that I have not considered.


[global]
workgroup = WORKGROUP
server string = Samba Server
netbios name = Server
security = share
passwd program = /usr/bin/passwd %u
smb passwd file = /etc/samba/smbpasswd
hide dot files = no
pam password change = yes
obey pam restrictions = yes
unix password sync = Yes
encrypt passwords = yes
os level = 20
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
max log size = 0
log file = /var/log/samba/%m.log
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
printing = lprng
printcap name = /etc/printcap
load printers = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes

[servershare]
comment = FILE SERVER
path = /usr/servershare
directory mask = 0777
create mask = 0777
read only = no

Try this file you should be able to copy and paste the text directly from this document
I setup a Samba server which has about 20 people who access the same single share
and this is our smb.conf file

[global]
workgroup = drafting
server string = samba
log file = /var/log/samba/%m.log
max log size = 100
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain master = yes
preferred master = yes
password server = None
guest ok = yes
dns proxy = no
username map = /etc/samba/smbusers


#======== Share Definitions ==================
[homes]
comment = Home Directories
browseable = no
writeable = yes
create mask = 0777
directory mask = 0777
force create mode = 0777
force directory mode = 0777
force group = drafting

[Inventor]
path = /Inventor
guest ok = yes
writeable = yes
create mask = 0777
directory mask = 0777
force create mode = 0777
force directory mode = 0777
force group = drafting


All of the users on the Linux system are part of the same group (drafting)
and really don't even use the [homes] share the Inventor share is the only
share need. All of the community files are stored in there.
 
Old 08-17-2005, 03:26 PM   #9
arrgh95
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry about the delay...

I tried modifying the smb.conf as you suggested and still the same results. I have done more investigation into the server and I am finding that the problem is related to ownership of the files and directories. I am puzzled by this as the most recent 2 machines logon to the server and are registered as different users. When these machines create something then they, and they alone are the ones that can edit whatever was created. I have very limited knowledge of Linux, or for that matter, the nuances of networking. But, I have the impression that this is an issue with how windows is connecting to the server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba¦server¦with¦windows¦2000¦clients dabash Linux - Networking 3 08-23-2005 02:08 AM
samba linux redhat to Windows 2000 Konqueror problem E-Rick Linux - Networking 0 10-20-2004 10:03 AM
Samba, RedHat 7.2, Windows 2000 bananaman Linux - Newbie 7 04-16-2003 11:39 PM
client Linux Redhat 8.0 cannot use Windows 2000 Printer Server tthai01 Linux - Networking 0 12-10-2002 04:49 AM
Samba 2.2.3 in RedHat 7.3 - problem with Windows 98,XP,2000 Wild-A Linux - Software 2 12-04-2002 07:52 AM


All times are GMT -5. The time now is 08:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration